Windows Vista Home Premium (SP1) 32bit

#1
Im running a DELL E520 (Pentium D CPU 2.8ghz 2.79ghz)(5gigs RAM)

I recently had my computer shipped to me from Boston to Texas. Upon packing the computer ran fine. When I recieved my computer and I turned it on I got a bluescreen "Dumping physical memory..." goes to a 100% and halted. Well I restarted the PC and got to the windows login screen, Logged in and it hung at a black screen with a curser. Rebooted into safe mode. Success. I put a few programs on the comuter via my laptop and CD burner. TrojanScanner, Malwarebytes, CCleaner. All of which initially folund errors and repaired them. Rebooted the PC. Still cant log into windows normally. Rebooted PC in safe mode w/ networking. Success. Researched my issue and found someone that turned off all the windows servieces in safe mode and rebooted into Windows noramlly. I did this successfully. So I have no idea first of all which service it might be or if it even is one. I then atcivated all "Microsoft Corp" services only. When I tried to reboot into Windows normally it hung after the login at a blackscreen with a curser. I am able to bring up the task manager via "ctrl alt delete" and log off or restart and such. Back in safe mode in the even manager I have a whole list of Errors.

I dont know if the event ID is local to the PC or not but here is a list:

7026:
The following boot-start or system-start driver(s) failed to load:
AvgLdx86
AvgMfx86
spldr
tclondrv

7001:
The Windows Image Acquisition (WIA) service depends on the Shell Hardware Detection service which failed to start because of the following error:
The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

The IPsec Policy Agent service depends on the Base Filtering Engine service which failed to start because of the following error:
The system cannot find the file specified.

The msfwsvc service depends on the Base Filtering Engine service which failed to start because of the following error:
The system cannot find the file specified.

The Windows Firewall service depends on the Base Filtering Engine service which failed to start because of the following error:
The system cannot find the file specified.

The Computer Browser service depends on the Server service which failed to start because of the following error:
The dependency service or group failed to start.

The WLAN AutoConfig service depends on the Extensible Authentication Protocol service which failed to start because of the following error:
The dependency service or group failed to start.

The Extensible Authentication Protocol service depends on the CNG Key Isolation service which failed to start because of the following error:
The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

7023:
The Base Filtering Engine service terminated with the following error:
The system cannot find the file specified.

10005:
DCOM got error "1084" attempting to start the service WSearch with arguments "" in order to run the server:
{9E175B6D-F52A-11D8-B9A5-505054503030}

DCOM got error "1084" attempting to start the service WSearch with arguments "" in order to run the server:
{7D096C5F-AC08-4F1F-BEB7-5C22C517CE39}

DCOM got error "1068" attempting to start the service fdPHost with arguments "" in order to run the server:
{145B4335-FE2A-4927-A040-7C35AD3180EF}

DCOM got error "1084" attempting to start the service EventSystem with arguments "" in order to run the server:
{1BE1F766-5536-11D1-B726-00C04FB926AF}

So, I have tried the windows vista repair CD, I get an error.
Im lost and need help.