Windows Vista MBR repair failed

#1
Hi all,
After the upgrade from Ubuntu 9.10 to 10.4 (in another partition of the same hard drive) I'm not able to boot on my Windows Vista any more. It is most likely due to my fault during installation, since I ask to overwrite with GRUB also Windows partition's MBR Anyway I was not able to fix it until now.
I tried to use "bootrec" from Vista recovery disc but /fixboot fails. Here is the output:
Code:
BootRec /fixmbr
The operation completed successfully.
BootRec  /fixboot
The volume does not contain a recognized file system.
Please  make sure that all required file system drives are loaded and  that the  volume is not corrupted.
I don't know if this is because it's not applying it to the right partition: Let's say the target volume is C: and target partition is Partition 2. How is the right sintax?
Unfortunately my PC didn't come with the installation DVD, thus I've taken the Recovery CD from this website and I don't have "bootsect" utility.
I don't have another Windows running at the moment hence EasyBCD is neither an option.
Should I try with the "/rebuildbcd" option for bootrec?
I followed the instruction in
Recovering the Vista Bootloader from the DVD - NeoSmart Technologies Wiki
but in Step 3 and 4 "bootsect" is needed.
Do you have any suggestion?
Thank you

P.S. As a last solution, would a Vista reinstallation solve the MBR problem or not?
 

mqudsi

Mostly Harmless
Staff member
#2
What's happened is that the active partition is no longer the Windows partition. Use diskpart from the command-line to set the Windows partition as active, then try that again.

You can try using our WIndows 7 recovery discs instead, as they have a copy of bootsect.exe
 
#3
Thank you, I've tried it but I didn't succeed.
This is what I've done in diskpart:

Code:
list disk
select disk 0
list partition
select partition 2
active
exit
However, if i enter diskpart again the partition is no more selected, thus I don't know if this setting is kept after exiting diskpart. How can I assess it?
 

mqudsi

Mostly Harmless
Staff member
#4
You need to restart for the changes to take effect. Disk Part doesn't let you view what is currently the active partition.