Windows will only boot from USB drive, repair/recovery disk's don't work, OS is MIA

Machine in question is a Sony Vaio running 64-bit Windows 7. My apologies as I am both an extreme novice and fairly sure this issue has been resolved in other threads, but none of the solutions I've found and tried have been successful. My neighbor told me he was having issues with his laptop so I, assuming that with google at my disposal I could fix most anything, offered to try to take care of it. When I received said laptop it failed to boot, stopping almost immediately upon start up to show a black screen with only a flashing cursor, and neither of the Window's repair disks I tried were able to help showing an error code that many others reported seeing when using their own repair disks. After some research I chose to make a bootable usb drive loaded with the recovery info/image iso which eventually enabled me to successfully boot and run Windows. As a precaution I downloaded Avast! which I used to do a thorough scan, finding and deleting/repairing many trojan and/or corrupt files, and attempted to boot the laptop from the hdd. Before trying to boot from the hdd I removed the usb drive, entered BIOS setup, disabled booting from external devices (which I had earlier enabled to use the bootable usb), and switched the hdd back to the first slot of the boot process, which returned the laptop to it's original black screen with flashing cursor upon attempting to boot. After more research I decided to change the boot order again and use the usb drive to boot windows so that I could download EasyBCD to create a partition on the hdd and load it with the recovery iso. When I again tried to boot from the hdd I received an error message saying no OS was found on the drive. I have since tried fixing/rewriting the MBR, gone through all of the windows repair/recovery options, and attempted to boot from every partition currently available in the hdd. I'm far from proficient when dealing with these issues, but I have a hard time believing that the only solution left is to back up all of the data and restore the hdd to factory defaults. Again I apologize for being a complete novice but if anyone can help with this, or even point me in a clear direction, I would be very thankful. Nearly forgot to mention that when able to boot from the usb drive files on the hdd are still accessible, so I don't believe this to be a hardware issue.
Last edited:
If any more info is needed please let me know, views of this thread continue to go up but no replies yet. I will provide any info I have left out upon request, just a novice trying to save someone the time and expense of dealing with commercial repair options.


Mostly Harmless
Staff member
When in the recovery environment, try using

bootsect.exe /nt60 all /force
bootsect.exe /nt60 /mbr all /force