Windows XP no longer booting after reformat of vista drive

#1
Hi all. I had to recently reformat my vista drive and reinstall vista (64 bit home premium) and I am no longer able to boot into XP which is on a different partition of the same drive. (Vista on C:\, XP on F:\)
I have set up the boot loader like this:


There are a total of 2 entries listed in the Vista Bootloader.
Bootloader Timeout: 30 seconds.
Default OS: Microsoft Windows Vista

Entry #1

Name: Microsoft Windows Vista
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

Entry #2

Name: Windows XP
BCD ID: {249b7309-bec4-11dd-be20-001e8c70fa7b}
Drive: F:\
Bootloader Path: \NTLDR

I suspect it has something to do with the boot loader path, as when I first added the XP entry it said something about NTLDR being missing?
I changed the drive to F:\ from C:\ in an attempt to point it in the right direction but there is obviously something else I am missing. Is there something I need to do to alter the boot loader path to make it so the XP can boot again?

Any help would most appreciated, and sorry if this is a stupid question! Kind regards.
 

Terry60

Knows where his towel is.
Staff member
#2
HI crusty, welcome to NST.
Change the drive path in EasyBCD to C: for XP (you're telling it where the boot files are), then copy NTLDR, ntdetect.com and boot.ini from F:\ to C:\.
Make sure that the copy C:\boot.ini points to the correct partition for XP.
It's all in the wiki. Take note of the troubleshooter and boot.ini rebuild links.
 
#3
With Vista on now you will first need to right click on the boot.ini and select properties in order to uncheck the read only box followed by clicking the apply button. First make sure you go into the tools>folder options>view tab to uncheck the hide all protected system setting found there so the boot.ini is visible in any Windows Explorer window.

Once that is done and the files are copied to the root of the Vista primary remember to uncheck the read only box and click apply so that you can simply double click on it after to see it opened up by NotePad. One simple change and resaving to overwrite the copy will generally see XP load right up when selected.

The default should read "rdisk(0)partition(2)" on both the default OS and operating systems entires in the boot.ini if XP is on the second partition. Otherwise the partition(2) has to be changed to the actual partition on the drive.

The problem however was not seeing XP added in automatically when seeing a fresh copy of Vista going on. You should see the "previous versions of Windows" option on the boot option menu when starting Vista up. That's what I find a little odd here. The installer generally automatically detects other Windows installations whether Vista or older.
 
#4
Hi guys, thanks for the replies. Sorry to be such a pain but I cannot actually even find NTLDR and NTDETECT.COM. Where should they be? I think I may have wiped them when I formatted my C:\ drive. Should I boot from my XP CD and run the repair mode and follow the command prompts in the rebuilding the boot.ini page? Will this also restore NTLDR and NTDETECT.COM if in fact they are missing? Thanks.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#5
They are hidden files. Open up My Computer. Tools>Folder Options>View Tab. There check the show hidden files and folders. Then scroll dow just once and you will see:

"Hide System Protected files (Recommended)"

Uncheck that box as well. Then the boot files will be shown.
 

Terry60

Knows where his towel is.
Staff member
#6
And untick "hide extensions for known filetypes" or boot.ini will just appear as "boot".
 
#7
You definitely want the boot.ini file to appear as that since Vista now sees a new "Boot" folder. I think you forgot to do what I told you earlier about unhiding things. :brows: You'll get there! :happy: