Windows7 and ESXi 4.1

#1
I can't get this to work, I'm probably doing something daft as per usual...

I installed Windows7 64-bit on a hard drive. Fine
I disconnected the W7 hard drive, connected a second hard drive, and installed ESXi 4.1. Fine

Note that the first time you boot ESXi after install it wipes and reformats all the other drives on the host to VMFS format so would have killed W7 if I'd left it there.

I reconnected the W7 drive, set that as the boot drive in BIOS and rebooted into W7. Fine

I installed EasyBCD.
ESXi uses SYSLINUX to boot so I added an entry with EasyBCD:

Linux/BSD
LILO/eLILO
Partition 3 - E\: as FAT 4MiB (this is Hypervisor0, the partition with the boot flag set)

Then using BCDedit, I changed the Path entry to: \ldlinux.sys

I booted and it failed, couldn't find \ldlinux.sys.

Then I noticed that the drive was set to C:, so I changed that to E: as there are two partitions on the first (W7 boot) disk.

So I booted and it hung. It found ldlinux.sys, but the boot didn't work - no msgs.

I'm wondering if the fact that I had to change the disk from C: to E: is significant?

Or, is \ldlinux.sys the wrong setting?

Any ideas?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
Hi Twincam,

I haven't personally tested ESXi with EasyBCD, but everything starting with "Then using BCDedit,...." is unneeded.

*IF* you can boot into ESXi by simply booting from the BIOS directly to E:, then selecting E: in EasyBCD was enough.
 
#3
When I did it the first time, it complained that it couldn't find the path - after all it isn't Linux. I'll check again, thanks. Booting directly into that partition works as that's the one with the ESXi boot flag set, and If I point the BIOS boot to that drive, it works.

Alan
 

mqudsi

Mostly Harmless
Staff member
#4
It shouldn't complain about the path. EasyBCD should create a stub loader in the NST folder, and that's what the entry should point to. If it's complaining about the path, that's a bug.
 
#5
There isn't an NST folder. It may have created one on C:, I'll check. I can also create an NST folder on E: and experiment with that. I'll see if I can get it to create the stub loader.

Alan
 
#7
I installed 2.1 and deleted all the entries except the Windows one, then I added two entries, a syslinux and a lilo.

the NST directory was created on C:

I booted from both entries, both came up "Boot Error".

Addendum:

ESXi still boots OK if I point the BIOS at disk2.

Here's the detailed mode output...

Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=\Device\HarddiskVolume1
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {f4154eb2-6091-11e0-a918-e28f25e2d483}
resumeobject {f4154eb1-6091-11e0-a918-e28f25e2d483}
displayorder {f4154eb2-6091-11e0-a918-e28f25e2d483}
{f4154ec7-6091-11e0-a918-e28f25e2d483}
{f4154ec8-6091-11e0-a918-e28f25e2d483}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 30
displaybootmenu Yes
Windows Boot Loader
-------------------
identifier {f4154eb2-6091-11e0-a918-e28f25e2d483}
device partition=C:
path \Windows\system32\winload.exe
description Windows 7 64-bit
locale en-US
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
recoverysequence {f4154eb3-6091-11e0-a918-e28f25e2d483}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {f4154eb1-6091-11e0-a918-e28f25e2d483}
nx OptIn
Real-mode Boot Sector
---------------------
identifier {f4154ec7-6091-11e0-a918-e28f25e2d483}
device partition=C:
path \NST\nst_linux-87A8540381845E3D774796E2AD0DD4DC.mbr
description NeoSmart Linux
Real-mode Boot Sector
---------------------
identifier {f4154ec8-6091-11e0-a918-e28f25e2d483}
device partition=C:
path \NST\nst_linux-DD3DDDEDDE47A4F26F86B3A1F9B8FC66.mbr
description NeoSmart Linux

Addendum:

Hypervisor0, the boot partition on the ESXi 4.1 Disk has the following files:

mboot.c32
safeboot.c32
syslinux.cfg

syslinux.cfg contains one line:

default safeboot.c32
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#8
You should be able to create a NeoGrub entry, and enter something like this in the configuration file:

find --set-root /mboot.c32
chainloader +1
boot
 
#9
That didn't work either, I think it's time to give up! I've disabled the boot menu and I'll just carry as before by changing the hard-drive sequence in BIOS when I want to change.

Thanks for all your help!

Alan
 

mqudsi

Mostly Harmless
Staff member
#10
Sorry we couldn't help, Alan.

I've been meaning to add official support for ESXi to EasyBCD, but have not yet had the chance.
 
#11
It's not going to be high on the priority list, not that many people use it outside datacentres! If you do get around to working it out it, let me know and I'll beta test for you.

Actually installing ESXi so that it boots on a PC is a breeze provided you have a supported NIC card - £5 new on eBay - built-in mboard ones are very unlikely to work). Disconnect all other disks from the PC first as the install process may wipe all the other disks and replace with VMFS filesystems. Give me a shout if/when you decide to do this and you have issues.

Thanks for helping!

Alan
 

mqudsi

Mostly Harmless
Staff member
#13
Thanks for sharing that. I've commented on the site about iReboot as a quick-reboot alternative.