Windows7 + Fedora 15 using 2 HDD

#1
Sorry if this has been asked before. This is my first try installing Fedora.
This what my Fedora HDD install looks like the actual partition sizes are different: linux_lvm.png

This is what the Win7 disk partition looks like: disk_info.PNG


This is what my BCD settings look like: BCD_settings.PNG

I've managed to verify the Grub is installed in the /boot partition of /sdb This is what is in the grub.conf file:

[admin@localhost ~]$ cd /boot
[admin@localhost boot]$ ls
config-2.6.38.6-26.rc1.fc15.x86_64

[admin@localhost grub]$ sudo cat grub.conf
[sudo] password for admin:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/mapper/vg_localhost-lv_root
# initrd /initrd-[generic-]version.img
#boot=/dev/sdb
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.38.6-26.rc1.fc15.x86_64)
root (hd0,0)
kernel /vmlinuz-2.6.38.6-26.rc1.fc15.x86_64 ro root=/dev/mapper/vg_localhost-lv_root rd_LVM_LV=vg_localhost/lv_root rd_LVM_LV=vg_localhost/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet
initrd /initramfs-2.6.38.6-26.rc1.fc15.x86_64.img
title Other
rootnoverify (hd1,0)
chainloader +1
[admin@localhost grub]$ +


I can boot either disk stand alone but only windows7 from the dual boot menu. when I try to boot Fedora all I get is the >grub prompt in what appears to be somewhere on the C: drive
Do I have to edit the grub.conf file?
 
#2
Solved the problem myself.

I solved my own problem but at a cost. I can no longer boot the disk with Fedora 15 on it standalone through the bios I must use dual boot. Perhaps that's by design.

It seems that Anaconda created the grub.conf file found in my initial plea for help that went unanswered for some reason:frowning:. This file had these two references:

splashimage=(hd0,0)/grub/splash.xpm.gz
root (hd0,0)


As you can see the reference is to hd0. For some reason Anaconda assumes that Fedora is on the first Disk hd0(sda) instead of what it actually is hd1(sdb). By editing the grub.conf file and changing the references to :

splashimage=(hd1,0)/grub/splash.xpm.gz
root (hd1,0)

I am now able to boot using easyBCD2.1

I would sure like to know why this step is necessary. Should I have configured Fedora differently somehow? When I installed Fedora from a DVD iso I wasn't given the option to directly set these values. If this modification to grub.conf is necessary and not a work around it would've been nice if these steps were in a tutorial. Perhaps they are and I just couldn't find them.