Winload.exe missing or corrupt

Hello it jedi's, I am a man in need of help.
I do not have much technical knowledge so please keep that in mind.

My computer running Vista Home Premium would not go past Startup repair anymore. It ran forever and ever.
So today i purchased NeoSmart's vista boot thingy on someone else's computer to solve my problem.

finally my computer did something else than endless reruns of startup repair.
i ran the Automated repair untill it said it was done and rebooted.

now, every time I restart my computer says:
Winload.exe is missing or corrupt etc etc.
Since Acer doesn't provide their clients with Windows Vista dvd's, i kept running the Automated Repair with the same result every time.
i saw someone else here with the same problem and he was advised to do something called 'chkdsk'by using the launch command line. I tried this but it either said that it was a bad command or it did nothing.

I have an Acer Aspire M3641
windows vista home premium installed on my C drive

Thanks in advance for any help!
Last edited:


If you're going through hell, keep going.
Staff member
Moved this to Windows recovery CDs and as per the sticky at the top all support requests go to EasyRE
Send EasyRE support requests to

But, you never know, someone with expertise may also answer you here but I would email support anyway.
Thank you. Already sent an e-mail and received some help.
My computer is still stuck at the same point though so any additional help is more than welcome!


If you're going through hell, keep going.
Staff member
Unfortunately I have no knowledge of this, hopefully someone will help soon.