wont recognise winxp "windows.0"

#1
I have Win7 as my primary system on one HDD and winxp on another. When i run Easybcd2.0 on either HDD it wont find the Winxp.

I looked around for a possible solution and kind of found part of it- my xp install is listed as "WINDOWS.0" due to there being a previous install of xp on this disc (which is now removed) If i rename this directory "WINDOWS" easybcd will now find it, however winxp will no longer load up correctly, obviously all the entries point to WINDOWS.0 directory and not WINDOWS.

I've cleaned up boot.ini so only the one install is recognised and it runs fine if I boot priority to the Winxp drive

How can i get Easybcd to recognise this install of XP with the core directory being named WINDOWS.0 instead of WINDOWS ???

Appreciate any assistance, I'm only partially tech minded when it comes to windows installs and how they create directories and boot.ini entries etc. Thanks
 

JustinW

Super Moderator
Staff member
#2
Are you using the auto or manual method when you add the XP entry? In your case, you'll probably want to use the automatic method, which well chainload ntldr and your boot.ini to load WinXP that way. If you want to fix things though long term by having the install in the Windows directory you're going to haft to re-install XP, unless you want to spend many hours going through XP's registry to correct the references.
 

mqudsi

Mostly Harmless
Staff member
#3
Kairozamorro, that won't work. EasyBCD searches for the WINDOWS directory as he mentions.

bobbyd: Rename WINDOWS.0 to WINDOWS. Add the entry in EasyBCD.

Open boot.ini, and change WINDOWS to WINDOWS.0

Rename WINDOWS back to WINDOWS.0
 
#4
thanks guru, i'll give that a try. Just wondering how i go about changing the boot.ini if i'm in Win7 at the time? Cause if i'm in Win xp at the time can i get the boot sector loaded on to the Win7 hdd.
 

mqudsi

Mostly Harmless
Staff member
#5
boot.ini is just a file on your boot disk. It has nothing to do with the boot sector.
 
#6
I did what you suggested guru- changed windows.0 to windows, ran easybcd and XP was found, renamed back to windows.0 but when i looked at boot.ini on the XP hdd, it already pointed to windows.0 not windows.

When i try to boot XP it comes up with "ntldr.exe not found" or something similar?
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#7
Change the boot.ini which EasyBCD created on the "system" partition, not the one on XP.
 
#8
Thanks terry, have tried changing boot.ini on the win7 hdd but it wont let me save changes- cant seem to get around the permission of this file being read only as i cant locate it outside of "run" in order to change the permissions. My folders are set to show hidden files etc
 

Terry60

Knows where his towel is.
Staff member
#9
You can locate it with EasyBCD > Tools > Edit legacy entries.
Boot files are mostly "super-hidden". You need more than just "hidden files" unticked.
If you can't manage to get past Windows restrictions, you can always side-step Windows by booting a Live Linux distro, and using it to edit any file you like. It doesn't care about Windows permissions.
 
#10
thanks terry- using this i was able to find the boot.ini just as before but also still cant save it just as before, owing to the "read only" permission. Need to get around this read only issue.
 

JustinW

Super Moderator
Staff member
#11
Right click on boot.ini > Properties > General. Under attributes uncheck "Read Only" than "Apply" the changes. Assuming permissions aren't messed up you should be able to edit it now.
 
#12
Cant right click on it cause theres no way of seeing in in explorer, even with show hidden files option on. I've tried to gain all permissions i can option.......frustrating. Keep the ideas coming please, i'm hopeful this can be sorted, thanks
 

mqudsi

Mostly Harmless
Staff member
#13
You need to enable the viewing of *system* files, not just hidden files. It's a separate option.
 
#14
Thanks guru

ok, one step closer but still no go- i found the option for hide protected system files and unchecked that, it now shows boot.ini in explorer and i could change the read only status. But now when i try to save it it just says access is denied. Under security tabs for bot.ini it has all permissions tick for me other than "special permissions" which i cant seem to find a change for anywhere. I must be an idiot i think.
 

JustinW

Super Moderator
Staff member
#15
Vista/W7 UAC can be quite annoying. Heres what you can do. Copy the file to your desktop and modify it as needed. Drag it back to explorer to replace the orginal file. It'll prompt for UAC elevation and than replace the file.
 
#16
Justin, you are a champion- what a strange but suitable solution. It didnt prompt me for uac elevation but it let me replace the file and it now works a treat, thank-you everyone for the suggestions.
 

mqudsi

Mostly Harmless
Staff member
#17
I must be an idiot i think.
I think the only idiot here is the one that invented the "protection" system used in Windows Vista and Windows 7.