Would like some help fixing mbr for a dual boot Windows Server 2008 and Ubuntu Server

#1
Hi --

Background:

I have a i7 machine with the following three hard disks:
  • 2 2TB Seagate drives that are configured as hardware RAID 0 and set up as 2 volumes
    • Volume 1 has 3 partitions
      • Partition 1 -- 100MB System Partition
      • Partition 1 -- 2TB NTFS Formatted Drive
      • Partition 2 -- 1TB Free Space
    • Volume 2 has 2 partitons
      • Partition 1 -- 16GB swap area for Ubuntu
      • Partition 2 -- 750GB Ubuntu install
  • 1 260GB Seagate drive
    • Partition 1 -- 100MB System Partition
    • Partition 2 -- 235GB Windows Server 2008 Install
    • Partition 3 -- 16GB Windows Swap File Drive
    • Partition 4 -- 8GB NTFS Formatted Drive
I first configured the 2TB drives as RAID 0 in the BIOS utility. No problems; everything fine

I next nstalled Windows Server 2008 onto the 260GB drive -- fine, no problems. Recognized RAID drive correctly as one big drive, etc.

I next installed Ubuntu on Volume 2 of the RAID, setting up partition 1 as a 16GB swap area putting Ubuntu itself onto Partion 2 (formatted as Ext4) and in the course of the install placed GRUB2 loader onto the RAID drives Volume1, Partition 2 along with Ubuntu.

I then rebooted in Windows and tried to use EasyBCD to try to set up a dual boot configuration to add the Ubuntu install into the Windows boot menu.

Problem is, when I add an entry and choose the Linux tab and then the GRUB2 entry, I never get a chance to specify the drive and partition where Ubuntu is located. It always says Automatically Configured and then gives me a boot error when I tried to reboot.

I tried specifiying Grub (Legacy), which let me choose the correct partion, but still errored out when I reboot.

Is there anything I can do at this point. Ideally, I would like to be able to edit the boot record and put the correct drive and path in. But it's not like it used to be in the old days, with a hidden text file that specifies different boot alternatives. (Or at least I don't see such a file on my C: root where it used to be located).

Any suggestions anyone can give me would be greatly appreciated.

Thanks.

Mike
 

mqudsi

Mostly Harmless
Staff member
#2
Hi Mike,

I'd bet it's your RAID causing problems. If you reinstall Ubuntu but during setup create a separate /boot partition on the 260GB drive, you should be good to go.