Writing Xp new bootloader not working.

armageddon51

New Member
Hello,

I use EasyBcd very few times but there is something that puzzle me lately. I had a simple setup with 7 64-bits and XP on the same boot drive. I want to delete 7 to make room for Linux. I tried to get EasyBcd to write a new XP bootloader since I didn't need 7anymore. After confirm writing the MBR and rebooting nothing had happen. The 7 bootloader was still there. I tried it twice. So finally use the bootsect nt52 trick to get rid of it.

Did I miss something with Easy Bcd. That should have been a simple operation. ?
Tx
 

mqudsi

Mostly Harmless
Staff member
Hi armageddon, welcome to NST.

Sounds like there's a mix-up in Windows as to which device is your boot drive. EasyBCD would be changing the a different partition than the one you boot from.
 

armageddon51

New Member
Hello,

that's weird because I had disable the other disk (non bootable) in the bios so there was only the main disk left. Anyway does your program use the bootsec.exe command to do the mbr changes ?

Tx
 

mqudsi

Mostly Harmless
Staff member
Right - but if it was connected to the main IDE/SATA port, Windows might still believe that it was disk 0.

EasyBCD does use bootsect.exe to do the MBR changes, but not with the /all parameter.
 

armageddon51

New Member
Well in my system the disk disappear from any os when desable in the bios but who knows ! Anyway that may be the only explanation.
Thank's man.
 

mqudsi

Mostly Harmless
Staff member
It's not a matter of simply appearing or disappearing. The actual disk number to the OS must also be shifted.

i.e. it's not enough for disk 0 to vanish, but disk 1 must also be relabeled disk 0.
 

armageddon51

New Member
Hi M.Guru,

I don't know if you want to get to the bottom of this and spend time but here is the thing. I have 2 disks, one has always been the master and use for boot. The other one is only data and non bootable. I always desable it before installing an OS not to be confused. Anyway the boot.ini (XP) file is correct with disk0. As for 7, it must have been set on this one too since with the data disk offline would have never boot.

However Is it possible that because I did not delete the 7 entry first in the boot list, the bootloader writing didn't work ? It could not have write to the desabled disk. :wtf:
 

mqudsi

Mostly Harmless
Staff member
When you fixed it yourself from the commandline with bootsect.exe, did you have to use the /all switch?
 

mqudsi

Mostly Harmless
Staff member
Yeah, it's appearing to be something caused by the internal behavior of bootsect.exe

Future versions of EasyBCD will use our own MBR-writing utility instead of relying on bootsect, because there's a lot of unexpected behavior with this MS tool.
 

mqudsi

Mostly Harmless
Staff member
Thank you :smile:
 
Top