Xandros Linux, Visa, XP Triple-boot?

I have XP and Vista booting with the default Vista bootloader, and I've installed Xandros Linux 4.0 Professional Desktop on a 20 GB partition of the primary hard drive 0. I made sure and un-check the option while installing Xandros that said "Install boot manager on the master boot record". Underneath there, a note read as follows "Note: A copy of the boot manager will also be placed on the root partitiion (hda2)". Nowhere on the screen did I see the words "LILO" or "GRUB", so I really don't know which one to select when adding the entry in the EasyBCD program. I tried both LILO and GRUB, and neither one worked. They both get stuck while booting after selecting the new item I added, saying "Bootsector from C.H. Hochstatter; Cannot load from Harddisk; Insert Systemdisk and press any key".
I even tried downloading the new beta version 1.61 and tried a grubless installation, but that just boots me into a grup command prompt where I'm expected to hit the TAB key and select from hundreds of commands that I have no idea what to do with.
Can you help?
Sorry, I just saw on another post that you are asking for the debug info...
Windows Boot Manager
identifier              {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device                  partition=D:
description             Windows Boot Manager
locale                  en-US
inherit                 {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default                 {78d33846-f100-11db-928c-f77a59547ada}
resumeobject            {78d33847-f100-11db-928c-f77a59547ada}
displayorder            {466f5a88-0af2-4f76-9038-095b170dc21c}
toolsdisplayorder       {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout                 30
Windows Legacy OS Loader
identifier              {466f5a88-0af2-4f76-9038-095b170dc21c}
device                  partition=D:
path                    \ntldr
description             Windows XP
Windows Boot Loader
identifier              {78d33846-f100-11db-928c-f77a59547ada}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Microsoft Windows Vista
locale                  en-US
inherit                 {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
osdevice                partition=C:
systemroot              \Windows
resumeobject            {78d33847-f100-11db-928c-f77a59547ada}
nx                      OptIn
Real-mode Boot Sector
identifier              {b6c9765e-32d8-11dc-b604-0019b967649b}
device                  partition=D:
path                    \NST\nst_grub-0FCDA0362E833C3B9AE96854E37F7979.mbr
description             Xandros Linux


Mostly Harmless
Staff member
Hi smckenna, welcome to NeoSmart Technologies.

Xandros uses LILO, so EasyBCD's grubless-install option won't work (it relies on having the grub menu file on your HD somewhere, whether or not it's actually installed to the MBR or Bootsector).

In EasyBCD, what drive + partition did you select when adding a LILO entry?
hda2 == hard drive 0, partition 2 in EasyBCD 1.61.


Mostly Harmless
Staff member
What does the description for Drive 0, Partition 2 say?
Here are all the entries for Drive 0 when I pull down the drop-box:
Partition 0 (HPFS/NTFS - 20 GB)
Partition 1 (Win95 Xint 13 Extended)
Partition 2 (HPFS/NTFS - 110 GB)
Partition 3 (Linux Native - 20 GB)
*However, when I look at my partitions using the Vista Disk Management, there are only 3 partitions, not 4 (see below). I think maybe the second entry is saying that there is an extended partition, and the rest of the partitions listed are inside the extended partition?



Mostly Harmless
Staff member
Yeah, you're right.

The blue is an extended partition indeed. Maybe this is something that EasyBCD should indicate, or at the very least not assign a number to in future versions.

At any rate, yes, Disk 0, Partition 3 in EasyBCD.

It looks like LILO was never properly configured during the setup routine.

I recommend just install EasyBCD 1.61 Beta.

Add/Remove | NeoGrub | Install NeoGrub | Configure NeoGrub

Set up the menu.lst as according to your Xandros configuration. Here's a very lengthy sample menu.lst to get you started: http://neosmart.net/wiki/download/attachments/196621/menu.lst
Well, I gave it my honest best try, with the following menu.lst file:
# NeoSmart NeoGrub Bootloader Configuration File
# This is the NeoGrub configuration file, and should be located at D:\NST\menu.lst
# Please see the EasyBCD Documentation for information on how to create/modify entries:
# [URL]http://neosmart.net/wiki/display/EBCD[/URL]
# Boot automatically after 30 secs.
timeout 30
# By default, boot the first entry.
default 0
# For booting GNU/Linux
title  GNU/Linux
root (hd0,2)
kernel /boot/initrd-2.6.15-dcc-uni.gz root=/dev/sda2
I changed it to sda instead of hda because I have an SATA hard drive. Also, I put in the path and filename for the kernel image file (I think). I pulled this from the Xandros user's manual in the LILO configuration section. However, it gives the following error upon selecting the item in the NeoGrub bootloader menu:
Booting 'GNU/Linux'
root (hd0,2)
Filesystem type is reiserfs, partition type 0x83
kernel /boot/initrd-2.6.15-dcc-uni.gz root=/dev/sda2
Error 17: File not found.
I wish there was some way I could simply mount the linux partition so I could peek and see what the actual path and filename is. However, even if I got this working, the very first time the Xandros updated itself, even with a minor O.S. version update, wouldn't it break the NeoGrup menu.lst file that refers to the old version? Or, worse yet, it would try to load the old version of the operating system, even though there is a newer O.S. image file present?!


Mostly Harmless
Staff member
Yes. (btw, please use "code" and "quote" bbcode!)

If you install GRUB within Xandros, GRUB would auto-updated itself to the new file though.

Going by what I see, your drive and partition number are correct in the NeoGrub file.

If you want to take a peek at the file name, grab yourself a Live CD. Kanotix or an Ubuntu Live CD would do the trick.