xp boot destroyed by windows update


I have had a dual boot working with Vista (installed first) and XP for a while now. I just did a windows update for XP (including a hardware update for the AMD processor) and after rebooting I can no longer boot to XP getting a message about autochk not being there. Found suggestions on the web that this might be that the partition for the OS is hidden but it is not. I can see it from vista as D and the windows folder is there and autochk.exe is in system32.

I have used EasyBCD to delete the boot entry for XP and then reinstalled it several times and I still can not boot to XP. I hate hate hate hate vista and was ready to dump it completely but can now only boot to it. I don't care if I loose Vista, I just want XP back.

This problem happened immediately after installing two recommended "hardware updates in windows update. They were for the AMP processor (no idea what was installed) and for the wireless card which I can not test from XP because I can't boot it. There is no way I can roll back this update obviously. Can not boot to safe mode in XP either.

What is left to check? Reading some of teh forum posts it looked like I should have a "boot" folder in the boot partition but there is none. There is also no boot.ini anywhere on the drive so I can not take the suggestion to edit it. help help help, I can not live with vista. It was a bitch to install XP on this computer because HP does not provide the drivers for XP. The thought of re-installing XP is scary.
Hi Spencoid, welcome to NST.
When the boot gives messages about files being missing, it generally means that it's being pointed to the wrong partition (or the partition's hidden as you said). In this case boot.ini not finding XP, though I've only ever seen autochk as an error when trying to boot Vista !
Vista's boot folder and all the XP boot files are all hidden system files, so you'll need to set/unset the appropriate flags in folder options to see them.
If, with hidden files displayed, you still can't find boot.ini, then it must be using the hard coded default in NTLDR, and maybe that's changed during WUD. (though I'd doubt it).
If you need to recreate boot.ini, you can read all about it here

(and it's not the "boot" partition that contains the boot files - It's the "active" partition - stupid I know, but that's MS's command of the English language for you))
Last edited:
I checked and I do have the boot folder. In folder options, display system files and folders was not set. I had show hidden files and folders checked and did not realize that there was another level of protection. I have a C and a D partition when booted to Vista. Both are visible in explorer from vista so I assume that the partitions are not hidden. Vista is installed on C and XP is installed on D. There is only on physical drive. The boot.ini is copied below and looks right to me according to the article re. creating a boot.ini. Vista is not listed as an OS but it is listed as the default. When I boot the machine I get both in the list but can only boot to Vista. Teying to boot to XP results in a loop of trying to boot and the message about autochk missing. autochk.exe is in the windows folder in system32

what else can be wrong? This doesn't make any sense.

[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn
Can you post a screenshot of your disk management display, and copy/paste the text from EasyBCD detailed mode display settings.
xp destroyed by windows update

here is the info from detailed settings. i can not figure out how to paste a screenshot so i am putting it on my server hope this works

Windows Boot Manager
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=C:
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {c12c3dbe-986e-11dc-915d-c036dd6b0c22}
resumeobject {c12c3dbf-986e-11dc-915d-c036dd6b0c22}
displayorder {c12c3dbe-986e-11dc-915d-c036dd6b0c22}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 30

Windows Boot Loader
identifier {c12c3dbe-986e-11dc-915d-c036dd6b0c22}
device partition=C:
path \Windows\system32\winload.exe
description Microsoft Windows Vista
locale en-US
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
recoverysequence {572bcd55-ffa7-11d9-aae2-0007e994107d}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {c12c3dbf-986e-11dc-915d-c036dd6b0c22}
nx OptIn

Real-mode Boot Sector
identifier {adba2f5f-0f7e-11dd-a193-001d6042311f}
device partition=C:
path \NTLDR
description Microsoft Windows
interesting but i don't see how this applies to my problem. i read the articles and can see that it could be an annoyance if the "dirty bit" is set but my problem is that windows does not boot. if it is that autochk can not be found then i need to make it findable or what? i can not boot to XP even in safe mode unless maybe if i remove Vista as a boot option and can then use F8 to start in safe mode but with the multiboot setup i do not see any way to boot XP at all. i can not edit the registry to prevent autochk from running.

if there is a problem with autochk and if it will only run if the dirty bit is set, is there some way to change it from vista or does autochk always run at start if set to do so and the only fix would be to edit the xp registry from outside of XP?

needless to say, i am very pissed off at microsoft for destroying my xp partition in a simple windows update.

please, someone, come up with the magic solution that i need.
This was a reply in a thread describing your problem with autochk preventing boot. It's suggesting that it's not the boot process as such, that's failing. (and your posted stuff looks OK and normal).
What appears to be happening is that the boot is detecting the flag for an improper shutdown and then fails, trying to execute the automatic chkdsk.
Not something I've seen dealt with here, which is why I pointed you at the other thread.
If you can use the recovery console to run chkdsk and reset the flag, or reset it somehow without running chkdsk, and get into a booted system where you can run it, you should be able to get back your working system.
Guru or Mak might be able to help, but I don't know the appropriate command parameters, which is why I pointed you to a forum where someone does seem to know.

I see what Terry is getting at now. Try this:

First click Start> Run> bring up a command prompt by typing in "CMD" and type " fsutil dirty query d: ". This queries the drive, and more than likely it will tell you that it is dirty. Next, type "CHKNTFS /X D:". The X tells Windows to NOT check that particular drive on the next reboot. At this time, manually reboot your computer, it should not do a Chkdsk and take you directly to Windows.

See if that stops the check disk utility from coming up and allowing you to boot correctly.

no idea what the problem actually was but running chkdsk from command prompt in vista did not fix it. did not try setting the dirty bit as suggested above because the problem was fixed before seeing this suggestion.

called microsoft support and they walked me through a "repair" installation booting from the XP disc. it found the installation on the second partition and actually fixed it without destroying my application registry settings or even the desktop file. could not do this without support because the product code supplied with the disc did not work for repair and support gave me a new one that did work.

nothing was wrong with the EasyBCD end of things everything works after fixing windows that was destroyed by the update. no more optional updates for me.
i can not boot to XP even in safe mode unless maybe if i remove Vista as a boot option and can then use F8 to start in safe mode but with the multiboot setup i do not see any way to boot XP at all. i can not edit the registry to prevent autochk from running.

I dual-boot XP/Vista on my laptop using Vista's bootloader. In order to get to XP's advanced options boot menu to get into safe mode, you must hit F8 immediately after selecting the entry to boot XP. You cannot select F8 for XP's entry when bootmgr is the active bootloader because NTLDR is chainloaded to boot XP. You just don't know it because NTLDR boots XP immediately for the fact it is the only item in the boot.ini file.
I think you'd have needed to boot into XP's recovery console rather than Vista's to fix the problem, but glad to find you've got it up and runnning again.
To give them their due, MS have always managed to get me sorted again when WUD leaves the system broken, it's about the only free support they offer.