XP boot options disappeared

#1
Hello,
I installed EasyBCD 1.7.2 in my Windows 7 rc1 partition. My pc looks like this:

Windows XP sp2
Windows 7 RC1
Ubuntu

From this boot menu I am able to start W7 and XP (didn't test Ubuntu yet) but I don't get the 'safe mode' options for XP since I see no 'F8' option in the boot menu.
How can I get this option back?

Thanks,
Marc
 

Terry60

Knows where his towel is.
Staff member
#2
HI Marc, welcome to NST.
Select XP from the boot menu and then hit F8.
You need to generate the F8 interrupt to the NTLDR if you want XP's extended boot options.
If you hit F8 before the boot menu, the interrupt is being processed by bootmgr and it will give you the Vista extended menu.
Bootmgr chains to NTLDR when you select XP from its menu, and that's when you need to grab its attention with a swift jab of the function key.
By the way, you'll need to download and use EasyBCD 2.0 latest build if you want to set up Ubuntu in a triple-boot. The grub syntax in recent Linux builds changed, and support for that change only exists in version 2.0.
1.7 will only work for Ubuntu 8.04 or earlier.