XP Drive Option Greyed-Out

bwana

New Member
#1
I have a similar problem to this fellow:

http://neosmart.net/forums/showthread.php?t=1049

When I boot into XP and try to start EasyBCD 1.7.1, I get an error. "The store import operation has failed. The volume does not contain a recognized file system. Please make sure that all the required file system drivers are loaded and that the volume is not corrupted."

I am only dual booting with xp on 1 disk (a raid) and vista on another (simple sata). If i select the raid volume as the first boot volume in the bios, i boot into xp. Attempts to make the raid volume active dont work-the option in 'disk management' is grayed out. the raid volume simply says 'system'. the vista volume says 'active'.

when i set the the vista volume in bios to be the first boot device, i can get into vista, but when i try to add a boot entry to the xp volume in easybcd, it does not let me set the drive letter. it says 'C' and that box is grayed out. the xp volume is labeled 'D' when vista boots (as you know the drive letters switch around depending on which is the boot volume).
 
Last edited:

bwana

New Member
#3
Aha! I figured it out. When I run easy bcd from xp and it asks for the boot volume, it wants the letter, D! The Vista install happens to be there as well so i select d for the second dialog. Then I get an interesting result. I get a dialog that says the files are missing. I click ok through that and then i get another dialog saying the operation completed successfully. Now it works! With the XP volume set as the first boot volume in the bios, i get the OS selector menu and i can go into either os.

I also figured out the problem with the business about the volume selection dropdown list being grayed out when easybcd is run from within vista. i noticed that to change the setup i have to do that from the 'change settings screen'. the 'add entry' screen' merely allows one to add an entry but not correct which volume it points to. when you select the type of os as 2K/NT/XP/2K3 then the drive letter is grayed out. but if a longhorn/vista type is selected then the drive letter dropdown list is usable. It doesnt matter tho. The associated drive letter can then be edited through the change settings dialog. Unfortunately this process did not work for me, initially. I kept getting a vista bootloader error when i chose windows xp at boot. It would say that \ntldr is missing. obviously it was looking for that file on the vista volume. i had to boot into xp, start easybcd and point it to D for both dialog selections. then all was good.

Addendum:

Thread split to own topic.


Please take a look at the XP documentation at Windows XP - NeoSmart Technologies Wiki
thank you. the interesting comment in the wiki that threw me off (I actually read it before i posted) was

"The "Drive" option in EasyBCD for Windows XP and below does not refer to the drive with Windows XP on it, but rather the system boot drive with NTLDR, NTDETECT.COM, and BOOT.INI"

In my case, those files only exist at the root of the xp volume. In xp that volume has the letter C. (is this beginning to sound like sesame street?) nfortunately, running easybcd from within xp and using the letter c woud give the errors outlined above. Only when i chose the letter d (the vista volume lacking those files) for both dialogs, did it work.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#4
That's intriguing.

Thanks for the input on that; I'll have to clarify the wiki text a bit further then.

EasyBCD wants to know the drive letter that should become the boot drive, then the drive letter that is for Vista. Usually the one with NTLDR is the intended boot drive, but I see that is not the case.

Glad it worked, at any rate.