XP/F12 dual boot trouble


I had a working install with grub on the mbr, F9 /boot on the first partition, XP on the second, the rest of Fedora on the third and swap space in the fourth. It booted like a charm.

Today I upgraded to F12 (reformatting P1, P3 and P4 and leaving XP's P2 unaltered). I erroneously put the new grub on the first partition... it was too late to change it by the time I noticed. After the install I tried booting, which failed. Where you'd normally get "Loading grub" and the the grub menu, I got "GRUB" and then nothing. However, with a GParted disk I could boot both OS's fine.

As it was on my mbr before, I tried reinstalling grub to the mbr. I now get a proper grub menu at boot and my F12 boots fine. XP is totally dead. Nothing through grub and nothing with my GParted disk. I read the FAQ here for the umpteenth time, it really is a nice thing, and got to "Troubleshooting XP". I get the blank screen from "After choosing to boot into windows, I get a black, blank screen.", meaning (as says the FAQ) that NTDETECT.COM is causing trouble. I don't however understand how I can fix this with the grabable files. Could someone expand on the procedure, and maybe also on what I can further mess up by messing with these files? I tried googleing the file/error, but didn't get any wiser from that.

One extra thing: I was in the XP disk management tab somewhere along the road and got the XP partition marked active. It might be wrong or it might not, but I cannot change it again in Windows as I cannot boot it. If I'm going to need to use diskpart or fdisk again, I might need some tips there too...

Thanks in advance!
Hi Porrum, welcome to NST.
That wiki troubleshooter refers to dual booting XP from the Vista/W7 BCD with bootmgr. It won't help you with fixing the XP boot through Grub.
You'll need to wait around for one of our tame Linux boys to appear for sensible advice on that.
Meanwhile you could perhaps ascertain whether the upgrade from F9 to F12 also involved a move from grub to grub2, because that will change what needs to be done to boot XP via the Linux boot manager.
Drop to a command line in grub with "c":

find --set-root /ntldr

In the directory listing do you see ntdetect.com, ntldr, and boot.ini? Try this:

chainloader /ntldr
Thanks for the speedy replies.

My grub menu states "GNU Grub 0.97", I don't know whether that's grub or grub2.

As for the "find --set-root /ntldr", it returns "Error 15: File not found".

I'm getting really curious about if and how this is going to get fixed :smile:.
Ok, set the XP partition to "active" (or "boot") with Gparted.
Then boot the XP disk, access the Recovery console, type your XP password, and run these commands:


That will get your XP booting. Next, get something like wingrub or grub4dos, and use it to boot fedora from the windows bootloader. You could also try this:

Get (and run) EasyBCD 2.0 Beta
Go to Useful-Utilties, and select Power Console.
Run the following commands:
bootpart X C:\Fedora.lnx Fedora Linux
where "X" is replaced with the correct partition value the first command returns for the Fedora /boot partition. That will create a special re-director file (named "Fedora.lnx") to the bootsector of the Fedora boot partition, and allow you to chainload it from XP's NTLDR (via the boot.ini file).

Then you'll have a dual-boot again.
I know it's been a while, but as I did not have time due to exams, my problem is still unsolved. Also, something mysteriously fried my motherboard last month, so I had to replace it. I now have a new bios I do not know very well.

Considering your previous suggestions, I marked my XP partition (2) as active using Parted, and then put in my XP SP3 disk. I was expecting to be able to get into the recovery console, as you described, but the thing hangs after "setup is inspecting your computers hardware configuration". It gives a blank screen. Googling that message returns a lot of hits, but I cannot really filter out what my problem would be.

Thus, I'm stuck, again :smile:.

Two main questions:
* Am I correct in trying to use my XP SP3 cd to get to the recovery console or do I need another disk?
* If it is the correct disk, how to I get rid of the blank screen and progress?

Thanks in advance!
Thus, I'm stuck, again :smile:.

Two main questions:
* Am I correct in trying to use my XP SP3 cd to get to the recovery console or do I need another disk?
* If it is the correct disk, how to I get rid of the blank screen and progress?

Thanks in advance!
Is your XP SP3 cd one you slipstreamed? Probably best to try an XP CD that came with your computer (assuming of course, one did...). If you downloaded that one from a 3rd party site, no telling what problems are on it. If you don't have an XP cd that came with your computer, you should order one from your OEM, which would probably be cheaper than purchasing a retail version.
My XP Professional (SP3) cd is a fully official one that I bought with my computer (parts :smile:) and paid for dearly. I suppose it actually would be a dvd and not a cd, but I'm not at home so I cannot check. I installed XP from it about a year and a half ago (with my previous motherboard and bios) and at that time it did not hang and gave all proper menus I needed.

Is there maybe something that I can try to see whether I'm dealing with a configuration problem or something else? I tried a GParted live cd again, which works fine (except with my XP partition of course), so it's not that the disks are not booting.
Hmm. Your latest problem probably has something to do with your BIOS settings.
Anyway, the purpose of running those commands I gave you earlier was to rewrite the Grub MBR with the XP MBR, and to rewrite code to the bootsector of the XP partition which will look for NTLDR.
If you're unable to do that, try using Testdisk from Linux, and repair the bootsector with that tool.
Of course, we're not even sure if the boot per se is what's acting up. It could be a system file deeper in the XP OS that is corrupted, in which case your only real option would be to reinstall XP.
Hi guys, I know this seems an old problem (ancient more like), but it remains unfixed. I've been out of the country for my studies and just got back to the computer with the problem now.

As it is, situation isn't exactly the same anymore. I'll list what I know (please ask for specifics when needed):
* grub on mbr
* windows XP pro on a logical partition (sda2)
* f12 on a logical partition (sda3)
* sda1 is unformatted (/boot 100MB originally), sda4 is swap

Problem still lies in booting XP. I now get the initial xp screen with the logo (I got that after I removed the small linux /boot partition before the windows partition). However, normally you get green loading bars and those don't appear. The thing just reboots when I get there. After the first time it showed the list with options for 'windows didn't boot normally', 'safe mode', etc. etc.. None of them work, it's always reboot. I have an official xp disk (the one which I installed from), but I can't seem to find out how to get into the recovery console with that. Also, if I let it load the normal setup, it crashes with a message explaining 'windows has discovered a problem... will not continue in order not to damage any files'.

'Minor' problem is that the pc has a different motherboard from the original setup. I kept on using the f12 for a while after XP became a problem, fried my motherboard on a nasty calculation and had no choice but to replace it.

Hopefully someone with a lot of XP knowledge can shed some light on this. As I get to see the logo I'm assuming it's not the bootloader that gives me trouble.

Thanks in advance!
Is there any chance on someone having a look at this? Or should I repost the problem in another thread? I'd really like to fix this without reinstalling.
Thanks for all the replies so far, it's another three months and I'm back to this problematic installation.

The problem: if I put in my XP Professional SP3 cd (a hologram fronted one) and boot from it, I get a couple of steps:
* A black screen with "setup is checking your system's hardware configuration"
* A couple of seconds with an entirely black screen
* A blue screen with "WINDOWS SETUP"

In that last screen, a bar appears at the bottom, going sequentially (and only once) through a very limited list of options:
* Press F6 if you need to install any RAID/3rd Party drivers
* Press F2 to initiate Automated System Recovery

If you don't pick any of those two, setup start loading a bunch of drivers without presenting any other options, and after a minute or so, continues to what I think is supposed to be normal XP boot.

At that point I get a blue screen of death, we have stopped in order not to cause any damage to your system. You might try to reboot if it's the first time, scan for viruses, or remove any new hard drives and other components. And yadda yadda yadda, you all know the screen.

So, I'm stuck again, since I can't seem to get into any decent type of XP setup, not even a fresh one. We're long past the time where it would be a lot more efficient to just wipe the thing and install seven, but as I said before, I'd really prefer bringing the old system back to life and getting for instance some tidbits of sony license info I can't recover without windows running.

Any tips on how I can get into a real setup mode?



You can ignore that last post :happy:, I'm posting this from XP.

At the third attempt, the blue screen of death gave me some hex-codes which I could google (0x000 0007B, and more useful: 0xF78D2524). An AHCI setting in the BIOS was causing the trouble with the XP setup, after I switched that to IDE default, the setup came through fully and I was able to quickly run a repair install.

An unexpected side benefit is that by switching that to IDE, a whole section at boot has disappeared, which makes everything boot faster. I actually have no clue why I had that setting and what I have lost by switching it of.

Thanks again for all the attempts at a solution, I'm happy it's finally fixed.
Last edited: