XP legacy / another freaking bootmgr screen

#1
Hi,
I was wondering if EasyBCD can handle the legacy entry for XP better ...
I can see an uneditable path /NTLDR set by EasyBCD - which is useless ... of course I can create the DIR and put the files in there
but it does not work ...

Hmm .. My Question is - how can I boot directly into XP?

Scenario --
a) XP PRO SP3 was installed first (first disk and partition)
b) after that: Win7 Enterpr. installation on 1st disk, 2nd partition

Win7 "insists" on "drive C", so it names its partition "C" (freakin confusing)

I used EasyBCD 1.72 to add the legacy XP entry --
this works -- but another bootscreen with XP and Win7 (with Win7 as default) shows, where I have to select XP.
This is really annoying.

Is it me who has done something wrong?
Is it possible to directly boot to XP from the first bootloader screen?

It does not seem to work --


I tried as well my third OS "openSuse 11.2" using grub -- installed on different partitions, but I seem unable to boot directly into XP.

Simply -- won't do it...

What can be done? Can I delete the Win7 loader stuff from my XP partition?
(Which files?)

Ideally I would like to use either
GRUB - to boot directly to Win7 or XP or openSuse

or use the Win7 bootloader -- with 1. Win7 and 2. XP (but loading directly!! without another bootloader screen here) 3. and openSuse 11.2

Is it possible?

Cheers
x
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
Hi x,

You shouldn't see the second boot screen unless you have multiple Windows XP installations.

What does your boot.ini look like?
 

Terry60

Knows where his towel is.
Staff member
#3
You should be using EasyBCD 2.0 latest build.
It automates booting XP.
1.7 expects you to understand and do the additional manual tasks yourself.
see point 5 in the sticky.
 
#4
Ok thx for the quick suggestions.
I deinstalled the Win7 bootloader, repaired XP from console (fixmbr, systemroot and bootcfg /scan fixing up all system issues)
This fixed up the XP install -- one issue was the option "/noexecute=optin /fastdetect", that I had in my boot.ini.
bootcfg /scan found the correct settings .. so I could boot finally into XP.

Well the options in the boot.ini worked always, but for some reason not with the Win7 bootloader. Any reason for this?

After removing this line in the boot.ini XP Pro bootet
-> changed from
multi(0)disk(0)rdisk(0)partition(1)\windows="XPPRO | SP3 (hd0,1)" /noexecute=optin /fastdetect
to
multi(0)disk(0)rdisk(0)partition(1)\windows="XPPRO | SP3 (hd0,1)"

I then used "EasyBCD 2beta" (latest build, 79) to setup openSuse and Win 7 .... which was my rescue!!
Because -- after removing the Win7/Vista bootloader -- Win7 was unable to repair the installation itself
by booting from the Win7DVD ...
How crappy programmed this recovery - because a fully functional Win7 Enterprise was there!!!)
After using EasyBCD - everything worked again.

Thx, Keep up the good work .. I noticed the new GRUB is already implemented .. Cool.
x
 
Last edited: