XP not booting - blinking cursor - but RIPLinux can boot it

#1
I have a problem with Windows XP not booting - got the dreaded blinking cursor - but using GRUB on the RIPLinux boot CD allows me to boot XP on the partition without any problems (I can use XP as usual). There is only 1 partition on 1 SATA hard drive in my laptop.

I've been researching the problem and trying to fix it for the last month. Can EasyBCD fix it without Vista?

I've tried using the Windows Recovery Console, fixmbr, fixboot, chkdsk /r, dozens of times without success. I've also copied the ntldr and ntdetect.com from the CD. Nothing works and my laptop just keeps giving me the blinking cursor. I've also tried using TestDisk but to no avail. I've also done a parallel XP install but it fails to boot after the files are copied from the CD. The only thing that I haven't tried is to re-size the partition to less than 136 GB, which fixed this problem for some.

If I format the drive and install a fresh copy of Windows the drive works fine and boots up normally. So obviously there is something wrong with the booting of the original OS or something not quite right with the partition but all checks say there are no problems. I've restored the backup image I made above, using Drive Image 7, and can successfully boot it with the RIPLinux GRUB. I really need the original XP to work because of the amount of effort to re-setup the whole thing from scratch is incredibly difficult (more difficult than trying to wait a few months to fix this).

Any idea how to fix the booting problem? Or has anyone come across a solution. I've already spent about a month fixing it but have so far failed :x yet I'm so close.

How I ended up in this mess: The problem was caused by me :shame: because I had PGP Desktop 9.9 installed and running with an encrypted drive, I subsequently installed Drive Clone Pro to backup my drive before going on holiday (not realizing that it would try to install its own boot manager) which toasted the PGP boot loader. I managed to decrypt and un-instrument the drive with the PGP Recovery CD (took 11 days to decrypt it while it was plugged into my 'hotel' room under the bed!). The decrypting subsequently toasted my partition, which was accessible prior to decryption. I then managed to recover the partition with Partition Table Doctor, which made everything accessible allowing me to recover all my files (later found out that TestDisk would have done this as well). I took an image of the drive after that to save a current copy of the files (200GB, 3 million files, took forever).

Jeremy
 

JustinW

Super Moderator
Staff member
#2
Jeremy, unless the encryption software you used came with a resuce disc to decrypt the drive our recovery nor a regular Windows disc well not be able to access the drive to correct it. You'll need to re-install Windows. If you want to use full disk encryption in the future I would recommend TrueCrypt, which requires you to burn a resuce disc during the encryption proccess that can recover TrueCrypt's bootloader in situations like this so you at least rescue your data if not recover the system.
 
#3
Thanks for the reply. I did already decrypt the drive successfully. I'm now trying to boot the drive after the havoc created by Drive Clone Pro.

I forgot to mention that I did format the drive and attempt to restore just the necessary files but it loses all of the permission and attributes on restore (either a limitation of DI7 or doing it from within another Windows environment).
 
#5
No I haven't tried that, I only have XP on the drive so I suspect that a Vista fix won't help me.

Reducing the drive size below 136GB didn't help me, as I thought that it might. I don't have a Vista disk so maybe I should try to install Linux on a piece of the drive to see if it helps because GRUB can boot the XP partition by me asking it to load the ntldr on the primary partition.
 
#7
Thanks for the reply, I appreciate the help. A repair install doesn't fix it. There is something up with the MBR, not sure what it is.

My next step is to try and install Linux and use GRUB to boot the XP partition then overwrite the MBR from the Recovery Console. I may not have time this week to test it out though. Like I said the RIPLinux CD can boot the ntldr on partition 1 of hdd 1, no issue with Windows XP after that. It is just that my laptop won't boot it on its own.

I did try booting the hard drive on my ASUS A8V mobo (Promise FastTrack controller) and it can boot the drive, but it only loads about 2 dozen files before I naturally get stop message (0x7B I think) for a boot device problem because I don't have the Promise SATA drives on that install.

Jeremy