I installed XP - Ubuntu - Vista, now Ubuntu does not boot anymore.
I'm using easybcd 1.52. My pc just has one harddisc with 2 primary partitions (XP, XP Recovery) and one extended partition with 3 logical partitions (Ubuntu, Vista, free space partition).

I tried to use easybcd 1.52 with the Linux/BSD option with Drive set to 0 and partition set to 1 up to 7, but no luck, Ubuntu does not boot anymore.

1 = error of vista bcd
2 = boots xp recovery partition
3 = displays a _
4 = error of vista bcd
5 = disk erro: press ctrl-alt-del (I guess this is an Ubuntu error message)
6 = error of vista bcd
7 = error of vista bcd

Any ideas?
Hello xgrate, welcome to NeoSmart Technologies!

The reason you're seeing that error is because GRUB isn't installed on your bootsector.
Try install NeoGrub instead - Add/Remove Entries -> NeoGrub -> Install.
I already tried NeoGrub, but that doesnt change anything.
And once NeoGrub is installed there is the Configuration button which opens a text editor. But i cant find any doc/guide how to edit this file (if needed).

Grub was installed, before the Vista install, in the MBR - bootloader of Ubuntu. Vista has overwritten the MBR. Normally grub is still installed after this, isnt it? It just inaccessible because the MBR is overwritten.

Do you have any more advise?

PS: another strang thing. If I open the 'Disk Manager' in XP I can see the following partition sequence:
Primary NTFS = XP
Extended Partition with 3 partitions (Unknown = Ubuntu - NTFS = Vista - NTFS = Data)
Primary NTFS = Recovery W2K

If I open the 'Disk Manager' in Vista it's different !!!
Primary NTFS = XP
Primary Unknown (!!!!)
Extended Partition (NTFS = Vista - NTFS = Data)
Primary NTFS = Recovery W2K
I did some more tests, but I cant get Ubuntu starting with easyBCD 1.52.

I booted Ubuntu from the rescue console and (re)installed GRUB in the bootsector of the Ubuntu partition using the following commands:
grub> find /boot/grub/stage1
grub> root (hd0,4)
grub> setup (hd0,4) install
This reported ok, no errors.

My hard disc setup (100GByte)
Partition 0: Windows XP
Partition 1: W2K recovery
Partition 2: extended partition
Partition 3: not used
Extended partition:
Partition 4: Ubuntu (booted using GRUB)
Partition 5: Windows Vista
Partition 6: NTFS formatted partition to store data

I configured easyBCD 1.52.
A. using the Linux/BSD option which installs the nst_grub.mbr file in /NST in Partition 0.
-> ERROR when I select this option in the Vista boot menu:
'A disk read error occurred. Press Ctrl+Alt+Del to restart.'

B. using the neogrub: this installs menu.lst & stage1 & stage2 in /NST in Partition 0
-> ERROR: when I select this option in the Vista boot menu the screens blanks for a few seconds and then returns to the Vista boot menu

One more thing, the Ubuntu partition is formatted with reiserfs. In this case GRUB uses stage1, stage2 AND stage1.5(reiserfs version).

I have the impression the Linux/BSD nst_grub.mbr option can not handle the stage1.5 and thus breaks on the reiserfs. And the new NeoGrub option does not include the stage1.5 and thus only supports ext2/ext3. I might be wrong, but cant this be the problem.

Anyhow, I now spend many hours getting this to work, I'm nearly giving up, I've had it.

If I can help you with any more information to get this solved, just ask ComputerGuru.
OK, you were right, NeoGrub doesn't support Stage1.5 (hence, no reiserfs support either).

The one thing to check is whether or not hda4 is the same number under Vista. If you get a disk read error, that means that the chainload file is corrupt.
Thanks, so neogrub wont do the job. Have you plans to adapt this?

The hda4/chainloader issue:
Both in WinXP and Ubuntu I see the partitions as described aboved.
But in Vista is looks different, as if Vista (x64 version) reads the partition table wrong (could it be). If I check with 'Disk Management' I get the following partition info.

0: XP (D:smile: NTFS, Healthy, Active, Primary Partition
1: Recovery F:, NTFS, Healthy, Primary Partition
2: Healthy (Primary Partition) --> this one is wrong, this partition is part of the extended partition 1 and hosts Ubuntu
3 (should include 2) is an extended partition:
3a: Vista C:, NTFS, Healthy, Boot, Page File, Crash Dump, Logical Drive
3b: Data E:, NTFS, Logical Drive

I dont know of any tools (fdisk) in Vista to really view a list of partitions.

If I use UFS Explorer 3.0 I can access the Linux partition. It's there and accessible from Vista x64.

An idea how I should configure easybcd to get Ubuntu started with this info?
How can I check the chainloader and how to repair it?


I have similar issue as you. You've obviously done a lot of work and I feel your pain. I have XP, Vista, Ubuntu, and OSX on my notebook. I used to use GRUB for XP, Ubuntu, and OSX and it worked flawlessly. Vista's boot mgr obviously took over which is why EasyBCD became an option. XP, Vista, and OSX boot fine, but I can't get back to the Ubuntu partition to boot. I've tried both ways to point to the GRUB partition, but I think we're down to the reiserfs issue. Hopefully Computer Guru will enlighten us soon. I will keep an eye on this thread.


OK, here's how it works:

You install GRUB to the *bootsector* of a linux partition. Not the MBR, just the bootsector.
You boot into Vista or XP, and you tell EasyBCD which Partition you installed GRUB to.
EasyBCD makes an image of the bootsector, converts it into a chainload file, and uses that to boot into Linux.

Can you pin down which of the steps aren't working?
Do you have nst_grub.mbr in the C:\NST\ folder?
I did install grub in the bootsector, not in the MBR (Windows still boots).
I did the procedure you mentioned, and nst_grub.mbr is installed in C:\NST\

When I select 'Ubuntu' in the Vista boot menu I get:

A disk read error occurred
Press Ctrl+Alt+Del to restart

Any more ideas?
The only thing that I can think of is that GRUB didn't install right.

Your best bet would be to manually install GRUB yourself from a rescue disk or live cd.
I booted Ubuntu from the rescue console and (re)installed GRUB in the bootsector of the Ubuntu partition using the following commands:
grub> find /boot/grub/stage1
grub> root (hd0,4)
grub> setup (hd0,4) install
This reported ok, no errors.

No change, Ubuntu still does not boot with easybcd.
Finally, got it working. Super.

Maybe you should add some more info on how to select the partition number for Linux/Grub.
Linux is installed in the first logical partition of an extended partition (= partition 3).
I thought the easybcd parameter 'partition' should have been 5 (= first logical partition = sda5), but if I enter 3 (the number of the extended partition) it all works.

Anyhow, great tool, easybcd.
I will now install OSX and hopefully get this one working too.

Keep up the good work.
Oh ok - that makes sense.
So did you have to re-install GRUB? Or if you didn't reinstall it but use partition number 3 in EasyBCD would it have still worked?

This will all be expanded in the documentation, but our very small team is incredibly pressed for time and busy with tens of projects at the moment - but the documentation is coming along, just slowly.

Glad you got it to work though, that's what matters. Good luck with OS X - start a thread if you need help....

(and recommend EasyBCD to everyone you know!!!)

:smile: CG

Thanks for all the help. I put GRUB on a bootsector followed your steps and EasyBCD worked like a charm. I currently quad boot into Vista, XP, Ubuntu, and OSX.


sorry im noob wif this
but how do you go about installing grub in the bootsector of the linux partition
a step by step guide would b helpful