XP + Vista + boot.ini error

#1
Hi there guys,

I have a problem (obviously)
I have Vista Ultimate nad Win XP professional
Vista is @ drive C:
XP s @ drive F:

Firstly I have installed XP and then Vista.

thats how my EasyBCD settings look like:
Code:
There are a total of 2 entries listed in the Vista Bootloader.
Bootloader Timeout: 5 seconds.
Default OS: Microsoft Windows Vista

Entry #1

Name:  Microsoft Windows Vista
BCD ID:  {current}
Drive:  C:\
Bootloader Path:  \Windows\system32\winload.exe
Windows Directory:  \Windows

Entry #2

Name:  Microsoft Windows XP
BCD ID:  {479dbeb0-9c48-11dd-bf41-00218512410c}
Drive:  F:\
Bootloader Path:  \NTLDR
I didnt have boot.ini file neither in XP nor in VISTA, so I did it myself - please tell me if correctly:

Code:
[boot loader] 
timeout=5 
default=multi(0)disk(0)rdisk(0)partition(3)\WINDOWS 
[operating systems] 
multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="Windows XP Professional" /fastdetect 
multi(0)disk(0)rdisk(1)partition(3)\WINDOWS="Windows Server 2003" /fastdetect
And now to the interesting part:

I cant boot from XP, and EasyBCD cant find the boot.ini.
When I try to boot in BIOS, and choose Win XP, then I get an error of boot.ini file :/


What am I doing wrong, coz I'm pretty sure Ive screwed up somewere...


Cheers guys !
S87
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2
Post a screenshot of your Disk Management screen. Only then can we tell for sure.
 

Terry60

Knows where his towel is.
Staff member
#3
#4
Ok,

Now I will reinstall VISTA, coz I made some bad decisions and now it wont start ;]

Will post in few minutes after reinstalling it.

S87

Ok here is my disc manager screen:
My OS language is Polish, so I have translated the most important words...



I shall try Terry's way, anyways Im looking for those files aka XP boot files...
 
Last edited by a moderator:

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#5
Okay language barrier. But from the looks of it the C drive is the boot drive. That is where the XP entry should point to and the NTLDR, NTDETECT and boot.ini files should be located. At the root of the drive not in any folder.

To see these files open Computer>Organize>Folder Options>View Tab.

There select to show all files. Also select to show system files. It is recommended to ahve this on to hide them but the boot files are protected by the system and you need to turn it off to copy them to the Vista drive.

After you copy the files over you can turn that settings back on if you wish. From there if XP doesnt boot it will be because the boot.ini doesnt point to the right partition.
 

JustinW

Super Moderator
Staff member
#6
After copying the files over to Vista's partition, you'll need to change XP's entry in EasyBCD to point to C: (Instead of F: as seen from your first post) since that is Vista's partition.