XP-Vista dual-boot on 'Preloaded' laptop

#1
For the last three weeks I've been battling with a problem:
I want to boot into either Vista or XP on my new Lenovo laptop.

It came with Vista pre-installed in partition 2. Part.1 is ~9Gb, 'Rescue and
Recovery', is at the start of the disk.
Their XP downgrade places XP in Partion 1 and the the R&R partition is
at the end of the disk. i.e. completely different layout.

Lenovo don't supply Windows installation disks, only the 'Rescue &
Recovery' disks, which format the entire disk into two partitions and
installs their distribution.

I've used linux and an external disk to image the two
Windows installs & partition the disk.
Either image restored into their respective disk layout works reliably.

I am not using a Linux bootloader.

I've dowloaded EasyBCD and two CD's to help:
- 'fixntldr' for XP - boots XP and allows selection of an XP image
- neosmart Vista recovery CD (has the Vista 'Repair' boot option)

Currently I have XP in partition 1 with EasyBCD installed and Vista in Part.2.
Vista will boot & allow a login, but doesn't run properly and I cannot
run EasyBCD under Vista.
Paths to system DLL's (Windows\System32) are wrong - it looks like
'system root' points to the XP partition.
After login, Vista gives a series of error dialogs saying (IE) loading
the user profile has failed.

I've rebuilt the BCD on Vista following instructions from:
http://neosmart.net/wiki/display/EBCD/Recovering+the+Vista+Bootloader+from+the+DVD

There is a copy of BCD in \Boot in both partitions.

Using Mbrfix, I've installed the Vista boot MBR on the disk.
I've run 'bootsect': /nt52 for the XP partition and /nt60 for the Vista
Partition.

[Solved: I reran 'bootsec /nt52 c: /force]
Now the thing I find *really* weird:
- setting the 'active' disk to Partition 2, the Vista boot fails.
- setting 'Partition 1' active - XP doesn't boot, but Vista does (in
its crippled state)

The Vista repair disk either says "no fault found" or "unknown error".
When Vista boots, it says "read error" - which I take to mean the volume referred to in BCD is invalid/removed.

Question:
How do I rebuild the BCD in Partition 2 without access to EasyBCD
running under Vista?
 

mqudsi

Mostly Harmless
Staff member
#2
Hi Steve, welcome to NeoSmart Technologies.

You're not alone with the problem where Vista forgets what drive actually belongs to it and which doesn't.. we had several other members with the same problem, which leaves one unable to use Vista since it can't locate its files.

I can't find the link to the solution posted by Microsoft right now, but I'm searching for it.
 

Terry60

Knows where his towel is.
Staff member
#3
#4
Terry,

Thanks for your help. In it's currently mangled state, I haven't been able to get simple programs to run on Vista. But I haven't actually tried to run 'regedit'.

Currently I'm reimaging Vista back into it's "as delivered" volume and will be trying to "generalise" the BCD as described in: http://www.multibooters.co.uk/cloning.html

Will let you know how it goes...

Addendum:

I've run the 'generalise' BCD (change 'device' to "boot") as per the multibooters 'clone' instructions. It reboots fine in the original partition. I've yet to test in another partition.

Darned if I can get Win-XP working in partition 3 (preloaded in Part.1)

No matter what I do, it seems the Vista bootloader remains stuck in the Part.3 bootsector. [I've run bootsect /nt52... many times]

I can show it's the Vista bootmgr:
- if I don't have 'boot.ini', NTLDR & NTDETECT.COM in the *Vista* partition, it fails to boot with "\NTLDR Not found"
- With a 'boot.ini' that should work, it boots through the first XP splash screen (with the animated image), throws up the second splash screen - in which I'd expect to see a "login prompt". But it hangs there... Does not respond to CTRL+ALT+DEL.
- I get this same hang trying to fire up XP from:
- Vista and
- 'Fix Ntldr' boot CD

From Linux's Grub menu (desperation), I see "A disk read error occurred, press Ctrl+Alt+Del to restart" - this is the message I see when Vista Bootmgr has an invalid BCD...

I'm not seen anything on the Net about what vendors do with O/S's they Preload...
I'm wondering if there is some check being done, or a modified executable.

Still confused.

If
 
Last edited:
#5
More progress.

This forum post gives a clue:
http://forum.abit-usa.com/showthread.php?t=63931&page=2

"Damn! I was at my wits end. I said screw it and installed SP2 on seperate SATA channels. Didnt notice any difference in performance but the nagging thought was still there in my mind. Why the hell doesn;t SP2 install on a 16k cluster size?

I then decided to go back to the basics. Paper and pen. Drew the entire installation process right from the copying of files. All of a sudden it struck me - Disk Read error! You get this error only when the MBR is unable to read the partition correctly. So bascially the setup is not even getting to the loader files. It has to be the fricking MBR."

That explains one problem (read error), but not the fix.

It doesn't explain why XP hangs when I attempt to move it to a new partition.
Any pointers there most welcome :smile:
I don't know if that's a 'feature' of preloaded O/S's or not.