XP/Vista issue

#1
Hello!
First of all I want to say, that I've read the XP-Troubleshooting article in the wiki and the sticky topic, but I couldn't solve the problem.

I just got my new laptop and tried to set up a XP/Vista dualboot. First I installed XP and it worked fine. Then I put in the Vista-DVD and installed Vista directly from XP (without booting from the disc). When Vista finished the installation, it re-booted itself. I couldn't boot any OS by this time, because some Asus-recovery thingy booted automatically. I used a live-CD to delete the hidden recovery partition and Vista worked fine, but XP didn't.

Here's a screenshot of the Disk-Management:


I live in Austria, so my copy of Vista is German. I don't think that you guys speak german, so I'll explain it.

1) There's no OS on the E: drive, only data.
2) The Vista partition (C:\) is in an extended partition with E:\. It's logical and it got the boot flag.
3) The XP partition (D:\) is marked as System partition, active and as the primary partition.
4) There's about 10 gigs unallocated space, that was the recovery partition first (I'll probably install ubuntu on it, but I want to get XP and Vista working first :lol:smile:

Okay. When I boot the computer, I can choose between Vista and XP - Vista works fine, but when I boot XP, kind of nothing happens. There's only a little, white line blinking in the upper left corner.
When I boot Vista after trying to boot XP, it says, that some system files may be damaged and that it's recommended that I rescue my system. Vista boots perfecty if I choose "Start Vista normally".

The wiki-article says, a blank screen means, that NTLDR was found, but NTDETECT.COM wasn't. I've placed both files and the boot.ini onto the root directory of the active partition (the XP one - D:\) already, but it still doesn't work. I've also put them into the root of the Vista partition (C:\). When I go to Tools --> Edit Legacy Entries, it opend the boot.ini on C:\. Does this mean, I have to edit that one?

Here's what both boot.inis look like:

;
;Warning: Boot.ini is used on Windows XP and earlier operating systems.
;Warning: Use BCDEDIT.exe to modify Windows Vista boot options.
;
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /NOEXECUTE=OPTIN /FASTDETECT
I hope someone can help me solving my problem.

Thanks in advance,
Garfield

PS.: Sorry for my bad English, I'm still learning this language.
 

Terry60

Knows where his towel is.
Staff member
#2
Hi Garfield, welcome to NST.
Can you copy/paste the output from EasyBCD "view settings" in detailed (debug mode).
Are you sure that EasyBCD/Tools/etc is opening C:boot.ini ? It should be finding the "system" partition.
If you can produce evidence that it's failing to do that correctly, please post it in the EasyBCD bug forum.

and btw, Your English is better than most Americans' on here !
 
Last edited:
#3
Hey,
here's the view-settings output:

Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=D:
path \bootmgr
description Windows Boot Manager
locale de-DE
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {0e5f7141-d2af-11dd-ac90-de09a82d7617}
resumeobject {a50c6d13-d2c5-11dd-91e0-806e6f6e6963}
displayorder {0e5f7141-d2af-11dd-ac90-de09a82d7617}
{0e5f7142-d2af-11dd-ac90-de09a82d7617}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 20

Windows Boot Loader
-------------------
identifier {0e5f7141-d2af-11dd-ac90-de09a82d7617}
device partition=C:
path \Windows\system32\winload.exe
description Windows Vista Ultimate
recoverysequence {0e5f713e-d2af-11dd-ac90-de09a82d7617}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {a50c6d13-d2c5-11dd-91e0-806e6f6e6963}

Real-mode Boot Sector
---------------------
identifier {0e5f7142-d2af-11dd-ac90-de09a82d7617}
device partition=C:
path \NTLDR
description Microsoft Windows XP
Yes, I am quite sure it's the boot.ini on C:\. If I try to open the one on D:\, Notepad shows the error "Access Denied"...it doesn't do when I open the boot.ini on C:\.

Mhh...do you really think, EasyBCD recognizes the right boot.ini? You can change the path to it in Tools/Options. It said "C:\boot.ini" by default, I haven't changed anything.

Thanks for your help!
 

Terry60

Knows where his towel is.
Staff member
#4
Remember that Easy BCD runs with UAC elevation, so it has access where you might not have.
Make a cosmetic change to the C:\boot.ini that you can access directly (change a word in the comment into German for instance), then see if it's there or not in the Easy/tools option, so you can be sure which one Easy is seeing.
Your BCD looks fine, and if you've got the 3 boot files in the "system" root (which you must have,since it is XP (unless you moved them out of course !)), then I can only think that the BIOS is still seeing your deleted partition as 1, and trying to boot XP from a piece of blank disk.
When you're sure that you're editing D:boot.ini (use wordpad (right click - run as administrator) instead of notepad if Easy really isn't finding it) then try different partition numbers for XP and see if the symptoms change. If so, you should hit the right number somewhere between 2 and 6.
(You can't rely on the order that the partitions appear in Disk Management necesssarily, when trying to work out which number to use. The order that you created them in seems to come into it too.)
 
#5
Okay, finally I got it working. (EasyBCD actually did open the wrong boot.ini.)
I had to change the Drive letter for XP in EasyBCD to "D:\" and then I modified the boot.ini to this:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /NOEXECUTE=OPTIN /FASTDETECT
Now everything works like a charm. Thanks for your help, Terry!

Greetings,
Garfield
 

Terry60

Knows where his towel is.
Staff member
#6
I'm so sorry to have let you down Garfield.
I guessed the BCD might be wrong (hence why I asked for the screenshot) and then completely missed the glaring error of the XP entry not pointing to the "system" partition.
The very thing I tell everyone to check in the sticky, and I misread it myself.
Good job you read it properly and sorted it for yourself.
My apologies again. The service here is normally a lot better than that.
(slapped wrist for me - memo to read more carefully in future)

I'll point out your observation of the Easy/tools/edit failure to Guru.
It looks like maybe it's being mislead by a bad pointer in the BCD as you were, and I in turn failed to notice.
This surprises me, as I thought it would locate the "system" partition itself, but CG (as the author) knows the code.
 
Last edited:

JustinW

Super Moderator
Staff member
#7
Yeah that is a little odd... Do you got a boot.ini on your Vista partition that could possibly be the verdict for throwing it off?