XP won't finish its install, tried everything!!!??

Hello. This looks like a great forum with some great support and very good info posted in the wiki sections. I have searched this forum, and many many others and can not find a solution to my issue. I will try to make this long story, as short as possible while still including the important details.

First is the Rig: HP Compaq nw9440, with a WD 750gig Sata.

There is a XP sticker on back of laptop, so I assume XP WAS on it before, however it only came with Win 7 32bit on it, though it said it was not genuine, and I do not have the CD's for those versions. What I wanted to do, was install XP Pro with SP2 slipped on it that I have used a few times in the past including about 6 months ago (I knew there could be a trick or two to this), then afterwards install a good copy of 7 64bit over the bad one.

What I did was use an empty partition at the end of the drive, and started an XP install on it. The drive had a 200meg active primary (with boot stuff), 250gig primary with 7 on it, 250g primary with media on it, and 200 primary with nothing. XP SP2 could see all this.

So, I didn't know at the time but in the Bios Sata Native mode was disabled, and I proceeded to install. The first time, I left the NTFS alone, and XP started loading all its setup files no problem. On the very first reboot, I got an error: Windows could not start because the following file is missing or corrupt: Windows root>\system32\hal.dll

I did some googling on this, and the general consesus and this bullentin Error message: "Windows could not start because of a computer disk hardware configuration problem" seemed to indicate that the path in the boot.ini may be wrong. So with this knowledge, here are all the things I tried, or can confirm:

- I tried starting over and letting XP do a full format of the partition, after deleting the boot files it put in the 200meg partition, no change.
- I tried changing the default path in the boot.ini file to 1-5, and tried changing the actual path as well to 1 - 5. No matter which path I used, I either got the hal.dll error OR hardware configuration problem error.
- I am using XP Pro with SP2 slipped, that I used just 6 months ago so I know its good, or it should be at least, no scratches either.
- Hal.dll and Ntoskrnl.exe are in the Windows folder
- It is a Sata drive and XP sees it and all partitions no problem before the install without doing F6
- Win 7 does not boot, of course, unless I boot from Recover CD I made prior and repair the boot, which works. Then I tried using EasyBCD to add XP, XP still comes up with the same message.
- Once in Win 7, I do see boot.ini, ntdetect and other file in the 200mb system partition that Win 7 made, right where they should be.
- I tried installing NOT giving the 200mb partition a letter, AND giving it a letter, no difference (files were in right place)
- I even tried editing the Boot manager with EasyBCD to include XP, so I get a choice of Xp or 7, still same errors.
- I also tried booting the XP disc and trying a repair install but this goes no where.

So, after all that, I was no further ahead and now this is going on 3 days of hell. In another forum someone suggested maybe the Win 7 not being genuine, it could be interfering with the XP install. It didn't sound logical to me, since no 7 files are called or executed during the XP setup, but whatever as this point I want to smash the laptop to bits.

So, I ZERO out the entire 700gig drive. So now I am starting fresh. I boot from XP CD, it sees the whole drive as empty, I create 3 partitions (and for some reason it creates a 10mb unallocated one at the END of the drive) and I full format the 3rd one (30 gig) and the first one (60 gig) and leave the one in the middle unallocated for now. With both now having NTFS on them I install XP to the 3rd 30gig partition. Can you guess what happens on the first reboot? Yep, I pull my hair out due to exact same error.

So really at wit's end here. I used Partition Wizard and OPHcrack just to boot up at this point, just to check things out. The boot files are on first 60gig partition and its active, XP was on the 3rd partition, but it was "logical" for some reason. I changed this to Primary, and tried to continue install but its a still a no-go.

Any insight would be greatly appreciated, I feel like I have missed something very small from the beginning, and its still missing what ever that is.


Mostly Harmless
Staff member
Make sure to disable AHCI/NCQ in the BIOS?
Make sure to disable AHCI/NCQ in the BIOS?
Hi thank you for reply. I FINALLY got it to work, holy crap what a nightmare.

Turns out it had nothing to do with Sata As far as I can tell. The Bios DID have Sata mode disabled as I mentioned and explains why XP had no issue seeing the drive (though I thought SP2 had Sata drivers included....).

I don't know what was wrong, but my best guess is that I was trying to install to the 3rd or 4th partition each of the two times I tried prior. When it worked this last time, I installed it to the very first C partition.

The only other thing I did differently was slipstream SP3 into the install instead of SP2. I did use the SP2 disc that I was using to do this, so nothing must have been wrong with the disc as I figured.

So either SP3 has something important for my hardware or otherwise that SP2 does not, or installing on the first partition was the solution. When I try to enable Sata mode now it won't boot, so I need to install a driver first and go through a little process, then I should have my Sata running optimally hopefully.