Yet another "Winload.exe invalid signature"

Hi all
When the free WIN7->WIN10 upgrade neared end I gave in and did the upgrade - after all, you could always downgrade again. Well, as many others, I found that WIN10 had some issues with both some games and some of my hardware, so I decided to basically downgrade. But since I wanted to keep my WIN10 installation alive, I copied it to VHD and used EasyBCD to set up dual boot, then restored my old WIN7. That way, I could still boot into WIN10, have it upgraded and see if the time for a cut over had come. Only problem was, that WIN10 boot was sooo slow, because it wasn't on a SSD.
Today I got a 500GB SSD, migrated my WIN7 to that and then copied the WIN10 VHD to the new SSD as well. Unfortunately, I now get the WInload invalid signature error other people has written about. This occurs both on the new VHD, but strangely also on the old one - and that HAS been working.
A post from Terry60 have lead me to believe that the BOOTMGR file is the culprit and sure enough: Both on my C: drive and the System Reserved partition on the same disk, it has a file date of 22-11-2010, whereas any BOOTMGR file in the VHD is much younger. But on those BOOTMGR files that has an extension, you can the their certificate - end that expired on nov 18, 2016. Does this have anything to do with my problem?
Now, the logical thing to do would be to replace BOOTMGR on C: and System Reserved with one from the WIN10 VHD...but with one, and what would be the smartest way to do it
Sorry for the length of the post, BRGDS
Sven Sorensen, Denmark
Hi again
Problem solved - sort of...
I have come to realise that my PC has more than one way of booting (as well as multiple locations).
Replacing the bootmgr files caused my multi-boot to disappear. However, while fiddling around with it, I accidentally chose another boot location and lo! and behold: The old WIN10 VHD booted up. Great, now I just need to add the new entry for WIN10 on my new SSD. But when starting EasyBCD I got the "This is an EFI boot" warning, something I did not see when using EasyBCD on my WIN7. Still; I could add the new entry, and the new WIN booted fine.
Unfortunately, I cannot say the same for my WIN7. Here I get "WINLOAD.EFI" missing or invalid when choosing the same boot location.
SO: When I need to boot WIN10, I must change the boot location, and it will give an EFI boot. But my WIN7 installation requires a non-EFI boot...
This is a mess, but I can live with it. It's just not very elegant, but I don't think I'll go into changing my WIN7 installation to an EFI aware thing, as I'm quite sure that will cause all kinds of grief.
Thanks for reading, and of course, I'm open to suggestions.
Sven Sorensen


Knows where his towel is.
Staff member
I had W7 and W8.1 dual-booting in UEFI GPT mode on SSD when W10 beta was around.
I didn't want to replace either with a Beta OS so I installed W10 on an MBR HDD.
It was quite happy to triple-boot the two older systems from W10's MBR bootmgr, using the Winload.exe loaders.
W8 has since been upgraded to W10 (W7 is still my OS of choice) and now controls the dual-boot using the .efi bootmgr via the Winload.efi loaders.
Your problem is that you can't do the reverse (W10 from W7 MBR) because of the "inv dig sig" problem, and W10 from UEFI won't boot an MBR OS.
The only option is to update the W7 bootmgr using W10's version (bootmgr, not bootmgr.efi) and let it dual boot via the Winload.exe from each OS.
Hi Terry
Thanks for your input.
I've managed to get it working as I would like it to, but my problem was that I don't have a WIN10 CD (as it was the free update).
But I do have a WIN2012 server core, and so I went and installed a dummy server in a VHD. Hey, presto - that gave me a new BOOTMGR, and all I needed to do afterwards was to insert the Boot Entries for my old WIN7 and my WIN10 VHD.
Case closed, thanks again!