2.0 b76 bootgrabber issue/fix

#21
When I tried to use the new bootgrabber, I got so many messages I did not know what to look for. Overflows and some other things. Now that I know it is a debugging version, I will try it again tomorrow.

I have still not been able to get the normal bootgrabber to fail. :happy:
 

mqudsi

Mostly Harmless
Staff member
#22
Well if you formatted and changed everything, then bootgrabber.exe now works (debug or normal won't matter).

I guess I have no way of finding out where it was failing :frowning:
 
#23
Here is what I think you were asking. The picture is the error message, which is different from the original one, but still a problem. Once again, ntldr and ntdetect are put in the System Reserve partition, but not boot.ini.

Any feedback as to what these dumps might indicate so I can look in a more specific area, or at least not change something that would effect the outcome?

Sorry I changed some things around, but I did not want you going to a lot of trouble if the problem was just with my setup.
 

Attachments

Last edited:

mqudsi

Mostly Harmless
Staff member
#24
Actually, it's th exact opposite: it's not just you and I can't release 2.0 until I get all BootGrabber.exe crashes fixed.

So your help here is very much appreciated, it enables me to pin down a bug that I cannot track down myself on my own PC because I just don't experience it.

The zip file you just uploaded, this is from the debug version that I posted earlier?
 
#25
The zip file you just uploaded, this is from the debug version that I posted earlier?
Yes. It threw me at first because the message was different. The other one actually said bootgrabber, this one does not.

Just to make sure, I moved the original bootgrabber to another folder on my desktop and dropped in the new one you supplied to the bin folder. Hope this is right.

It is strange it worked several times in a row. In between, I had removed both hard drives, put my old one back in and loaded Fedora. Then I replaced the Win 7 drive and set it to primary. After that there were numerous attempts to get Fedora to boot using EasyBCD 2.0.0.79. Your Wiki was down, but I got it to work by putting a drive letter on the System Reserved partition.

When I replaced the XP drive, the first attempt to use EasyBCD, with the subsitiute bootgrabber, failed.

I just hope my system is not a problem, it is from 2002 and seems to have some quirks when it comes to forgiving problems with hard drive formatting.
 

mqudsi

Mostly Harmless
Staff member
#26
Last edited:
#27
The new file, 589K was put in place and the result was this message. There were two more after this one, then the Boot helper failed message. The zip file contains 2 minidumps. A7B6 was taken for bootgrabber after the message. The other one was done after ignoring the messages and allowing the process to fail.

All I have to do to get the failure is to go to tools, and try to "Auto Configure boot.ini"
 

Attachments

mqudsi

Mostly Harmless
Staff member
#28
Whoops!

I was referencing some old code from before last nights rewrite..... just changed the reference.

The good news? We're *almost* there!!


Could you try this new build, please? Hopefully this'll be the one :\
 

Attachments

#29
It does not crash, but it does not put the boot.ini file in the System Reserved Partition, with or without a letter.

I also noticed the new bootgrabber file has a shield on it, whatever that means...
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#30
Excellent news :grinning:


Does it create a file anywhere else?

Please open your register to HKLM\System\Setup

What is the value of SystemPartition?

Also

EasyBCD | Useful Utils | Power Console
Code:
BootGrabber.exe /bootcfg %the value from SystemPartition in the registry%
Copy and paste the results here?


Much appreciated!
 
#31
OK..Hopefully this is correct.

If I do not put the % marks on the command, the failure message goes away.

I only have 2 boot.ini files from today, and both are in a \Recent folder.
 

Attachments

Last edited:

mqudsi

Mostly Harmless
Staff member
#33
Sorry about that - I did not mean that you should write the "%" in the text.

In your case, just type:
bootgrabber.exe /bootcfg \Device\HarddiskVolume3

:smile:
 
#34
I did it that way also. I just noticed, there is now a boot.ini file in the System Reserved Partition. I will do it again to make sure.

I have done it twice more and the boot.ini file was placed in the correct location
 

Attachments

Last edited:

mqudsi

Mostly Harmless
Staff member
#35
OK, so for the final test: delete all the boot.ini files, stick bootgrabber.exe in the bin folder, and have EasyBCD autoconfigure.... hopefully everything will be a-OK?
 
#36
Looks like it is working. I will try it again in the next couple of days and then reinstall everything and start over.

If you have any input, try to warn people about trying to install XP with the System Reserve Partition in place.

Thanks.
 

mqudsi

Mostly Harmless
Staff member
#37
Awesome. The goal of BootGrabber is to make the dual-boot work regardless of system reserve or not - thank you SO MUCH for your help :grinning: