Advanced settings - Drive selection does not save

EasyBCD 2.02 on windows vista home premium x64

1= new boot entry added
2= saving the new drive selction in advanced settings
3= overview confirming change has occured
4= after reboot of program, change is gone, indicating that the change was never truely implemented. confirmed by the fact that the lnux boot entry is looking on the wrong hard drive for its bootloader



Knows where his towel is.
Staff member
Why did you change the letter in advanced ?
What were you trying to do ?
Linux partitions don't have letters, that entry is pointing to the NST Neogrub bridge to the automatically located Linux.
What Linux are you using ?
Are you sure it uses legacy grub ?
Ubuntu 10.x uses grub2.
Last edited:
I admit that I know little about linux, but I tried all other variables and legacy grub seems to get the closest to working. It is Ubuntu 9.10. If this is not a bug and it is correctly targetting the linux partition, why can I not get a proper boot? I either enter a command line mode in which the kernal has not loaded, or get a flashing bar like the one you see when a computer is loading a disk just before you get the press any key prompt. I have been unable to get past either. I can change the boot priority in bios to select the linux drive and it works fine, but I would like to boot to the windows boot manager and be able to select from there.


I apologize for the misinformed post, I just read your PLEASE READ in the other forum. I just followed links from the application.
Last edited:


Knows where his towel is.
Staff member
So it's OK now ?
no, it still won't allow me to dual boot properly, but it is likely that it is caused by something on my end and not a bug in the program. The only problem that I see however is that windows does not recognize the hard drive that linux is on, it says that it is not a mounted volume.


Knows where his towel is.
Staff member
Windows doesn't recognize Linux file systems, but EasyBCD bootgrabber does.
Ubuntu 9.10 uses grub2.
Select that and let EasyBCD locate it automatically.
Did that, still didn't work. I've tried every combination with no success. I'm not sure what is causing it, but all I get is the screen with command line options, most of whuch tell me that the kernal needs to be loaded before that action can occur. Changing boot sequence in BIOS still works fine
Last edited:
I'm a new user (few minutes!) :wink: Thanks for great program. I had XP installed, then installed Win7-64bit on second primary partition, then lost it when I did repair install of XP (default OS). Download and ran latest v2.0.2.117. Not sure if my issue is related to this thread, but seems like it.
Running under XP, I attempted to change name of profile (BASIC tab on ADVANCED SETTINGS) from
"Windows 7" to "Windows 7 (64 bit)". When clicking SAVE, I got a standard XP fault. Sent debug info to MS.

Finally successful when I assigned drive letter to Win7 primary partition. This same operation failed every time (very reproducible) when no drive letter is assigned to Win7 partition (even though EasyBCD detected the partition, etc as "Device: \Device\HarddiskVolume2")

Going to Diskmgmr.msc and assigning a tmp drive letter to the Win7 partition, then allowed
EasyBCD to save the new name, etc.

Great program, keep up the great work!


Knows where his towel is.
Staff member
Why were you using "advanced" ?
renaming an entry is a standard feature of "edit boot menu"
In advanced there's a "drive" parameter (kept out of "edit..." because it's not something that should be changed normally) and if the partition doesn't have a letter, it can only be specified as "boot". What did you specify ?