Application Unable to start (0xc000007b)

#1
I am running Windows 7 x64 and when I try to start easybcd 2.0 Build 76 I get the following error. The application was unable to start correctly (0xc000007b). I had a dual boot machine with 2 copies of XP on different partitions (Hard Drives). One I used for applications and the other strictly for gaming. When I installed the Windows 7 x64 upgrade disk to my primary load C: it wiped out my boot option to my second install of xp D: and I would like to use easybcd to fix this. I currently can only boot to Windows 7 on the C: drive. Note: it appears that drive D: may be the active partition. Thanks for any help you can suggest. Dave
 

mqudsi

Mostly Harmless
Staff member
#2
Double-check your .NET installation (uninstall any manually-installed .NET distributions) and try again.
 
#3
I uninstalled 3.5.1 that came with Windows 7 and rebooted. Then I installed Netframework Beta 4.0 and rebooted. When I tried to run easybcd 2.0 build 76 I receive the same error code (0xc000007b). I am not sure what to do at this point?
 

mqudsi

Mostly Harmless
Staff member
#4
Try without install 4.0... EasyBCD is written with .NET 2.0 which theoretically should be preinstalled on 7 and require no further work on your behalf, but clearly that is not the case.
 
#5
I downloaded Netframework 2.0 x64 from miscrosoft and tried to install it and came up with a message that it was allready installed as part of the operating system and not needed. Will try and remove 4.0 beta.

Addendum:

Removed Netframework Beta 4.0 and still receive the same error code. Not sure what to do at this point.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#6
This error means that Windows wasn't able to load the binary file. Programs written with .NET need to be pre-loaded by the .NET Framework, so if it's not working properly this is the sort of error you'd expect to see.

While I'm betting it's an issue with .NET 2.0 not resolving correctly (you're not the first with this problem), a Google search on the matter seems to indicate that certain malware may also cause this problem to appear.
 
#7
I scanned the system with Zone Alarm security suite and AD-Ware and did not find any problems. I first tried to run Easybcd before I loaded very many apps trying to figure out the dual boot trouble. Is there another free app that uses Net framework 2.0 that I can try to run to see if all apps may be blocked or have trouble that use 2.0?
 

mqudsi

Mostly Harmless
Staff member
#10
Interesting - now why would ZA interfere?

You wouldn't happen to have a link to that thread, Justin, would you? I couldn't find it by searching for ZA...
 
#11
iReboot did not want to run also. Rather than give up my ZA protection it occurred to me that I could reboot in safe mode and see if EasyBCD 2.0 would run. The program ran like a champ. I installed the missing boot options and ntrl files. Rebooted and now have both OS options available. My advice to other Windows 7 x64 users is just to run the app from safe mode and all is well. Hats off to the creator of EasyBCD!!! Job well done. I guess it still does not answer the question that ZA may be the culprit, but an easy fix. Thanks again - Dave
 

mqudsi

Mostly Harmless
Staff member
#12
And a big "you're welcome" back from the creator :smile:

Glad it worked, was going to suggest Safe Mode but then I recalled that once upon a time EasyBCD wouldn't work in safe mode and couldn't remember if I had fixed that particular bug or not... guess I did :smile:
 
#15
Hi Guys, I just posted a new thread on this - it's the Force Field part of ZA Extreme security - it runs as a service and doesn't unload even if you unload ZA from the systray.

You need to kill ISWSVC.exe and EasyBCD will start.

I've posted a question on the ZA forum as to why Force Field would do this - but not holding my breath!!

One other "odd" thing is that I have the exact same ZA version installed on XP and EasyBCD works fine there - no idea why that would be....
 

mqudsi

Mostly Harmless
Staff member
#16
Hey Dave!

Thanks for sharing that with us... interesting indeed. So what's the purpose of the ZA ForceField?
 
#18
Hi Yepper,
I've got ZA Extreme security - so possibly different but as I say - use task manager (or SysInternals Process Explorer - better than task manager) to see if ISWSVC.exe is running, if it is kill it and EasyBCD will start - but be quick before ISWSVC.exe restarts.

If you don't have ISWSVC.exe running, try just uninstalling ZA and see if EasyBCD works - who knows there may be other ZA components that have this effect...

CG,
Force field is ZA's browser security stuff - runs browser in virtualisation - don't know much more detail than that. I'm going to log this with ZA support - so far just on their user forum.
 

mqudsi

Mostly Harmless
Staff member
#19
EasyBCD only uses the internet once a week to check for an internet update... But it's nothing to do with this, since the error isn't actually in EasyBCD - it's *Windows* telling you that it's failing to load the binary EasBCD files (and usually this message occurs because the .NET library which is used to virtualize the binary .NET executables is unavailable).


But anyway, that was pretty obvious from when Yepper said that iReboot would also not run - looks to me like ZA ForceField is stopping all .NET apps from running! :S
 
#20
I checked my services in task manager and I have iswsvc.exe running. I can not stop it in task manager. I will have to stop it in services. Thanks