bcdedit.exe hangs in detailed view

SIW2

Distinguished Member
LOL. Was just about to post I know what it is.

Partition1 Vistx64(C)

Partition2 7 x64(D)

I have Easy installed on both.

I am using the bcd store on D

No matter which I am booted into I get the unhandled exception tying to add .wim.

The fix is to put a copy of boot.sdi in the NST folder of the partition whose bcd store you are using.

So I put boot.sdi in NST folder on D. Success.:lol:

Easy seems to use the NST folder of the partition whose bcd store you have loaded.?
 

mqudsi

Mostly Harmless
Staff member
Exactly.

There is an error in copying boot.sdi over, so if it's already there, you won't get the crash :smile:
 

SIW2

Distinguished Member
Great - now that is working.

All is good.

Still can't get these Linux iso's to load - they boot , but that's it. WinPe .iso's seem ok so far. Shame. That's not to do with Easy as they actually boot - except that PM10(Paragon Partition Manager Linux based .iso) . That seems to be a PLOP issue , as PLOP appears instead.

I have PM10.iso on a logical drive - no idea why that should make a diff. Will put it somewhere else and try again.

Addendum:

It seems to go to PLOP if it doesn't like the look of the.iso

I just tried a different ( Linux based) .iso. First added the entry for Logical drive G.

On selection , Plop appeared.

Then put that same .iso on Primary partition D - added it there.

On selection - PLOP comes up again.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
Hmmm, I have Acronis Disk Director 10 ISO working and it's Linux based.

Try putting the ISOs on your system boot drive and try again? Perhaps it has something to do with logical drives, etc.....

If only there were a common ISO we could both try.

Addendum:

OK, try build 71, which was attached to this post here: Exception when selecting wrong entry under External Devices - The NeoSmart Forums

It should fix the WIM crash.
 
Last edited:

SIW2

Distinguished Member
I have a lot of Paragon stuff. I tried one of the WinPe .sio' - boots and loads fine.

It is the Linux one's that won't. One or two will boot and hang trying to load.

Most will just go straight to PLOP.

I could upload a small one to Dropbox , or similar.


Hang on - I'll try the free rescue kit Express from the Paragon site - see if that causes it - if so, you could have a go with it.



This is weird:

rk90_express.exe

I put the .iso from rk90 on C drive - added the entry. On selection - it boots a completely different one - the DB10 .iso ( which boots, but doesn't load properly ).

Should I try deleting bcd hive on D and start afresh?

EDIT: Build 71 is not starting. Same thing again - it shows in Task Manager , along with bcdedit.exe - but no GUI.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
Check if build 70 will hang on run.. I think it too will, because I didn't make any changes between 70 and 71 that would affect that behavior.

Addendum:

With regards to the ISOs, what's happening is that it's "rolling over" to the next entry when the first one doesn't work.
 
Last edited:

SIW2

Distinguished Member
Makes sense with the .iso's.

So, if none of them work - then PLOP opens - as it is the next entry?

Where is build 70?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
I don't see how the 10th differs from any of those before it :S

Try adding another entry.. say a Vista one (doesn't matter where it points to or anything). Does EBCD still hang?

Addendum:

Nevermind, I get the same thing on my PC... For some reason it hangs if there are 10 entries :S

Addendum:

OK, found the issue.... EasyBCD was deadlocking the system because bcdedit's buffer was overflowing.

Will fix in a minute..
 
Last edited:

mqudsi

Mostly Harmless
Staff member
OK, fixed.

Please see the attached EasyBCD 2.0 Beta Build 72 and verify that fixes the hang issue for once and for all.

:x
 

Attachments

  • EasyBCD 2.0 Beta - Build 72.exe
    1.2 MB · Views: 1

SIW2

Distinguished Member
This build is working really well for me.

The only thing is these Linux based .iso's.

Most of them won't boot at all- Plop comes up.

One Paragon Linux/Dos.iso will boot - but it won't actually load.

The Acronis Maxblast.iso (ATI 11) will boot - but it refuses to work. It claims I don't have a Maxtor/Seagate drive.

That's atrocious - I do have those - that's what I am using.

Good job I never needed to use it in a disaster situation . Big thumbs down for Acronis.

At least the Paragon Linux/Dos work from cd/usb and let me get to the recovery options.

I booted a Paragon WinPE .iso from the HD - works fine.
 
Last edited:

SIW2

Distinguished Member
Will try again now - with 72.

Addendum:

Yes - the RK90 - boots and loads just fine.

it was the 13th entry. I put it on the system partition .

Also tried the Paragon DB10 Server Linux/Dos.iso - also put it on the system partition. Booted fine. Long time loading 2 -3 minutes - then Success.

Seems to only be a problem booting them from a logical drive. Tho I haven't tried that with build 72.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
Great. Stick them on a primary partition then and problem solved :smile:

I reckon that addresses all the issues raised/covered in this thread? Can I close this as "fixed?"
 

SIW2

Distinguished Member
Absolutely - all working well with this build - so far. lol.

Great work. You have had a busy Sunday.
 
Top