Begginner having trouble dual booting

#1
Ok I installed Win 7 while my XP drive was disconnected then reconnected the XP drive and set the boot order in Bios to now boot from the Win7 drive. I then Installed EasyBCD 2.0 63 to Win7 and added the XP entry.
I'm not able to boot into XP and I think the problem is in my boot.ini file/s ?

Win7 Boot.ini said:
[boot loader]
timeout=20
default=\WINDOWS
[operating systems]
\WINDOWS="Windows XP on V:\" /fastdetect
XP Boot.ini said:
[boot loader]
timeout=0
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
C:\ = "Unidentified operating system on drive C."
Both partitions have the ntdetect.com and ntldr files on them although I see the file dates on the XP partition are old 2004 and 2006 and the file sizes of ntldr are different (245kb & 291kb)?
My Win 7 is Disk 0 partition 1 and XP is Disk 1 Partition 1 and I have attatched a pic from "Disk Management" for diagnosis.
I have removed and added the XP entry several times and don't see any change to boot.ini? Am I missing something basic?
Any help would be much appreciated.
 

Attachments

Terry60

Knows where his towel is.
Staff member
#2
Hi M, welcome to NST
That C:\boot.ini is clearly incorrect.
Did you let Easy2 auto-configure the XP entry for you ?
or have you been making manual interventions of some kind ?
Can you copy/paste the contents of the EasyBCD "display settings" output in debug mode.
 
#3
Hi Terry and thanks for replying. No I haven't made any manual changes to anything but from the file dates on the XP partition I suspect EasyBCD hasn't made any changes either???? The info in boot.ini also looks left over from when XP was first in the boot order?
Debug Mode said:
Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=C:
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {f7c05e86-886c-11de-8105-d363d4ae7863}
resumeobject {f7c05e85-886c-11de-8105-d363d4ae7863}
displayorder {f7c05e86-886c-11de-8105-d363d4ae7863}
{f7c05e8a-886c-11de-8105-d363d4ae7863}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 30

Windows Boot Loader
-------------------
identifier {f7c05e86-886c-11de-8105-d363d4ae7863}
device partition=C:
path \Windows\system32\winload.exe
description Windows 7
locale en-US
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
recoverysequence {f7c05e87-886c-11de-8105-d363d4ae7863}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {f7c05e85-886c-11de-8105-d363d4ae7863}
nx OptIn

Real-mode Boot Sector
---------------------
identifier {f7c05e8a-886c-11de-8105-d363d4ae7863}
device partition=C:
path \NTLDR
description Microsoft Windows XP

Addendum:

As I never mentioned the actual error message I get when I attempt to boot into XP I thought I'd do that now while I wait for some help.
XP Boot Error said:
Windows could not start because of a computer disk hardware configuration problem.
Could not read from selected boot disk. Check boot path and disk hardware.
Please check the windows documentation about hardware disk configuration and your hardware reference manuals for additional information.
This message stays on the screen until I press a key and then the pc reboots.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#4
I can't see any reason why that shouldn't work perfectly. There is an intermittent problem in that build with anonymous W7 boot partitions which doesn't apply in your case.
You could try one of the slightly earlier builds and see if that configures correctly, if not we'll have to go back to the old fashioned method of configuring boot.ini manually.
If you have to resort to that, copy the version from XP to W7 and edit rdisk(0) to rdisk(1) in both places it occurs.
 
#5
I've tried 2 earlier 2.0 Beta versions with no change to my boot.ini files so it looks like I'm going to have to do it manually.
Regarding the boot.ini on my XP partition:
Q1, Should this boot.ini mention both OS's?
Q2, My existing XP boot.ini has a timeout=0, should that be changed to 30 ?
Q3, How do I make XP the default OS (might change this once I get more programs installed in Win7).

Q4, Am I correct that
XP is on multi(0)disk(0)rdisk(1)partition(1)
and
Windows 7 is on multi(0)disk(0)rdisk(0)partition(1)
Basically I think I need someone to tell me exactly what should be in my boot.ini but I do wish to understand what I'm changing and why.

Thanks in advance
Mike.
 

Terry60

Knows where his towel is.
Staff member
#6
boot.ini has nothing to do with W7. It cannot be made to boot it. It shouldn't be mentioned.
You've only one XP system, delete the other line.
Timeout is irrelevant with a single OS. Either timeout(0) or having a single entry will mean that no menu is presented, and the default (only) entry is taken immediately.
rdisk(0) is always the HDD you're booting from, so C:\boot.ini must point to the other HDD where XP actually resides (hence rdisk(1))
Try this for reference.
 
#7
FIXED

After modifying the boot.ini on both partitions to match the info from "Disk Management" if I choose to boot into XP I would get a short 2 line error which flashed up very quickly:
Invalid BOOT.INI file
Booting from C:\windows\
Then it would reboot. The only way to read it was to capture the pc screen with my digital camera so I could pause the playback and read it.

What was happening was Windows 7 and the "Disk Management" tool were masking an error I had made days earlier. I have been an XP user for many years and I wanted to have both XP and Win7 start up as C:
To achieve this (after reading another post here) and because I have several hdd's I decided to disconnect my hard drive with XP on it and then install Windows 7 on a different drive. As my computer case is not the easiest to access I attempted to do this by disabling the drive in BIOS only. When I first ran Windows 7 setup it was offering to Upgrade so I aborted and shut the pc down and took the plunge of disconnecting the sata cable to the XP disk.
After installing Windows 7 I shutdown the pc, reconnected the sata cable and restarted. In all this process I never enabled the drive containing Xp in Bios (Gigabyte EX58 Extreme Motherboard) and because Windows 7 and "Disk Management" showed the drive I never had a second thought about it.
Only after going back into bios to change the boot order to make the XP drive the boot disk (and finding it missing from the list) did I remember what changesI had made some days ago in Bios. So after setting the Sata Ch back to "Auto" in bios and putting the drives in the correct boot order then rebooting back into Windows 7 and running EasyBCD again it all worked as designed. EasyBCD made the correct changes and copied the files where they belonged and I am now able to boot in to either OS. I hope this explanation of what I did wrong helps others as well as explain why EasyBCD did not appear to work correctly in this situation.
Thanks Terry for your patience and help.

Best Regards
Mike.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#8
I think you misunderstodd my earlier post. When I said
"copy the version from XP to W7 and edit rdisk(0) to rdisk(1) in both places it occurs".
I meant both places in C:\boot.ini, not on both HDDs,
You shouldn't have changed V:\boot.ini. That only gets used when you boot the XP HDD directly, in which case rdisk is (0). You leave the version on XP alone so that you can always boot that HDD by changing the BIOS boot sequence should W7 ever break. rdisk(1) on V:\ will stop you being able to boot XP directly.
The C:\boot.ini you posted looks perfect.
If it's saying there's an error, is there any problem I can't see ? For example spaces where there should be none, or lack of spaces where there should be one.
Otherwise there's something very weird happening on your system. You're the first person for whom Easy2 fails to auto-configure, and even a manual edit fails when it apparently contains the correct information.
Check the syntax with a fine-tooth comb, and put the V:\boot.ini back to rdisk(0) and see if XP boots when it's first in the BIOS.
What are you using to edit boot.ini ? Not a word processor that's putting invisible formatting information into the text ?
 
#9
Hi Terry, Thought you were offline so when I found my error I edited my previous post to explain what I had been doing wrong to cause my problems. I did misunderstand you earlier and will have to change my Boot.ini on the XP drive back to rdisk(0) so thanks for pointing that out.

Best Regards
Mike.
 

Terry60

Knows where his towel is.
Staff member
#10
Great! I knew there must be some explanation, but nothing was visibly wrong in your posts so it was a difficult one to figure. Glad you've now seen Easy2 doing the business as intended.