Boot Trouble

#1
This is going to sound a little odd, but I can't quite seem to get a grip on this issue. I am running Vista Ultimate. I have a single drive made into 3 different partitions. These partitions were then converted to dynamic disks. I also run MS VPC. I have an XP VM I use for testing purposes and what not. I decided to install WUBI to this VM. After the installation I shut it down. Later on I ahd to reboot my host computer for something and when it attempted to boot back up I received all kinds of Grub errors and could not locate my vista install and could not load linux without compiling the kernel. This really threw me off as I had intalled wubi in the virtual, not on my vista machine. I booted to WindowsRE from ym vista disk and checked things out and on my root drive I have a grldr file. I believe this is associated with Grub. I cannot get it to boot into anything. Throughout my "poking" around, now when I boot my machine I get no errors at all.... it just doesn't boot. It will say attempting to boot from hard drive and jsut sit there. If I bot from Vista DVD and go into RE I try to run bcdedit I get an error saying it cannot find it. I run bootsect /nt60 c: and it returns success. I run bootrec /fixmbr and it succeeds/ I run bootrec /fixboot and it tells me that my volume does not contain a recognized file system, yet vol command and diskpart reveals volume is ntfs still. I run bootrec /rebuildbcd and it finds my c:\windows directory, but when trying to add ti to the list it gives an error saying the specified path could not be found. bcdedit shows same thing, specified path could not be found. It is like all boot configuration info has been wiped from my machine. I have tried copying it from the DVD and from other Vista installs to no avail. Each time I try to recreate the system store it will not let me and gives various errors. I can easily reintall as I did not have much loaded but I would like to try to figure this one out. If anyone could help I would greatly appreciate it. Thanks!
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
Hi cspclay, welcome to NeoSmart Technologies.

Give this a shot:
Boot from the Vista DVD | Repair Options | Command Prompt:
Code:
del c:\boot\ /f /s
bootrec /fixmbr
bootrec /rebuildbcd
exit
Should do the trick. Good luck.
 
#3
Thanks for the help, I appreciate it. But that is something I have already tried. I have ran bootrec /fixmbr, /fixboot (which errors out), and /rebuildbcd (which finds my C:\windows direcotry and asks to add it to the boot list but when I select yes it errors out saying the specified file could not be found.) It is almost like the default system bcd store is gone. I cannot even use the bcdedit /createstore command to create a new store, I receive the same error saying the specified path could not be found. I have deleted the boot folder numerous times and tried those various commands in many different orders to no avail. When I boot into the recovery environment and choose the repair option, it brings up the screen to select the installation you wish to repair.... but I have no installations listed. I tried running an offline restore on it which also did nothing. thanks!
 

mqudsi

Mostly Harmless
Staff member
#4
Notice the first line with the delete command, that should address this issue.
 
#6
Also, I currently do not have a boot folder on any of my volumes and when running bootrec /fixmbr it completes successfully but the /rebuildbcd gives the same old error message that the specified file could not be found. Running those hoes not seem to be rebuilding or recreating the boot folder. Thanks again for your help with this issue.
 

mqudsi

Mostly Harmless
Staff member
#7
OK, time to do it manually.

Code:
del c:\boot\ /f /s
mkdir c:\Boot\
xcopy c:\windows\boot\pcat\* C:\boot\ EXCLUDE:bootmgr /E /C /Q /G /H /R /Y
xcopy c:\windows\boot\fonts\* c:\boot\Fonts\ /E /C /Q /G /H /R /Y
copy c:\windows\boot\pcat\bootmgr C:\Bootmgr
bcdedit.exe /createstore c:\boot\BCD
bcdedit.exe /create {bootmgr} /d "Windows Boot Manager"
bcdedit.exe /set {bootmgr} device partition=C:
bcdedit.exe /timeout 5
bcdedit.exe /create /d "Windows Vista" /application osloader
# You should get a message saying {ID} was created successfully. Use {ID} in future commands.
bcdedit.exe /set {ID} osdevice partition=C:
bcdedit.exe /set {ID} device partition=C:
bcdedit.exe /set {ID} path \Windows\system32\winload.exe
bcdedit.exe /displayorder {ID}
bcdedit.exe /default {ID}
bcdedit.exe /set {ID} systemroot \Windows
exit
No guarantees, but that should do the trick. If it doesn't we'll at least know which step errors out and we can debug it from there.
 
#8
I followed your directions but still nothing. Everything works up until the bcdedit.exe /create {bootmgr} /d "Windows Boot Manager" line. That step fails out with "The boot configuration data store could not be opened. The system cannot find the file specified". If I use the /store switch and manually tell it to use the store created in the step prior it works fine, as do the rest of the commands, but having to specify the store to execute them on still leaves the system unbootable. If I run the bootrec /fixboot command it gives me an error saying my file system is not recognized, but it is ntfs. When going to the repair option from the Vista DVD at the prompt to select which OS to repair, I have nothing in that box to select. Not sure if any of this info helps or but there it is. I appreciate all your help with this. Like I said, I could easily format it and reload it but I really would like to figure out what went wrong and how to fix it. Thanks!
 

mqudsi

Mostly Harmless
Staff member
#9
I really don't know what happened to your machine to put it in this condition - deleting C:\Boot\BCD should have cleared the original system store yet it is obviously refusing to disappear.

It sounds like a previous failed install, a improperly set-up MBR/bootloader, or a dozen other things - I really have no clue.

Best thing to do is to zero out the MBR (formatting the partition doesn't do that).
EasyBCD ships with a tool called MbrFix.exe - you can run it from the RE too if you like:
Code:
cd "C:\program files\neosmart technologies\easybcd\bin\"
mbrfix.exe /drive 0 clean
That will totally zero out the first drive you have installed (removing all partitions on it and the bootloader too).
 
#10
I appreciate your help. I have a lot of information on my other two partitions I need to keep so zeroing out my drive at this point isn't an option. I will remove and recreate my c partition and reinstall and see if that does any good. I haven't used EasyBCD before but if it is like most programs and requires installation I am still out of luck as I can't currently install anything due to the installer service not being found. I was hoping to avoid reinstalling but I reckon I don't have much of a choice. thanks again for all your help and efforts.
 

mqudsi

Mostly Harmless
Staff member
#11
It doesn't use the Windows Installer Service, it just extracts itself to the correct directory (based on NSIS setup).

Good luck.
 
#13
I found this thread with google as I was trying to research a solution to this problem, and I thought I'd share the solution I figured out. The problem is that the drive he is trying to install the boot manager on isn't marked as active or system (explaining the message "The system cannot find the file specified")

Use diskpart to select the primary partition of the drive you want to boot from and type "active" to mark it as active. To further mark this drive as system, just use the bootrec /fixboot command. Finally, use bootrec /rebuildbcd to register the windows installation.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#14
Hey dejooles, welcome to NST.

Thanks for sharing your feedback, I'm sure it'll come in handy for others with the same problem!
 
#15
Thanks a ton!

Hey I wanted to say thanks for the help! I had this exact problem, and due to computer guru's help all the way trhough and especially dejoole's info abuot dispart at the end (although I had to go to http://www.mydigitallife.info/2007/...lternative-in-windows-vista-2000-2003-and-xp/ in order to find out how to work it), I finally got my computer running again! I usually don't just register because I'm too lazy, but as I would have been in a very tight spot (as I need my laptop for various things), I decided to register to thank you!

Anyway, thank you all very much (I guess i should also thank cspclay for actually having the problem before me so taht I could ifnd an answer!)

-David
 

mqudsi

Mostly Harmless
Staff member
#16
Hiya David!

Thanks for registering and for those kind words - it's always our pleasure to be of help. If there's anything more we can do for you, just post away :smile:
 
#17
Similar problem...

So I have a similar problem to the initial post in this thread. I am (errr... was) running Windows Vista Ultimate and had just converted my vista hdd to a dynamic disk when I attempted to install linux mandriva 2008.1 on a separate, empty hdd. Upon restarting, grub was all messed up and I couldn't boot anything. After another restart grub had disappeared entirely, and no boot into vista. At this point, I would really like to simply restore my ability to boot Vista, however I get a disk read error upon booting. I've attempted all of the relevant functions of bootrec.exe; /fixmbr is successful, but /fixboot results in "the volume does not conatin a recognized file system". The command /rebuildbcd results in "the system cannot find the path specified". I've tried rebuilding manually, as was suggested, however it appears my system will not delete any files; upon attempting the second command to make the C:\boot directory after using the del command to remove it, I'm informed that there is already a folder named c:\boot (so nothing was deleted at all). Are there any other steps that can be taken, or am I pretty much hooped and should just reformat and start again?
 

JustinW

Super Moderator
Staff member
#18
You did try the automatic start up repair option first, right?

A lot of the time, Windows does not play well with modifications to its disk type or hard disk controller. Since coverting it back to a basic disk would require deleting the partitions, this wouldn't do you any good.

In this case, a re-format and install is the best solution. Backup your data if you can. BTW, I would prepare the disk to be dynamic and partition it for Vista using diskpart before re-installing. Doing this well make it less likely for problems if you were to install Vista again and chose to convert the disk aftwards to be dynamic.
 
#19
I registered to thank you guys for EasyBCD, features full and very easy to use, simple GREAT!.

I want to share with you guys my experience maybe someone will find a solution to his/her problem like I did.

I had the same exact problem as cspclay, and tried the same solutions, I tried also the solution give by computer guru and others. None of these worked.

When I tried to use bootsect, I found that I don't have it neither on my Windows Vista DVD nor on my HD.

I've tried diskpart and gparted to make the partition active, but that didn't help either.

Luckily I have a second hard drive, I installed Vista on this HD and then installed EasyBCD, and tried to fix the MBR and it worked like a charm. I was able to access my old Vista, it saved me a lot of time I will spend on getting all my applications customized the way I want in addition to migrate my profiles. Thanks so much guys for this great tool.

The only thing that didn't work for me was to make a menu to select from which Vista I want to load (the old one or the new one), even though the EasyBCD gave me a success on writing the menu, but I was only able to get to the old vista. A work around was to install EasyBCD on the old vista and use the iReboot, which allowed me before restarting the machine to select which system I won't to access.

Again thank you for your help.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#20
Hi Omar, welcome to NST.
You say you couldn't access both Vistas when you added the second with EasyBCD.
Were you editing the correct BCD ? The one on the active partition of the 1st drive in the boot sequence is the one in control, not necessarily the one on the system that's running.
Have a look at
http://www.multibooters.co.uk/multiboot.html
and read down to the section on multiple Vistas and see if that explains what was happening.