Boot Trouble


Thank you Terry for the link I will look through it.

I'm sorry if I wasn't clear in my previous post. When I added the second (Old Vista) using EasyBCD I was able to access it successfully after I rebooted (From the new Vista). But it didn't show a menu that allows me to select which Vista I want to use, so I lost access to the new Vista. (I can access the new Vista as I said using the iReboot.


Telephone Sanitizer (2nd Class)
Staff member
Ah, I see. It sounds like you set timeout to 0.
That will suppress the boot menu and go to the default.
Put it back to 5 or so and it will give you the menu without unnecessarily delaying the boot when you do want to let it default.


Telephone Sanitizer (2nd Class)
Staff member
Sorry Omar,
do you mean it was already set to 30 and doesn't work, or that you've now set it to 30 and it does ?


Super Moderator
Staff member
Do bcdedit /set {bootmgr} displaybootmenu yes if you can see the other entry in EasyBCD, have the timeout set at 30, but still do not get a menu.


I had this problem also and Terry60 suggested this solution to me in thread: Vista will not boot - The NeoSmart Forums and it worked. Actually I didn't disconnected the drive but applied vista dvd startup repairing 3 times, my computer worked :grinning: Before this solution I had tried all the suggestions in this thread and non of them worked for me^^
Thank you very much Terry60!
Here is the solution suggested:
"Try disconnecting your D disk temporarily so that it doesn't confuse the situation, then boot from your Vista DVD, select repair my computer then repair startup.
You will probably need to do this more than once (it does warn you so), as it only seems capable of fixing one thing at a time.
Eventually, the system should boot properly without needing the DVD, at which point you can reconnect your D disk and carry on where you left off before."


New Member
are dynamic volumes the culprit?

Hey there - I'm in the same boat as everyone above, I haven't had any luck with anything and I'm wondering: Does it have to do with the dynamic volume? And if so, what's the remedy?

My particular situation was this:

Disk 0

Part 1 - Mac OS X
Part 2 - OS X data

Disk 1

Part 1 - Windows 7 (dynamic volume)
Part 2 - Data storage (dynamic volume)

I wanted to reclaim that OS X data storage and use it for Windows so I re-partitioned / formatted with NTFS. Next boot was "missing OS" and so it began. What *should* have worked was rebuilding BCD with bootrec.exe /rebuildbcd. Alas all I ever got was "error reading filesystem. Make sure drivers are loaded you're not corrupt" yadda yadda. BCDedit /create {bootmgr} would fail with the same error. After running chkdsk c: /f till I was blue in the face, it dawned on me that this *had* to do with the dynamic volume - there was simply nothing left to explain it.

So I've re-installed Win 7 on to Disk 0, part 2 and installed EasyBCD. I did Diagnostic Center / Reset BCD Storage (after "Recreate missing/deleted boot files" suggested I do so). The output of which is:

There is one entry in the Vista Bootloader.
Bootloader Timeout: 5 seconds.
Default OS: Windows Vista
Entry #1
Name: Windows Vista
BCD ID: {default}
Drive: Deleted Partition
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

(I added the bolding). It literally is referring to "deleted partition". Keep in mind, this volume is fully availble to me in Explorer, Disk Manager etc.

I can backup / restore now that I'm operational again, but I would ideally like to boot into that installation at Disk 1, part 1.

Any thoughts?


EasyBCD worked any damn way even though it referred to "Deleted Partition"!!!

So I umm...yeah. Ok. Donate - I'll do that.
Last edited:


New Member
Thanks a bunch guys

Same as puppyman, but I can trace my problems to when I looked into installing OSX. I hadn't adjusted ANYTHING, just booted to the install disk, and I started getting these problems. Anyway, since OSX has to be installed to GUID, I gave up and put it on my second hard disk, and it's all working fine. I was never tooooo worried, as I could always use the chameleon bootloader from my usb to boot to C:, which gave me the old Windows 7 bootloader (which I configured with EasyBCD), but now I can get there straight up!! SUCCESS!! Now running XP, 7 and SL happily on the one laptop :smile:
Thanks again to you guys, that thread was a lifesaver in the late, worrying stages of setting everything up!


Hi cspclay, welcome to NeoSmart Technologies.

Give this a shot:
Boot from the Vista DVD | Repair Options | Command Prompt:
del c:\boot\ /f /s
bootrec /fixmbr
bootrec /rebuildbcd
Should do the trick. Good luck.

Just registerred to reply a reason why this didn't work in my situation.

It's quite simple. The del c:\boot\ /f /s command just deleted the files from the directories and not the boot directory itself. The rd or rmdir command will accomplish this properly.

Just do this revised way. It worked for me.

rd c:\boot\ /s /q
bootrec /fixmbr
bootrec /rebuildbcd


Mostly Harmless
Staff member
Hi kadafitcd, welcome to NeoSmart.

Thanks very much for those revised instructions. I'll make sure nowhere else on the site (wiki and documentation) is it used, but I don't think so. Usually our instructions are to only delete the BCD file itself.


I tried to use the del command in a situation that just happened here at my shop. It never would work. But when I used the rd command and completely removed the directory it worked like a charm. So thank you all so much for posting this it helped me a ton.


New Member
This is the fix!

I found this thread with google as I was trying to research a solution to this problem, and I thought I'd share the solution I figured out. The problem is that the drive he is trying to install the boot manager on isn't marked as active or system (explaining the message "The system cannot find the file specified")

Use diskpart to select the primary partition of the drive you want to boot from and type "active" to mark it as active. To further mark this drive as system, just use the bootrec /fixboot command. Finally, use bootrec /rebuildbcd to register the windows installation.

Many thanks for the above advice on marking the first partition active. That is indeed the solution to the problem of "The volume does not contain a recognized file system" returned by bootrec.exe and applies to Windows 7 as well. Many thanks for the excellent insight!!!


New Member
OK, time to do it manually.

del c:\boot\ /f /s
mkdir c:\Boot\
xcopy c:\windows\boot\pcat\* C:\boot\ EXCLUDE:bootmgr /E /C /Q /G /H /R /Y
xcopy c:\windows\boot\fonts\* c:\boot\Fonts\ /E /C /Q /G /H /R /Y
copy c:\windows\boot\pcat\bootmgr C:\Bootmgr
bcdedit.exe /createstore c:\boot\BCD
bcdedit.exe /create {bootmgr} /d "Windows Boot Manager"
bcdedit.exe /set {bootmgr} device partition=C:
bcdedit.exe /timeout 5
bcdedit.exe /create /d "Windows Vista" /application osloader
# You should get a message saying {ID} was created successfully. Use {ID} in future commands.
bcdedit.exe /set {ID} osdevice partition=C:
bcdedit.exe /set {ID} device partition=C:
bcdedit.exe /set {ID} path \Windows\system32\winload.exe
bcdedit.exe /displayorder {ID}
bcdedit.exe /default {ID}
bcdedit.exe /set {ID} systemroot \Windows

No guarantees, but that should do the trick. If it doesn't we'll at least know which step errors out and we can debug it from there.

Just wanted to say thanks for this...after having similar issues to OP - after Debian really made a mess of boot up I was getting Missing OS.
I was also having the same issue that the system cannot find the path specified when trying to use bootrec.

This was on Server 2008R2 - incase it helps anyone else with the same problem.
Thanks again.