BOOTMGR MISSING

#1
First want to thank all you guys out there who volunteer your time and expertise to help out boot issues.
Problems started yesterday after my son installed a new Intel quad core processor on his Windows 7 64-bit system. Task Manager was only showing two cores, so I Googled that and found a suggestion to go into MSCONFIG > Boot > Advanced Options > and unchecked the box next to Number of Processors:
Tried to reboot, and was unsuccessful. So downloaded a Windows System Repair Disk - 64-bit, burned it to DVD, changed BIOS boot sequence to boot to CD, and hit power on. When I hit "any key to boot from CD/DVD...", it goes to a black screen with a flashing white cursor in top left corner of screen.
Tried to use Windows 7 Installation DVD to rebuild boot directory, but when I tried to boot from that, it goes straight to System Recovery (does not give other options for CMD prompt, System Restore, etc.), runs for 10 or 15 minutes, at which time we give up and turn things off.
I installed the corrupt Windows 7 drive as a second drive on a stable W7 system, and using a EASEUS partition tool, copied the corrupt OS to a new partition on the stable drive (to salvage files/folders in case of a clean install later), then formatted the corrupt drive and finally, selected Rebuild MBR.
Reinstalled formatted drive back on my son's computer, tried to boot from Windows Installation Disk, and got a BOOTMGR MISSING error.
Reconnected drive to stable system, ran Easy BCD > BCD Deployment, and installed BCD, and Write MBR. Reinstalled in son's computer and still get BOOTMGR MISSING error.
Where do I go from here? Is the drive fried? Please advise, and thanks in advance for your time and knowledge.
 
#3
Thanks for the quick response.
Unfortunately, those repair options are not available, as I am stuck on the BOOTMGR MISSING screen when I attempt to boot using either 1)Windows Repair Disk, or 2)Windows Installation DVD.
 

Terry60

Knows where his towel is.
Staff member
#4
Are you still getting " Press any key ....." when you try booting from either disc ?
If not check the BIOS sequence again.
 
#5
yes, still get "Press any key..." using both disks.
another test i've performed to check integrity of optical drive: installed corrupt drive on my stable computer as only drive, then tried to boot using both DVDs. Got the BOOTMGR MISSING error both disks.
 

mqudsi

Mostly Harmless
Staff member
#6
You can't get 'BOOTMGR is missing" if you actually boot into a proper Windows setup or recovery CD.
 

Terry60

Knows where his towel is.
Staff member
#7
That "Press any key...." key message is from the optical disc.
i.e. it has already booted.
It's a bit misleading as a message, and should really read something like "Do you want to start the Installation setup program from the start ?"
Hence you press any key to get the Install screen (which also doubles as the repair screen) when starting an install, but not on the reboots during an install (otherwise you'd start over from the beginning again).
At what point subsequent to the "press any..." do you get "Bootmgr missing" ?
 
#8
Resolved:
Repaired MBR one more time using EaseUS Partition Manager. Then my son tried booting from the W7 Installation DVD. It went into the scrolling action, found an OS in need of repair, and when we selected Repair, it did the trick!!!
Now, after all my fumbling and experimenting, I'm left with two drives, each with two partitions and two versions of W7. Cannot delete the "extra" OS partition without going thru a third-party boot CD with a partition manager built in. Any tips on how to safely remove those extra partitions? If I delete them, will I get back into a boot issue?
Thanks
 

Terry60

Knows where his towel is.
Staff member
#9
You cannot delete whichever one is "system" in the Disk Management flags.
Disk Management flags have the following meanings


"boot" = "this is the system you're running"
"system" = "this is where I found the boot files for the currently running system"
"active" (on the first HDD in the BIOS boot sequence) = "this is where I started the search for the boot files"
"active" (on subsequent HDDs in the BIOS boot sequence) ="this is where I will look if I don't find something in the MBR on the first HDD"

If the one you want to keep isn't "system" you can use EasyBCD to copy the boot files to where you want them and then format the old location after booting from the new one
Changing the Boot Partition - EasyBCD - NeoSmart Technologies Wiki
 
#10
Terry:
Thanks for your patience and advice.
Have computer booting successfully into W7, but there's still a quirk in it; while attempting to repair my OS, using a number of Windows-based solutions (e.g.Windows Rescue Disk, Windows 7 Installation Disk, or Windows-based Macrium Reflect Rescue Disk) I am unable to boot into any of those programs. When the "Press any key to boot from CD...", I press keys but it ALWAYS boots into W7.
However, when I attempt to boot using a Linux-based Macrium Rescue CD or a Partition Wizard rescue CD (guessing Linux-based??), I am successful in booting into those programs.
Here's a possible clue, but I don't know how it fits this puzzle: there are two partitions on the quirky W7 HDD. Partition C: is an imaged copy of the original OS, and partition D: looks like a remnant from a clean install we tried when in the thick of solving this problem. Partition D: is <1GB and contains System Volume Information, Boot folder, etc. (see attachment). I've tried deleting Partition D:, but that results in an unbootable drive.
Is there a way to "fix" my drive so that I am able to access those Windows-based boot programs, e.g. if necessary, to do a clean install over an existing OS, or access Windows Repair Environment?
Thanks again for all your help.
 

Attachments

Terry60

Knows where his towel is.
Staff member
#11
Re-read my previous post.
You can't delete a "system" partition.
Use EasyBCD to put the boot files on C as described previously.
 
#12
Finally got the W7 HDD to boot. Looks to be stable. However, I am still not able to boot into either a Windows Installation DVD or a Windows Repair Environment Disk. I am attaching a screenshot of Computer Management console showing the troublesome disk.
I am able to boot successfully into Linux-based boot iso images.
Would really like to get this drive to the point where I can boot into Windows Installation DVD for any future clean installs.
On another note: any news to report on a WinPE/Easy BCD combo?
Thanks in advance.
 

Attachments

Terry60

Knows where his towel is.
Staff member
#13
Why ?
If your BIOS is set to boot CD before HDD (which it needs to be for an install to complete successfully) then merely mounting the DVD before booting will go straight to the setup (if you "press any key...") before you even get to the HDD bootmgr menu to select an option for the DVD, and if the DVD isn't mounted how would you select it ?
 
#14
I'm finally on to the real reason these DVD boot disks do not successfully boot: BIOS settings. Started to suspect it might be the DVD drive when I recalled some CD/DVD BIOS settings dealing with EFI, non-EFI protocol. Decided to test this theory by creating another bootable medium: USB flash drive. Created the bootable flash drive, set BIOS to boot to USB-HDD, and it booted straight to the flash drive!
The confusing part about all this was this BIOS-setting symptom mimicked a dysfunctional boot process. Now that I know the drive has a healthy boot process, I can focus on resolving the CD/DVD BIOS settings issue.
Thanks again for all your time and knowledge.
 

mqudsi

Mostly Harmless
Staff member
#15
You realize you never mentioned anywhere that your system was EFI?
 
#16
Only discovered EFI BIOS setting on 12/8, then had to Wiki EFI to decrypt the acronym. Would EFI settings cause the DVD boot process to not function?
 

mqudsi

Mostly Harmless
Staff member
#17
EFI changes everything. You need to do everything in a special way.
 
#18
My MB is a Gigabyte GA-G41MT-S2P that uses a "Hybrid EFI Technology". I'm guessing when the W7 64-bit was originally installed, it may have been installed with CD/DVD set to EFI. Cannot find any documentation showing exactly how this particular board installs W7 64-bit bootfiles, depending on which CD/DVD options are selected in the BIOS.