Cant Boot Fedora

#1
I am new to NeoSmart BCD. I have installed Fedora Core 10 on a seperate drive and it boots fine when it is the only drive in the system and I have GRUB installed and it (GRUB) opens before actual boot. I have Vista installed on another drive and boots fine. I have installed NeoSmart BCD via my Vista installation and followed instructions to the letter. Via BCD, I see my Lynux partition and added it to the Windows boot loader. Boot loader comes up and the Vista selection boots, but when attempting to boot Fedora it refuses to see the Lynux partition. Like everything else with Lynux, it simply never works the first time for a newby. Please help, I hate Microsft and want to be a Lynux head but no one in the community makes that very easy to achieve. :angry:
 
#2
Hello keep, welcome to NST.
You need to get the latest [thread=642]beta build[/thread] of EasyBCD which has far more Linux support than the 1.7 release, and supports the separate /boot partition Fedora uses (which 1.7 does not) with the "Grub is not installed..." option underneath the Linux tab checked.
 
#3
Still not working

Thanks for a response. So I assume that version 1.7 simply does not work with Fedora and Vista. So I have downloaded version 2 beta. It still does not work. Could someone simply tell me step by step what I need to do to make version 2 boot Fedora Core 10 and Windows Vista ?. I need step by step because if it is not step by step, too many assumptions are made in telling someone how to do things and important steps are simply left out. I really would like to believe that this software works. I need to know what boxes to check, what to enable and what to enter and where.

Many Thanks.
 
#4
Can you please describe the exact error code you get when attempting to boot into Fedora, instead of just saying "it did not work"...
Did you check the box underneath the Linux tab in the Add/Remove Entries section of EasyBCD before creating the Fedora entry, and did you make sure to point the BCD entry at the /boot partition that Fedora uses, under the Device drop-down menu?
 
#5
What I get when attempting to boot Fedora is a blinking cursor on a black screen, the OS just will not load. The box below the Linux tab IS checked and it is "GRUB isn't installed to MBR/bootsector". Under "type" what do I use ? GRUB or LILO. What Linux partition do I select ? 1 or 2 ? Do I need to go to the "NeoGrub tab and enable that ? Anything else ? Is there something very obvious that I have not done ?

Many Thanks,
 
#6
What I get when attempting to boot Fedora is a blinking cursor on a black screen, the OS just will not load. The box below the Linux tab IS checked and it is "GRUB isn't installed to MBR/bootsector". Under "type" what do I use ? GRUB or LILO. What Linux partition do I select ? 1 or 2 ? Do I need to go to the "NeoGrub tab and enable that ? Anything else ? Is there something very obvious that I have not done ?

Many Thanks,
Use Grub.
As for whether to point the Linux entry at partition 1 or partition 2, you will need to figure out that. :wink: I cannot possibly see your setup, to know what all you did...:tongueout:
But it needs to be pointed at the /boot partition that Fedora uses, not the Fedora root partition (which contains your Fedora OS).
If you want me to help you figure out which partition it is, post the results of the following command run from EasyBCD's Power Console on the Useful Utilities page:
Code:
bootpart
But it may be faster to just go ahead and try whichever partition it is you have not tried yet.

Cheers.

Jake
 
#7
OK. My Linux boot partition was identified as 2 I set that and the grub loader comes up at boot and when I select the Linux boot option, it tries to boot, then gives me an "ERROR 15" "file not found" error and will not boot. One thing I notice in the view of the windows boot loader load lines in Easy BCD is that both entries for the boot load for Windows AND the bootload lines for Fedora point to drive "C:" but as far as windows is concerned, my Fedora boot drive is E: so it would appear that Easy BCD is finding the grub boot loader then attempting to boot from the Windows drive C: and then not finding the Linux boot file and throwing the file not found error. Is there a way to change the entry in the Windows boot loader to E: from Easy Bcd ? (If that is the problem)

Many Thanks