Changed boot partition - Failed / No effect

#1
Hi,

I have an SSD drive (C:smile: on which the windows installation is and an additional drive (M:smile:. For some reason, in the current configuration windows boots from M:, or according to EasyBCD report:

Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=M:
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {62b9d021-5630-11e2-b80a-daede9a5203a}
resumeobject {62b9d020-5630-11e2-b80a-daede9a5203a}
displayorder {62b9d021-5630-11e2-b80a-daede9a5203a}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 3


Windows Boot Loader
-------------------
identifier {62b9d021-5630-11e2-b80a-daede9a5203a}
device partition=C:
path \Windows\system32\winload.exe
description Windows 7
locale en-US
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
recoverysequence {62b9d022-5630-11e2-b80a-daede9a5203a}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {62b9d020-5630-11e2-b80a-daede9a5203a}
nx OptIn

I've changed the boot section to C:, as described in https://neosmart.net/wiki/easybcd/basics/changing-the-boot-partition/ and received a confirmation message message. When I try to boot from C:, windows fails to boot. (no boot media). What am I doing wrong? What should I do?

Here's the EasyBCD report after the change:
Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device boot
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {62b9d021-5630-11e2-b80a-daede9a5203a}
resumeobject {62b9d020-5630-11e2-b80a-daede9a5203a}
displayorder {62b9d021-5630-11e2-b80a-daede9a5203a}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 3


Windows Boot Loader
-------------------
identifier {62b9d021-5630-11e2-b80a-daede9a5203a}
device partition=C:
path \Windows\system32\winload.exe
description Windows 7
locale en-US
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
recoverysequence {62b9d022-5630-11e2-b80a-daede9a5203a}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {62b9d020-5630-11e2-b80a-daede9a5203a}
nx OptIn
 

mqudsi

Mostly Harmless
Staff member
#2
Try manually rewriting the bootsector and mbr on C: from EasyBCD | Useful Utilities | Power Console

bootsect.exe /nt60 c: /force
bootsect.exe /nt60 c: /force /mbr
 
#3
Doesn't work

Try manually rewriting the bootsector and mbr on C: from EasyBCD | Useful Utilities | Power Console

bootsect.exe /nt60 c: /force
bootsect.exe /nt60 c: /force /mbr

I've tried it, but I still in the second line, instead of the original
"device partition=M:"

the resulting
"
device boot"

In fact, I have tried to move the boot sector to another drive (say E:smile: and I got the same result, so I guess this is not an SSD related issue. Also, out of curiousity, why windows prefers to install the boot sector on an HDD rather than an SSD? Should I prefer to do so as well?

 

Terry60

Knows where his towel is.
Staff member
#4
Can you post a Disk Management screenshot please.
Windows 7/8 default to trying to keep the boot files separate from the OS in order to allow you to encrypt the OS if you wish to without making the PC unbootable.
The normal behaviour if you install to empty space, is for setup to create two partitions in the space (C: and an unlettered 100Mb partition it names "System Reserved" where it places the boot files).
If you prevent it from doing this by pre-formatting the space (HDD or SSD) into a single partition, you can force it to place the boot files in C with everything else, but only if you also stop it finding an alternative. If it finds the target space is already formatted, it will look round all your other installed drives and place the boot files on the highest priority "active" partition in its single minded determination to keep the boot files away from the OS.
Stop it seeing any other "active" space than the target and it will eventually be coerced into doing what you want at install time.
If you didn't take those steps, you can find the boot files in the most unlikely (and unhelpful, performance wise) places.
EasyBCD "change boot drive" will normally correct that for you after the event.
 
#5
Can you post a Disk Management screenshot please.
Windows 7/8 default to trying to keep the boot files separate from the OS in order to allow you to encrypt the OS if you wish to without making the PC unbootable.
The normal behaviour if you install to empty space, is for setup to create two partitions in the space (C: and an unlettered 100Mb partition it names "System Reserved" where it places the boot files).
If you prevent it from doing this by pre-formatting the space (HDD or SSD) into a single partition, you can force it to place the boot files in C with everything else, but only if you also stop it finding an alternative. If it finds the target space is already formatted, it will look round all your other installed drives and place the boot files on the highest priority "active" partition in its single minded determination to keep the boot files away from the OS.
Stop it seeing any other "active" space than the target and it will eventually be coerced into doing what you want at install time.
If you didn't take those steps, you can find the boot files in the most unlikely (and unhelpful, performance wise) places.
EasyBCD "change boot drive" will normally correct that for you after the event.
Hi,

Please see attached. The drive I would like to remove is M:, and install the boot section on c:\ (where windows is installed, an SSD drive) or E: (An HDD, if it safer).
Note that after I apply the EasyBCD there is no change in the disk management (should I restart the computer in order to see a change in the disk management?)
 

Attachments

Terry60

Knows where his towel is.
Staff member
#6
Disk Management flags have the following meanings


"boot" = "this is the system you're running"
"system" = "this is where I found the boot files for the currently running system"
"active" (on the first HDD in the BIOS boot sequence) = "this is where I started the search for the boot files"
"active" (on subsequent HDDs in the BIOS boot sequence) ="this is where I will look if I don't find something in the MBR on the first HDD"

Until you reboot, nothing will change.
If you've successfully copied the boot files (set folder options like this to see them) you should find a \boot folder and a bootmgr file on C, and it should also be "active" which it doesn't appear to be.
If the files are there, use Disk Management to set C "active", then reboot.
When the system is booting from C, it will show as all three of system, active and boot.
 

Terry60

Knows where his towel is.
Staff member
#8
"change boot drive" does the copying, and everything else that's necessary.
Just check your partitions for copies of those items, to see if EasyBCD functioned as expected, or whether maybe you accidentally pointed it elsewhere.
If you used EasyBCD "change....", then there should be the originals on M and another set somewhere else. Just see if you can find them.
 
#9
"change boot drive" does the copying, and everything else that's necessary.
Just check your partitions for copies of those items, to see if EasyBCD functioned as expected, or whether maybe you accidentally pointed it elsewhere.
If you used EasyBCD "change....", then there should be the originals on M and another set somewhere else. Just see if you can find them.

Well, the files are there, but after restart, the disk managment image is unchanged. Is it because c:\ is not set to active? I thought EasyBCD should have changed this setting. Should I manually update it? Can I deactive the active signal if it fails? Any other idea what should I do next.
 

Terry60

Knows where his towel is.
Staff member
#10
Like I said in post #6, set C active in Disk Management and boot again with C at a higher priority in the BIOS than M.
You won't want to set C not active. Only active partitions can be booted from, so you'll never want it not to be active if your objective is to boot from the SSD (which it should be for performance reasons).