Cloning W7 to other partitions, then booting...

#1
I am trying to run a triple boot W7, whereby I install W7 x64 in the normal manner, and choose a 50gb partition on my primary disk. Do updates, drivers and some core apps, then image and restore to another partition on the same disk.

I then install and run EasBCD on the oriniginal OS to setup the boot options... I can then boot into the clone ok, and I can then hide the original OS by removing its drive letter. This all seems to work great, I have a clone of original and can boot into either, and they are both C.

The strange thing happens next, I then re-image the original, after I have installed some more apps, and restore to a 3rd partition on the same disk. Re-run EasyBCD on original OS to add the new clone, then proceed to boot into it. So EBCD see 3 OS, original on C, clone1 on D and clone2 on E.

At first it loaded the desktop, so I thought it was ok... I then noticed it had identified the system drive as E, and not C. Then noticed if I changed the desktop on this clone, and booted back to original, the desktop there had changed to. Windows seems to have got a bit mixed up! I dont understand how the first clone works fine! I then get warnings about Windows no being genuine etc...

Can anyone shed any light as to why this has happened, why the first clone worked OK, and windows identfied the system correctly on both orignial and clone1, and showed them as C, but recognised the 3rd clone (which was a new clone of original after easybcd install and some other apps).

Im going to try to resote the original clone to 3rd partition, and see what happens...

I was using an app called HypOS 2010 to clone and boot OS, but this seems to now work odd as Im now a non XP system, and lots of strange things were happening.

Cloning and booting XP used to be a doddle, adding new partitions into boot.ini, and using a bot manager to hide other partitions during boot, so active OS was always C.. but I cant get my head around achieving the same with W7!!!

Anyone advise???


EDIT: I restoed the oroginal clone of the original install to 3rd partition, and it booted ok , and showed as C drive, but I have noticed that this image was taken prior to activating windows... The 2nd clone I took was post activation, and was th eone I had problems with after a restor to 3rd partition...
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
We've had a lot of support requests about this - Windows does not use the disk and partition numbers to boot into an OS, it uses the volume ID.

When you clone a partition, you clone the volume ID along with it. As such, Windows will boot into the same OS regardless of which entry you pick from the boot menu.

You need to change the volume ID for your cloned disk: VolumeID
 
#3
OMG thank you!!... That makes perfect sense, and has indeed fixed the issue!

The reason one of them worked is that I was restoring a clone I had taken prior to a rebuild, so had a different ID, but a second restore of this would duplicate this ID!...

Brilliant, thanks.. thats saved me allsorts of headaches and hours of searching.. I feel a donation may be just around the corner!!!...

$10 donated :smile:
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#4
You are most welcome, DrBoot :smile:
 
#5
Do you happen to know of any imaging software that doesnt copy the volumeID? Its quite difficult to find out if they do without trying, and those that I have, do!
 

mqudsi

Mostly Harmless
Staff member
#6
Just change it manually post-cloning. It's a one-liner.
 
#7
Hi there,

I ran into this problem as well lately, and did as you suggested - changed the volume id using that command line app. Added the new entry for the cloned partition in EasyBCD but still it boots into the same partition. When I look at the settings in Debug Mode, I can see the "identifier" is identical for both partitions. Presumably this is the problem? Shouldn't these be different now I changed the volume id of the second partition?

I checked both partitions with "dir" in command line and they are definitely different volume IDs...

Help!
 
#8
Just change it manually post-cloning. It's a one-liner.
lol, yeah I know.. couldnt really be easier... think im just being uber lazy:booyah:

I just got used to using an app called HyperOS (I was a beta tester), which provided a single interface for backup/restore - cloning and booting into OS, but IMO development was poor and support non existant. Id nevr had any success doint W7 clones until stumbling across EasyBCD and VolumeID - so should be happy with that, it works great!!! Just wondered if there was an imaging software that didnt copy the ID!

user54, want to run through the steps you are doing? I assume you are using W7? I now have 4 clones of original install all booting fine, thanks to eBCD and VolumeID! Simple procedure:

1 - Install W7 & whatever else you like!
2 - Use your fav prog ro backup W7 partition.
3 - Restore backup to another partition.
4 - On original W7, install eBCD, you can check volume ID on C & D should be same!
5 - Change VolumeID on D to xxxx-xxxx (hex) - reboot.
6 - Check id on both partitions, should now be different.
7 - Run eBCD (should show original install boot info), add new entry (select OS and drive D).
8 - Reboot, should now have boot menu with 2 options, select your cloned OS!

Since doint this, Ive restored the backup to another 2 partitions, changed disk ID for each, created new entries in eBCD, and can boot into all 4 OS, no problem! Ive then gone into each OS, and removed the drive letter for non system drive, so I dont see all other OS drives. Each OS I then boot into is the C drive (as you would expect!), with non of the other drives visible.
 
#9
Hi DrBoot, thanks for you reply.

The steps you listed above are exactly what I tried with no luck (changed the id on partition D: to 1234-5678. What I did notice was in the eBCD Debug Mode screen, its listing the two partitions with the same "identifier". After having changed (and verified) the volume id, presumably these identifer numbers should be different. Is that the case with your setup?

I also have iReboot installed. I wonder if this could be causing any conflicts? What version of eBCD are you using?

I'll give it another go shortly and see if I have any more luck...
 
#10
Id never noticed before, but yes, all have same identifier... what exactly happens then when you boot???

ON CLOSER INSPECTION, THE FIRST PART OF THE IDENTIFIER IS DIFFERENT! - DOH!

Windows Boot Loader
-------------------
identifier {cc18e835-08cd-11e0-99a8-9fec0ef6d680}
device partition=C:
-------------------
identifier {cc18e838-08cd-11e0-99a8-9fec0ef6d680}
device partition=E:
-------------------
identifier {cc18e83a-08cd-11e0-99a8-9fec0ef6d680}
device partition=D:
-------------------
identifier {cc18e83b-08cd-11e0-99a8-9fec0ef6d680}
device partition=F:

Dont forget, when you boot into the new clone OS, it will be C - W7 by default, always makes the system drive, drive C. WHich is great for cloning, otherwise it would cause allsorts of drive letter issues!
 
Last edited:
#11
Actually you're right - the identifers are slightly different, but I'm suspicious about something here. Try this out: while booted into your 2nd partition, create a new folder on your desktop. Now boot into your 1st partition. Is that new folder still on your desktop? It shouldn't be. On my system it is.

I suspect what is happening is that when you boot into the 2nd (cloned) partition, eBCD is telling windows to boot from /windows on that second partition, but once up and running, the OS still thinks its on that other partition and writes erases etc files to that other patition. Eg if you uninstall a piece of software whilst on 2nd partition (that was also on the other partition because it was cloned), it will actually erase the files from the first partition, and not the 2nd, as it should. Really easy to miss this during normal moderate operation...

I'm thinking I'm actually going to have to do seperate installs on the different partitions...
 
#12
Just done exactly that, and no replication...

You havent by any chance moved your user profiles folders onto another drive, and included the desktop folder???

I move any shared files, such as pagefile, my docs, pictures, favourites etc to another partition, that way all clones ues the same partiition for this information... if you have also included the desktop folder with this, anything you create on the desktop would be duplicated across all clones...
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#13
what you're explaining sounds suspiciously like identical volume IDs.... are you sure they're now different?
 
#14
Strangely, Ive just replicated this issue... I wsa using my original W7 OS, when I did a live clone using Macrium Reflect. I then restored this clone to what was my D drive. Changed volume ID's and confirmed they were both different, then configured boot options in eBCD, rebooted, chose the cloned OS, and it loaded up as the D drive!.. So on this instance, I was able to create a folder on the desktop, which was then visible when I booted back to original....

So not sure what happened there, maybe it was the whole live cloning thing...????

Addendum:

Ive just done some quite extensive testing, and I can only conclude that if I do a resotre of a clone recently taken of my current C (original install), then restore it to another partition... regardless of the volume id, which I have changed on the restored partition, and confirmed, when I boot into that cloned OS, the system drive shows up as D (the original installation), and not the newly cloned and booted C, consequently, if I add something to the desktop, it as added to the D drive, so when I reboot to original, the folder I created is also there....

Where I had it working above, was I had been restoring clones from an older system, which would always work on first clone, but then fail on the second, due to volume ID. If I then changed this, any restores would work.

So I cant get clones taken from a current OS to boot properly, regardless of volumeID!
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#15
:frowning:

I assume this is something I'll have to just replicate and experiment with myself.
 
#16
Its the only conclusion I can come to...

The clones I had been successfully using were taken prior to a system rebuild, so wwere not clones of the current OS. Any clones of the current OS I take and restore, despite changing vID, end up booting showing whatever drive letter they were showing from original OS...

From my original install OS, on C, I have 3 other partitions, D, E & F... If I take a clone of C, restore to F, change vID on F, reboot back into original, setup boot menu in eBCD, select cloned OS of W7 on F, then boot into F.. the system drive shows as F. Restoring a clone from an older build would result in the OS correctly being C, and all working well...

I will try doing a backup/restore using a boot CD of Acronis, as Id done a clone of a live OS...

EDIT:
Just tried a new clone/restore using Acronis boot disk, and same result! Strange!...
 
Last edited:
#17
Coming from using XP for many years in precisely this fashion, its weird to discover 7 simply cannot work this way. I spoke to someone today who designs software and hardware components for Boeing, Rolls Royce and Airbus, and described the situation to him. His take was that 7 refers to file's locations on the hard drive in a different way to previous versions, and the "letters" C, D, etc are just for legacy understanding's sake, and not relevant to the way the file system is working underneath.

Oh well, as long as I understand what the facts are I can work with them. Just glad I spotted this before starting on any serious work on the partitions...
 

mqudsi

Mostly Harmless
Staff member
#18
That is absolutely true.

Windows 7 uses the partition ID plus where it starts on the hard disk to identify each partition instead of the letters, which are only there for the users' reference.
 

Terry60

Knows where his towel is.
Staff member
#19
That is, Vista and W7 BCD use the UID (including the disk sig, and the partition start address). The rest of the OS uses the disk letters in the same way as XP (which all assign them differently than legacy W9x).

When I've moved Vista/7 partitions to a different location, it has always been necessary to "startup repair" from the installation DVD to straighten out the BCD , which contains information relevant to the old location, not the new.

I've used Paragon Drive Copy, and that with the startup repair gave a perfectly working new copy. I've not tried to make multiple copies though, just move the OS to a new HDD.

I think your problems might be down to the particular "cloning" tool in use, (or which function of it you use). Some "clones" are not clones at all by the strict definition of the word. They're modified copies, in which the tool has detected an existing installation and "fixed" the registry in the copy by changing all C to the next available letter.
You need to research the "backup" "copy" and "clone" functions of whichever tool is in use to make sure you're using one which isn't doing something for you that you might not be aware of , and don't want.
 
Last edited:
#20
It does seem odd however that I can restore a clone of an older W7 system (not my current one), to a 2nd partition, then to a third, change the third's vID, then boot into the 2 of them fine...

I was using HyperOS (http://www.hyperossystems.co.uk/) which did the cloning, and boot menu automatically, but it had some fundamental flaws, and support was poor.. I was a beta tester for this software...

Would really love to get this solution to work, but maybe its not meant to be :frowning: