Dual Booting Vista & Fedora 10

#1
Basic Information -
http://fedoraproject.org/en/get-fedora

Windows Vista Computer Management (Disk Management) -
Disk 0 - E: 931.51BG NTFS
Disk 1 - F: 931.51BG NTFS
Disk 2 - C: 85 GB NTFS (Vista); 196 mb ext3 (Fedora Boot); 97.46 GB ext3 & swap; H: 80 GB RAW
Disk 3 - D: 931.51BG NTFS
Disk 4 - G: 931.51BG NTFS
CDRom 0
CDRom 1

All drives Serial ATA.
EasyBCD1.x wasn't working for me so I am trying 2.0 Beta.

I'm trying to dual boot Windows Vista and Fedora 10 on the same hard drive.

Steps to my crazied logic:
1) - Install Vista on ~100 gig partition (Disk Drive 2 [drive 3], Partition 1 [first])

2) - Load Vista, Create two 100 gig paritions, delete middle one, leave last one raw (future OS)

3) - Install Fedora on ~100 open gigs inbetween other two partitions (NTFS & RAW)

4) - Fedora 10 installed as 200 megabyte partition for boot (/boot - ext3), and then a single partition then broken into logical partitions for swap and ext3 (/).

5) - After Fedora Installed, Install EasyBCD and create Boot Entry for Fedora 10

6) - Restart Computer, Opens Up To Boot Menu... Choose Fedora 10... Computer Hangs.

Options in EasyBCD 2.0 Beta - Add/Remove Entries - Device:
Drive 0
Partition 1 (E:\ as NTFS - 932 GB)
Drive 1
Partition 1 (F:\ as NTFS - 932 GB)
Drive 2
Parition 1 (C:\ as NTFS = 84 GB)
Parition 2 (FAT16 - 98 GB)
Parition 3 (Linux - 0 GB)
Parition 4 (Type 0x8E - 97 GB)
Drive 3
Parition 1 (D:\ as NTFS - 932 GB)
Drive 4
Parition 1 (G:\ as NTFS - 932 GB)

I tried multiple ways to point to a variety of the above options to no avail. My current entries for the bootloader are:

Entry #1
Name: Windows Vista
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Entry #2
Name: Fedora 10
BCD ID: {c3f18e34-fe0c-11dd-b1bc-0022151c48fa}
Drive: C:\
Bootloader Path: \NST\nst_.mbr
Entry #3
Name: Fedora 10 - Attempt 2
BCD ID: {c3f18e35-fe0c-11dd-b1bc-0022151c48fa}
Drive: C:\
Bootloader Path: \NST\nst_.mbr
Entry #4
Name: NeoGrub Bootloader
BCD ID: {c3f18e37-fe0c-11dd-b1bc-0022151c48fa}
Drive: C:\
Bootloader Path: \NST\NeoGrub.mbr

The path "\NST\nst_.mbr" doesn't seem right to me... Any suggestions or helpful hints?

I should also note that the reason I switched to 2.0 Beta is because the earlier release was simply giving me a "Can't find boot sector" or "No boot image" or "Insert bootable device and press any key" errors when I tried to boot to them from the boot menu upon startup.

Help Me... oh pretty pretty please.

:lup: :ldown:
 
#2
Hi Viper. Welcome to NST
Your NeoGrub menu.lst (located at C:/NST/menu) is what will point at your Fedora partition. The Fedora entry says C because that is where it is reading the menu.lst from, not your Fedora partition.

So please post your menu.lst so we can take a look at it.

-Coolname007
 
#3
:frowning:

I haven't changed it yet... hehe... must be part of my problem huh... it is default:

# NeoSmart NeoGrub Bootloader Configuration File
#
# This is the NeoGrub configuration file, and should be located at C:\NST\menu.lst
# Please see the EasyBCD Documentation for information on how to create/modify entries:
# http://neosmart.net/wiki/display/EBCD/

title /boot/grub/menu.lst
find --set-root --ignore-floppies /boot/grub/menu.lst
configfile /boot/grub/menu.lst
# All your boot are belong to NeoSmart!
 
#4
Ok...so I know from that you're using NeoGrub in the auto-config way (i.e. selecting the "Grub isn't installed to the bootsector" option under the Linux tab in EasyBCD), which is telling it to read from the Fedora menu.lst (i.e. the one located on either your Fedora partition, or a separate /boot partition), which in turn is what must be currently configured wrong. :wink: So now you need to post the Fedora menu.lst, located at /boot/grub/menu.lst on either your Fedora partition, or on a separate /boot partition. Can you boot Fedora at all? If so, then you can post the menu.lst.

Also, are you sure you selected the correct partition for Fedora in the "Device" drop-down under the Linux tab when you created the entry? You need to select either the Fedora partition, or the separate /boot partition if there's one.

-Coolname007
 
Last edited:
#5
Although in my defense I read the following guide:
http://neosmart.net/wiki/display/EBCD/Linux

Which says that you don't need to mess with NeoGrub if you install Vista first, and then it is suppose to point to the right partition which is my understanding at any rate.

Couple other things I should mention also after reading these forums for the last day or so. One, I did NOT install grub to the MBR, I installed it seperately (as per advised by everyone). As a result my Vista works great everytime, I can always get into it. However my poor little Fedora is lost forever and can not be found. Poor Fedora.

Addendum:

I can't boot fedora, however I could boot to Live Fedora (boot from CD) and I might be able to find the grub directly /boot... However I would be worried that I was looking at the live version rather than the one on my harddrive... That'll only take a second though, let me see if i can find it...
 
Last edited:

JustinW

Super Moderator
Staff member
#6
Im going to give Fedora 10 a try when I get the chance. Every Fedora user we've got here trying to use version 10 hasn't been able to do it. I don't know if it has to do with filesystems or w/e, but it isn't working. F8 works fine though. Thats the last version I tried. However, 2.0 final should be able to handle it from what CG's been saying.

Anyway, give the manual configuration a go, seeing how the auto-config has failed you. Have you tried it again though wtihout checking the bootsector box? Uninstall neogrub in the neogrub tab and re-add the entry to try it.
 
#7
[root@localhost grub]# cat menu.lst
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd1,2)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img
#boot=/dev/sdc3
default=0
timeout=5
splashimage=(hd1,2)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.27.5-117.fc10.i686)
root (hd1,2)
kernel /vmlinuz-2.6.27.5-117.fc10.i686 ro root=UUID=d4d3f28a-5430-4327-b854-14fd04fa3d75 rhgb quiet
initrd /initrd-2.6.27.5-117.fc10.i686.img
title Other
rootnoverify (hd1,0)
chainloader +1
[root@localhost grub]#

Addendum:

So since I'm booted to the Live version right now... the /boot drive is actually generated from the CD... however it does exist on my harddrive as /media/-boot/grub

The following command however isn't doing anything for me:

[root@localhost grub]# find /media/-boot/grub/stage1
/media/-boot/grub/stage1
[root@localhost grub]#

Addendum:

So explain it to me like I'm an idiot... I take what I just posted from my linux thing and paste that into the Vista configuration and then try it again?
 
Last edited:

JustinW

Super Moderator
Staff member
#8
Delete the first entry in your \nst\menu.lst file on your Windows partition. Copy the entries (starting from the title line) over to \nst\menu.lst on your Windows partition from your linux partition's menu.lst.
 
#9
EasyBCD 2.0 Beta's NeoGrub menu.lst:

# NeoSmart NeoGrub Bootloader Configuration File
#
# This is the NeoGrub configuration file, and should be located at C:\NST\menu.lst
# Please see the EasyBCD Documentation for information on how to create/modify entries:
# http://neosmart.net/wiki/display/EBCD/

title Fedora 10
root (hd1,2)
kernel /vmlinuz-2.6.27.5-117.fc10.i686 ro root=UUID=d4d3f28a-5430-4327-b854-14fd04fa3d75 rhgb quiet
initrd /initrd-2.6.27.5-117.fc10.i686.img
# All your boot are belong to NeoSmart!
I reboot my machine, NeoGrub comes up great, it displays my entry of "Fedora 10" and then when I boot that that I get the following error:

Booting ' Fedora 10'
root (hd1,2)
Error 22: No such partition
Press any key to continue...
Next ideas?

Addendum:

The current thing that happens though is it boots to an option screen that gives me two options, "Windows Vista" or "NeoGrub"... and then when I choose "NeoGrub" I get the option of booting "Fedora 10"... So I'm going through two boot option screens...
 
Last edited:

JustinW

Super Moderator
Staff member
#10
That's because you don't have a default line. You can safely put that back into your file at the top before your fedora entry, like:

default 0

And your root (hd1,2) should be "root (hd0,2)"...

When you get that working, change the description of the "NeoGrub" entry using EasyBCD to something like "Fedora".
 
Last edited:
#13
So sounds like a lot of people are having problems getting Fedora 10 to work on their machines from what I've read, dual booting with Vista....

10 Complicated As Hell Steps to Make Fedora 10 and Vista Play Together:


Steps to Make It Happen On Single Drive:

1) - Install Vista First on NTFS Partition, Leave Drive Space For Fedora
2) - Once In Vista, Control Panel -> Administrative Tools -> Computer Management -> Verify Sufficient Empty Space ("Unallocated") For Fedora (arrange extra partitions for other operating system(s) as needed)
3) - Boot Fedora 10 Live CD:
http://fedoraproject.org/
4) - Install Fedora.
a) - Fedora 10 gives an option to use "Free Space" and setup configuration defaults. This is recommended. If an advanced user create your own configuration.
b) - This will create a swap partition, a /boot partition, and a root "/" partition (boot and root are ext3).
c) - Do NOT, not not not, install the bootlooder into the MBR. Install the Bootlooder onto the seperately created /boot drive.

5) - After Fedora 10 is installed. Go to your freshly installed /boot partition. You may have to mount it, you'll find it under something similar to /media/-boot/. You want to locate the menu.lst file for grub, it should be in the following location:
cd /media/-boot/grub/
Display this file using the following command:
cat /media/-boot/grub/menu.lst

Copy the important lines exactly out of this file, it should be something like the following:

title Fedora 10
root (hd1,2)
kernel /vmlinuz-2.6.27.5-117.fc10.i686 ro root=UUID=d4d3f28a-5430-4327-b854-14fd04fa3d75 rhgb quiet
initrd /initrd-2.6.27.5-117.fc10.i686.img

Reboot computer. Fedora isn't in your Vista bootloader at this point so only Vista will boot and Fedora is lost in the great unknown world. Vista Should Load.

6) - Download EasyBCD
http://www.neosmart.net/ -> http://neosmart.net/dl.php?id=1
7) - At this point you may need Easy BCD2.0 Beta (download from these forums)
8) - Open EasyBCD
a) - Go To Add/Remove Entries
b) - Click the Linux Tab, Check "GRUB isn't installed to MBR/bootsector", Click Add Entry
c) - Click the NeoGrub Tab, click "Configure"
d) - Edit the NeoGrub menu.lst file to match the Linux menu.lst file. HOWEVER, change the harddrive value to one less than what was in your linux value (Linux and Windows read hard-drives differently). Your new config should look something like this (compare this to the Linux version above):

# NeoSmart NeoGrub Bootloader Configuration File
#
# This is the NeoGrub configuration file, and should be located at C:\NST\menu.lst
# Please see the EasyBCD Documentation for information on how to create/modify entries:
# http://neosmart.net/wiki/display/EBCD/
default=0
timeout=5
hiddenmenu
title Fedora 10
root (hd0,2)
kernel /vmlinuz-2.6.27.5-117.fc10.i686 ro root=UUID=d4d3f28a-5430-4327-b854-14fd04fa3d75 rhgb quiet
initrd /initrd-2.6.27.5-117.fc10.i686.img
# All your boot are belong to NeoSmart!
9) - Reboot your machine.
10) - Verify you see Fedora 10 in your newly acquired boot menu. Attempt to Boot.

That should do it, you should be good to go.
 
Last edited by a moderator:

JustinW

Super Moderator
Staff member
#14
The auto-config might have also worked without those necessary steps as well had I known at the time you were pointing to 1,2 in the menu.lst on your linux partition. Regardless, thanks for posting the steps you took to solve your problem so that it may help others.
 
#15
Glad it all turned out for you in the end. :smile: Enjoy Fedora.
But yes, as Justin said, if you had changed the values of (hd1,2) in your Fedora menu.lst to (hd0,2) and added the default line, it would have worked perfectly without the need to copy anything or do any editing to your NeoGrub menu.lst. :wink:

Cheers,

-Coolname007
 
Last edited:
#16
I haven't used Fedora myself, but a couple friends told me to check it out...

I'm used to old old school redhat... the versions of linux where you didn't even consider using the GUI because the world might explode. Always great for servers though...

This new handy machine will be supporting ssh, dhcp, samba, and possibly some website hosting if I get the initiative to do it. Although the real call for it at the moment is the capacity to TFTP various switch configurations to it remotely while I'm not at home.

I'm used to dual-booting Windows 9x/2k... Vista with its new bootloader threw me. Had a couple guys dual boot Fedora and XP and said it was the easiest thing ever... Curse Vista.

Don't suppose you guys know any good TFTP programs for Linux... Again, I'm used to using the Windows versions.
 

mqudsi

Mostly Harmless
Staff member
#18
Can someone give me a one-word answer: EasyBCD 2.0 solves the Fedora problem?
 
#19
Can someone give me a one-word answer: EasyBCD 2.0 solves the Fedora problem?
Yes. :smile:

-Coolname007

Addendum:

Now for the longer answer...:brows: Checking the box that says Grub isn't installed to the bootsector definitely works. It just didn't work in his case until he put the correct values into his Fedora menu.lst. As for whether it would work with that box *unchecked* when he creates the entry is another story, and since he didn't try it, I guess we can't know for sure. :wink:

-Coolname007
 
Last edited:
#20
Not here... using BCDeasy 2.0 beta, Windows 7 and Fedora 10

Easybcd will try to find /boot/grub/menu.lst but fedora puts /boot in a separate partition so you should change it to only /grub/menu.lst or /grub/grub.conf since menu.lst is just a link to grub.conf
(There's no /boot/ directory because the whole partition is mounted as /boot)

I have another problem, though, with windows 7
I get a message like
Try (hd0,0) :NTFS5 : No neogrub
After sometime it finds neogrub on (hd0,1) and then it can load Fedora

This is probably related to windows 7 creating a partition for its boot files. Windows bootmgr stays on that partition at hd(0,0) but neogrub is in windows normal partition at (hd0,1).

How do I make the bootmgr open neogrub.mbr directly in hd(0,1)?

Am I making sense?
 
Last edited: