Dualboot Vista and Ubuntu on separate disks

#1
Hi.

I'm a new EasyBCD user and I'm having problems getting Ubuntu to boot.

I'm currently running Vista on my SATA drive which in BIOS is "ide channel 4 master". The IDE drive is primary ("ide channel 1") master, and has nothing but root, boot and swap partitions for Ubuntu. Ubuntu is installed with GRUB on hd(0) (which hopefully is the IDE drive, and for the record I did not disconnect the SATA drive before installing). The system boots into Vista automatically after Ubuntu installation.

My intention is to use EasyBCD and Vista bootloader to choose whether I'd like to boot into Vista or Ubuntu.

Now, adding Ubuntu Linux in EasyBCD as new entry. Which Linux-partition is the correct one? (Please see attached image easybcd2.jpg). I take it's /boot (which here is drive 0 partition 0). Also, please see attached image easybcd.jpg for entry overview.

My problem is, when rebooting into Vista bootmenu and selecting "Ubuntu Linux", some text flashes quickly by, and then I'm back to the Vista bootmenu.

Did I miss something while setting up EasyBCD ?

Thanks in advance :smile:

-skrangel
 

Attachments

mqudsi

Mostly Harmless
Staff member
#2
Hi Skrangel, welcome to NST.

No, you didn't miss anything in EasyBCD but you did when installing Ubuntu. The preferred method
is to have GRUB installed to an (hdx,y) location instead of just (hdx)

But no matter.

EasyBCD | Add/Remove Entries | Linux
"GRUB is not installed to the bootsector"
Add Entry

That should do the trick.
 
#3
Thanks Guru! I got a little bit further now, but I'm not quite at the finish.

I added Ubuntu with GRUB not installed. In addition, I followed the recipe for booting Linux from the Neogrub wiki, and corrected the kernel version and /dev/hdaX:

My menu.lst now looks like this:

Code:
title Ubuntu
find --set-root /boot/vmlinuz-2.6.22-14-generic
kernel /boot/vmlinuz-2.6.22-14-generic ro root=/dev/hda2
initrd /boot/initrd.img-2.6.22-14-generic
boot
hda1 is /boot, hda2 is / i presume. I've tried with both root=/dev/hda1 and root=/dev/hda2.

Now, I restart the computer, choose to boot Ubuntu from Vista bootmenu, get into the "Grub4DOS menu" and choose to boot Ubuntu. This is what happens next:

Code:
find --set-root /boot/vmlinuz-2.6.22-14-generic
Then, the system hangs and nothing happens.


Any suggestions?
 

mqudsi

Mostly Harmless
Staff member
#4
To me, that means that it doesn't find the vmlinuz file..

Are you sure Ubuntu prefixes these files with /boot/?
Because it might be /vmlinuz-... and /initrd-.... instead.
 

mqudsi

Mostly Harmless
Staff member
#6
Mind telling us what worked? I'm sure it'll help [thread=1075]some other members[/thread] here too :smile:
 
#7
Sorry forgot to clearify.

It worked when I changed the content in menu.lst to this:

Code:
title Ubuntu
find --set-root /vmlinuz-2.6.22-14-generic
kernel /vmlinuz-2.6.22-14-generic ro root=/dev/hda2
initrd /initrd.img-2.6.22-14-generic
boot
Thanks again for all help :smile:
 

mqudsi

Mostly Harmless
Staff member
#8
Sweet. I'll update the sample file in the Documentation.