Dualboot Win7+openSUSE, two hard drives

Hi, I have a problem dualbooting those two OS. This is my situation: I have an SSD, which is completely for Win7. Then I have a drive, on which I had a 100 GiB partition for Linux. I installed it appropriately, but now I can't get it to boot. Here is a screenshot:
What is weird is that in the EASEUS program, the 2.01 GB partition is labelled as fully used, but in the Disk Management window it is labelled as entirely empty.
I tried choosing all three possible Linux partitions to boot, but none worked, only black screen with flashing cursor appeared.

Could you help me out? Do you need more information?


Knows where his towel is.
Staff member
Did you choose grub2 from the dropdown menu ?
It will locate grub automatically..
Don't worry about Disk Management, that's just MS being parochial and refusing to acknowledge the existence of "foreign" file systems.
For very new builds of Linux, make sure you're also using the very latest build of EasyBCD
I did try Grub2 first, however it led to this after choosing to boot Linux: IMG_20120909_211829.jpg
So I figured something was wrong and tried choosing the partition myself, but to no avail.


Knows where his towel is.
Staff member
And what version of EasyBCD is that ? (Help > About)
The latest, I'll try to reinstall and reformat the drive, just in case.

Edit: I just did a clean install, still having the same problem.
Last edited: