EasyBCD 1.7.2 only shows C: drive

eturk

New Member
#1
Installed Ubuntu on drive 3 (vista on 0). easyBCD 1.7.2 only shows drive "C:\" & "BOOT".

The Linux instructions show example of using 0,2 to call out drive & partition but there is no place to do that. Is this a case where 1.7.2 is user friendly so now it doesn't list drives?

How do I select the correct drive?

thanks!
 

mqudsi

Mostly Harmless
Staff member
#2
Hi eturk, welcome to NeoSmart Technologies.

You're looking at the wrong page. One on the Add/Remove Entries section, you need to select the "Linux" tab in the bottom-half of the screen. It's the tab with a Penguin on it.

Once you click that tab you'll see a list of drives & partitions, and you'll be able to select 0,2 from there.

Good luck.
 

eturk

New Member
#3
only drive 0 in list though

You rock! thanks for getting back so quick!

That's the rub, there's only Drive 0, Partition 0 shown in the dropdown. Maybe it only shows physical HDs in PC? I have Ubuntu installed on a removeable drive and also have a USB drive, not showing. (screen attached)

Thanks!

BTW, since I have an Intel RAID 0, most other OSs don't recognize it. Ubuntu, OSX, etc. see 2 raw drives, not array. This is where Vista has better support. Thus I'm trying to load 2nd OS on a removable drive rather than slow down my machine by dropping RAID.
 

Attachments

mqudsi

Mostly Harmless
Staff member
#4
Hi eturk,

EasyBCD's support for removable drives depends on how Windows itself sees/recognizes the drive. You can see this thread for another EasyBCD + external USB drives issue: Dual booting Vista and Ubuntu - The NeoSmart Forums

The solution in that case was to attach the removable drive directly to the PC (i.e. not via a USB hub). I don't know if this is applicable in your case?
 

eturk

New Member
#5
OK, I see your comment in that thread: "Bah... EasyBCD isn't detecting Removable Drives there :frowning:"
So the problem is 1.7.2 doesn't see external drives. You want to add this for 2.0

is there a way to manually write in the drive (dev) since EasyBCD doesn't populate the dropdown correctly?

I've got 8 drives, they should all display in the dropdown. For example, the DVD drive should always be in the list in case someone wants to boot off a CD-bootable OS. Pretty much every PC has a DVD drive. Agreed?
 

mqudsi

Mostly Harmless
Staff member
#6
You can't chainload a DVD though, because a DVD doesn't use the traditional MBR + Bootsector format.
 

eturk

New Member
#7
OK, so we'll have to wait for easybcd v2.0 to correctly list all the drives in our Vista machine? like out external USB, etc? (as you said in that post)
 

mqudsi

Mostly Harmless
Staff member
#8
EasyBCD 2.0 might have support for external USB drives that are not recognized by Vista as being physically-attached hard disks. You have to realize that the way the OS sees the drives is very important - you should focus on getting it to see them as real drives instead of removable ones.
 

eturk

New Member
#9
My VAIO bios does have a setting for booting from external drives, but no documentation for how that works. How do we get Vista to see the drives as real?

I hear of people booting off external drives and this is my aim. Intel RAID makes this essential.
 

mqudsi

Mostly Harmless
Staff member
#10
It mostly depends on the external hardware being used, not the BIOS.

For instance, the controller for your USB drive and the way it's attached to the PC.
 

eturk

New Member
#11
thanks bud!
So it sounds like at the boot level a driver would be needed for usb?
where can i find out more about drives during boot loader? Intel RAID is just unavailable to any other OS and going to std drives makes no sense.

cheers!
 

JustinW

Super Moderator
Staff member
#12
It is the type of device you're using that is the issue if Windows sees it but it doesn't show in EasyBCD. Not all USB devices are supported as valid boot devices (though most are). I'm chainloaing to my external drive to boot my linux distros because of neogrub and EasyBCD. So no, it is not a problem with EasyBCD. I'd test to see if the device is capable of being a boot device by seeing if it shows up in the boot devices menu or check the boot order in the BIOS.
 

mqudsi

Mostly Harmless
Staff member
#13
Like kairozamorro says, it's not a driver issue. If anything, it's a firmware issue - what the drive reports itself as being when Windows asks.
 

eturk

New Member
#14
I do see both my Cooler Master Xcraft USB drive & my VAIO flash drive (shows as USB key) in my BIOS. Can move them to be first in boot order also. There is a feature in the BIOS (turned on now) that allows this, thus they show in BIOS. Played with Unplugging them and BIOS updates, so it is showing them at system start.

Hmmm, seems like they appear to the BIOS in boot order but EasyBCD doesn't list them.
 

mqudsi

Mostly Harmless
Staff member
#15
As I said, it's how Windows sees them that's the big question.

To boot from an external drive via the BIOS all you need to do is install GRUB to the drive's MBR. But for EasyBCD to interact with the drive, it needs to be recognized by Windows as a valid, fixed drive.
 

eturk

New Member
#16
Ah, think I'm getting it? Vista boot manager can't see these drives but Grub, Paragon Boot Manager, etc. can?

Is there a tool to see how the drives are reported? The BIOS sees them in the boot list.
 

JustinW

Super Moderator
Staff member
#17
You prob. in the end want to use Vista's bootmgr as the primary OS loader, so you really need to be concentrating on all the possible reasons of why it isnt working in Windows. If it doesn't work in Windows, the bootmgr sure as heck won't be able to boot from it. It doesn't sound like you are having any problems as far as the BIOS goes, but keep reading to see some possible solutions for it and getting EasyBCD to detect the device in Windows.

From some of your recent posts, it sounds like the feature you are talking about in the BIOS is USB emulation. Some BIOSes have the option to enable/disable it. If enabled, the BIOS allows you to boot from USB devices, but if disabled, it doesn't. Since Windows is detecting the devices just fine, try disabling emulation and then see if you can add it in Windows. Then re-enable emulation in the BIOS to boot from the USB device. Or try the simple steps, such as:

1) Assuring you have the latest drivers and BIOS for your machine
2) Plugging in the device to a different USB port (Windows may have not have recognized the device correctly). If the device appears in device manager, you could also try uninstalling the driver manually and then plugging back in the device. This sometimes makes Windows re-recognize the device and its drivers as if you plugged in the device for the first time.
3) Checking to see if the device appears in the Safely Remove Hardware list, accessible from an icon with a green checkmark in your system tray (by the time).
 
Last edited: