EasyBCD 2.0 BEta

svnp10

New Member
#1
Hi,
I have tried, as you suggested to use version 2.0 beta release, to boot Fedora 10 from IDE with "Grub isn't installed to the MBR/bootsector" checked. I have Windows Vista and WIndows 7 on Sata drive. My Master Boot loader is still Windows' boot loader. Obvioulsy I have used EasyBCD to add Fedora 10 entry.
I have boot (and grub)directory on partition 0 on disk 0, and fedora on partition 1 of disk 0, this is as viewed in EasyBCD. I installed GRUB to disk 0. Disk 0 is not system drive. System drive is SATA drive.

When i selected to boot Fedora 10 from OS list on windows OS choice, it takes me to "grub>" prompt. It doesn't boot into Fedora.

By using 'configfile (hd1,0)/boot/grub/menu.lst' at 'grub>' prompt and i am able to boot any OS. I have menu.lst configure for chainloading Windows. Let's not get into it.

As view from 'grub>' prompt:
I have boot directory on (hd1,0) and Linux on (hd1,0). /boot/ directory has the grub installed and (hd1,0) has the rest of the linux. hd0, which is SATA, has 4 partitions with first two partitions have Vista and Windows 7.

My point is checking "Grub isn't installed to the MBR/bootsector" doesn't help me boot Fedora 10 with EasyBCD 2.0.
 
#2
Hi,
I have tried, as you suggested to use version 2.0 beta release, to boot Fedora 10 from IDE with "Grub isn't installed to the MBR/bootsector" checked.
Hello again, svnp10. If you're referring to [post=37522]this thread[/post], actually I said quite the opposite. I told you that that option does not work with Fedora, due to the separate /boot partition Fedora uses, and that you will need to configure NeoGrub manually in order to boot it.
I have Windows Vista and WIndows 7 on Sata drive. My Master Boot loader is still Windows' boot loader. Obvioulsy I have used EasyBCD to add Fedora 10 entry.
I have boot (and grub)directory on partition 0 on disk 0, and fedora on partition 1 of disk 0, this is as viewed in EasyBCD. I installed GRUB to disk 0. Disk 0 is not system drive. System drive is SATA drive.

When i selected to boot Fedora 10 from OS list on windows OS choice, it takes me to "grub>" prompt. It doesn't boot into Fedora.

By using 'configfile (hd1,0)/boot/grub/menu.lst' at 'grub>' prompt and i am able to boot any OS. I have menu.lst configure for chainloading Windows. Let's not get into it.

As view from 'grub>' prompt:
I have boot directory on (hd1,0) and Linux on (hd1,0).
Ok, so are you saying you are not using a separate /boot partition?
/boot/ directory has the grub installed and (hd1,0) has the rest of the linux. hd0, which is SATA, has 4 partitions with first two partitions have Vista and Windows 7.

My point is checking "Grub isn't installed to the MBR/bootsector" doesn't help me boot Fedora 10 with EasyBCD 2.0.
See our Neogrub documentation for configuring your menu.lst manually.
 

svnp10

New Member
#3
hi 007,
I am using a separate /boot partition.
I tried editing neogrub.
I changed the line "configfile /boot/grub/menu.lst" to "configfile /grub/menu.lst"
It didn't help.
I suspected incorrect drive mapping and added root(hd1,0) before the configfile command in neogrub file. that didn't help too.
Do you know what needs to be changed on newgrub.
 

mqudsi

Mostly Harmless
Staff member
#4
Please try the newest EasyBCD 2.0 build.
 
#5
Nevermind. :grinning:
The [thread=642]latest build[/thread] (61) should fix that option, so that it will work even with Fedora, despite having a separate /boot partition. CG posted the build that fixes that problem within hours after making my last post, so it is no longer true. :??

Please give feedback on whether it works for you or not.

Jake
 

svnp10

New Member
#6
Sure, let me try. I will try the new build 61 with "Grub isn't installed to the MBR/bootsector" checked.

Addendum:

Thanks a million. It worked.
In the previous build I changed the neogrub file to have command "configfile /grub/menu.lst". That didn't work for me. But the same command works now.

I have removed all the fallback options in the neogrub file. I just have one entry and made it simple as it looked in the previous versionss.

Here is how it looks now:
-----------------------------------------------
find --set-root --ignore-floppies /grub/menu.lst
configfile /grub/menu.lst


--------------------------------------------------

I am not sure why same changes i did in previous versions didn't work.
Is there anything else I am missing?
Just to enlighten myself

thanks anyways
 
Last edited:

JustinW

Super Moderator
Staff member
#7
Glad you got it working :smile:

And CG does it again :joy:. Right on about fixing auto-configure too to handle multiple boot.ini entries :grinning: