EasyBCD 2.3 and 2.4 will not start on my Win7 (x32) PC

#1
I've had EasyBCD 2.2 for many and it stills works. I want to upgrade to the latest version but the program fails after starting with no noteceable error message. I know others have had this problem and very few ever find an answer.

I'm giving EasyBCD 2.4 another go. I updated my NET Framework to version 4.8. EasyBCD still doesn't start but I have found some messages written to the Event log.

After installation, there's an attempt to start EasyBCD. The program asks if the usage is Private or Commercial. I click 'OK' and then nothing.

The Event messages I've found are:

Event Error Messages.jpg

The last message (@5:30:34) is

Faulting application name: EasyBCD.exe, version: 2.4.0.237, time stamp: 0x5bfeecfa
Faulting module name: KERNELBASE.dll, version: 6.1.7601.24441, time stamp: 0x5cb9383e
Exception code: 0xe0434352
Fault offset: 0x0000845d
Faulting process id: 0x1eac
Faulting application start time: 0x01d57da1e0bef3bd
Faulting application path: C:\PROGRAM FILES\NeoSmart Technologies\EasyBCD\EasyBCD.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: 219aba16-e995-11e9-bd49-001f299b7c25

The earlier message (@5:30:32) is:

Application: EasyBCD.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Runtime.InteropServices.COMException
at System.Management.ThreadDispatch.Start()
at System.Management.ManagementScope.Initialize()
at System.Management.ManagementEventWatcher.Initialize()
at System.Management.ManagementEventWatcher.Start()
at _._._(_._)
at NeoSmart.EasyBCD.MainUI..ctor()
at _._._()

I've tried deleting the folder 'C:\Users\usrGreg\AppData\Local\NeoSmart_Technologies', many times, but it doesn't make any difference.

Any suggestions?

Win7 Pro (x32)
 
#2
That is exactly the reason I went back to version 2.2, because it works, and the newer versions do not.
It seems that this company doesn't seem to respond to users who are having problems and they certainly don't seem to care about fixing the problems.
But I have another problem which I can't fix either.
I put my EasyBCD 2.2 on a timeout of 30 seconds and when it comes up the first time it shows 30 seconds.
But the next time I boot up it only shows 5 seconds.
I have changed this back and forth many times, but it always defaults to 5 seconds no matter what I do.
 
#3
Hi BBacle, I see I am not alone.

MQudsi has addressed this issue a number of times in the past. His suggestions have helped some people but not others like you and me. He usually asks if there is anything on the Events log. I found something last week which is why I re-opened this issue.

I have EasyBCD for personal use and so there's no obligation on him to address my issues. I'm posting in the hope that what I saw on my Event log may trigger something that explains why EasyBCD doesn't start.
 

Terry60

Knows where his towel is.
Staff member
#4
Both 2.3 and 2.4 have worked perfectly on W7 and W10 for me.
Nobody other than the author will be able to diagnose the kind of runtime errors you report and advise what the problem with your particular PC is likely to be.
Unfortunately, he doesn't appear here in the user forum as frequently since becoming a new father as he did when he was a grad student.
I'll try to help with any problems using EasyBCD, but failure to execute is outside the remit of anyone other than the author, unless you can find a historic answer which addresses the same issue as you're experiencing.