EasyBCD crashes upon program start

DU-CH

New Member
Hi, I installed Windows 7 Pro x64 and Linux (OpenSUZE 11.2) on a new PC. No problems with either. However, I want the Windows Boot Manager to choose betwen W7 and Linux and found no way yet. EasyBCD should be able to solve the problem – however, I could not manage any version of it to run at all on Windows 7 Pro x64 (including even the last 2.0ß). I always get only an immediate program crash with the error 0xc000007b. Administrator rights do not help (neither for installing EasyBCD, nor for running it). Note: Windows 7 does not recognize the Linux installation, and the Linux installation does not start from Windows 7 because the Windows installer fails to configure correctly the boot manager.
 

mqudsi

Mostly Harmless
Staff member
You need to install the .NET 2.0 Framework first.
 

Flasharino

New Member
I have the same error in Windows 7 x64. I have verified that .net 2.0 SP2 is present using the MS .net Framework Setup Verification Tool (shown). Any other suggestions?
 

Attachments

Terry60

Knows where his towel is.
Staff member
Try deleting the NeoSmart folder from your Users/yourname/ app data/local folder and reinstall.
 

Flasharino

New Member
There is no NeoSmart folder in my c:\Users\[myname]\AppData\Local\ directory.

I tried installing again anyway by running the installer for v2.0.2 As Administrator. Still no NeoSmart dir there.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
You must have a corrupt .NET framework.
EasyBCD has no problem running on W7 x64 (that's what I'm talking to you from)
 

Flasharino

New Member
As mentioned, the Microsoft utility to validate the .net 2.0 installation verified the framework install. Is it acceptable that the 2.0 is SP2? Is there some way to log details of the EasyBCD error or get additional information about the problem? Is it an issue that there is no NeoSmart directory in the location you pointed out?
 

mqudsi

Mostly Harmless
Staff member
Do you by any chance have Zone Alarm Firewall installed?
 

Terry60

Knows where his towel is.
Staff member
I didn't ask that, because last time I used ZoneAlarm, they didn't have a 64 bit version for Vista/7.
Maybe they do now ?
 

Terry60

Knows where his towel is.
Staff member
In that case, disable it temporarily while you install EasyBCD, then restart it.
It's well known to cripple .NET installations.
 

Flasharino

New Member
I shut down ZoneAlarm completely, ran the installer (As Administrator) and I am still getting the same error. I also see that there is no 'NeoSmart' directory anywhere within the 'Users' directory or subdirectories.
 

mqudsi

Mostly Harmless
Staff member
No, you'll need to uninstall it.

It's a known issue, ZA for some reason stops EasyBCD from running.
 

Flasharino

New Member
The application uninstalls the existing one when run. I manually uninstalled anyway then ran the installer with Zonealarm shutdown and still no luck. Do you think it might work if I manually put the required files in the Appdata directory?
 

mqudsi

Mostly Harmless
Staff member
No, no.. those aren't required files.

It's definitely a ZA issue. The odds of it *not* being one, yet you having ZA installed are astronomical.
 
Top