EasyBCD - Does not SAVE or show latest entries on test PC

Tweakzz

New Member
#1
Hi all,

Have been having this very frustrating issue.
My EasyBCD 2.2 newly created or renamed menu entries DO NOT SHOW UP.

I put the USB back into the "program" PC and there they are????
But in the other "test" or "boot" PC it won't show the entries - usually some older or previous or original entry.

Main programming PC is a Asus Z77 i Deluxe ITX MoBo
Using Windows PC (Win 8 x64..but i recall it did the same on Win 7 x64)
Easy BCD 2,2 Comm Edition
Making a multi-boot USB (H) - tried USB 2 and 3 ports, and later on a hub just to be sure. Same on any/all.


So i browse to the H\boot\BCD and open that.
Create my menu's and then under Edit Boot Menu" and also "advanced setting" - i click SAVE in both, back n forth to make sure.

BUT - when i boot my other TEST PC with USB "H" - i see the old menu?????
And many times its also corrupt...

If i plug H back into the main programming PC - EasyBCD shows my latest entries.
Unplug it again and no luck...well, if i do it enough times i am sometimes lucky - but that is too hit and miss.

Another thing i noticed today and yesterday is some entries seem corrupt!!??
First two or three lines read ok - then strange characters appear....

I have tried different USB port
I have bought 4 different brands (2 each) of USB to try. Most USB 3 but i use USB 2 occ. to see if that makes any difference -(none s far)
My USB are mostly 32 or 64GB - but even on 8GB the menu error also appears - so no matter 1, 2, 4, 8, 32 , 64GB USB - any brand , all give errors

Ran chkdsk on main PC and on USB's. (no errors found!!!!)
Defragged all i could.
------------------------------------------------------

Any ideas anyone? This is holding me up enormously!

FYI - i tried using BCD onboard boot and BCD maker - no boot!!
So i used Microsofts USB ISO to Flash tool - using Win 8 x64 ISO - when finished it is H drive - then i simply edited the /boot/bcd store.
Later i make a root folder called ISO - in that are the Minitool partition Magic, macrium and win 8 install ISO's.
I have had them all work - then to try adding partition 2 with linux - but i cannot get that far with this menu issue.
Is there another way to make the USB bootable and yet maintain Win 8 install capability? (in case its my method??)

---------------------------------------

thanks in advance
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
Your post jumps around too much. I have no idea what you're trying to convey.

One sentence description of your problem, please.
 

Tweakzz

New Member
#3
Wow - ok ...i thought it was simple...let me please apologize profusely and try simpler...thanks

When i create the menus on the USB (selected BCD store) they obviously show.
I select "save"..wait for little confirmation scroll on lower part of the EasyBCD window...and i do a few saves just in case.
And i wait between "click saves" .

Then i try the new USB menu on a test PC by booting it from the USB.
BUT then i only see one or two 'menu entries' - not the full list of menu items as i just recently created!

This happens on all my brands USB and nearly consistently.

- and when i return the USB to the "programming PC" - there they are?
I leave EasyBCD open or 'running' on the programming PC - refresh BCD store to check..and there ALL the menu items are..
yet when i boot a PC only one or two may show..

So what do i need to do to save them properly..or make the booting PC see them all?
(ps - i switch the test or booting PC on /off, i reset it, power down and up - no change)

Hope that is clear enough? Thanks a mil.

Cheers

edit: adding example as it again/still is doing this..
1) Open EasyBCD - select BCD store = USB (I:smile: - root\boot\BCD
2) I add menu entries e.g.

----------------------
macrium mem
macrium disk
part magictool mem
part magictool disk
gparted mem
gparted disk
Win8 install mem (to test mem vs install, tho on this one its too big for mem if i recall correctly)
Win8 install disk
Linux (grub2)


save...wait..save...

remove USB from PC1 9programming PC)

Boot PC 2 from this USB
now i see the menu as follows...

------------------------------
macrium
part magictool
gparted
Win8 install
Linux (grub2)


Huh - i did not have those names ever or at all?
And of course none work.
I reboot the test PC, same error


NOW i put the USB back into PC 1 (programming PC) - refresh BCD store. (i can try reload BCD store - no diff - menu is as i made it)
There are all my proper original entries like before i tested it.
I try and make the timeout "wait for x seconds - but i notice the "time" is greyed out - so i cannot adjust time?

Now i reload - select BCD store and NOW the timeout time option is adjustable.
Seems i had to twiddle with that timeout else reloading or refreshing and then saving makes no effect at all.
So now i save a few times...again
And i remove USB to test it again....

AND NOW IT WORKS!
Just saving does not work.....
So if IF i reload BCD and save - or refresh it, and save - it DOES NOT WORK! (The test or booted from USB PC will not see my menu as i made it)
I seem to have to adjust user timeout or "other" areas before it realizes the changes i made and THEN it saves OK.

Hope that is detailed enough?

thx
win 8 enterprise
various brands USB 8/32/most 64GB
 
Last edited: