EasyBCD doesnt work after fixing MBR

#1
I had a rather nasty Windows / Linux Mint situation where i accidentally install a Linux Mint grub bootloader to my Windows system partition. This caused me not to be able to boot from windows but I could load Linux Mint just fine from Grub. None of the regular repair solutions would work to recover my MBR from a windows repair disk. I had to use a program called Bootice to reinstall/repair the MBR using it's option windows 6.x.

Happily I could now load windows but i noticed the boot loader was one I had set up a long time ago with EasyBCD. My two options were Windows and a copy of PCBSD I had installed at one time.

After booting into windows I tried to use EasyBCD to fix this. On startup of EasyBCD It could not find a valid bcd configuration. I loaded a saved configuration thinking I could simply edit it with new settings that would allow me to boot into either windows or Linux Mint. I made sure Windows was the default OS then set up a new entry for Linux pointing to it's partition.

This did not work. No matter it seems what i do with EasyBCD how I configure it or even resetting the BCD or repairing the boot files from the BCD backup repair menu, Windows still loads with the older Windows PCBSD options. I cant change the PCBSD to Linux Mint. I do not know if this is because windows is really loading an older copy of the MBR or BCD from my windows system partition or something else. In EasyBCD, I have my default windows OS pointing to the C drive, not Boot.

I await your reply and appreciate your time. Thank you.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
In EasyBCD > Tools > Options > General Settings do you have anything ticked and/or a file specified in the "automatically load ....." box ?
 
#3
The automatically load check box under Options > General Settings is Not checked. If it were, the system should try to load the backup copy of the BCD that I saved with EasyBCD. I assume I should try checking this box?
 

Terry60

Knows where his towel is.
Staff member
#4
It depends on which build of EasyBCD you're using. There's a bug (fixed in the latest Betas) from a few builds back where the tick for "auto.. load..." got put in the box above by mistake. If you can see a greyed file in the box and the option above is ticked, get the latest Beta and look again.
Then untick the option to make sure Easy is picking up the "live" BCD.
 
#5
I can see a greyed file in the box and the option above Not is ticked. Version I have is 2.1.2

A little more info that may help you nail down my problem. I did try to select a backup to auto load at startup and checked the box. This allows the EasyBCD config file to load at program start but does not effect the loading of the boot menu on system reboot. No matter if this check box is checked or not, I get the same results. I have windows 7 as default OS to boot into. I have tried it with pointing to my BOOT partition and pointing to C:. The second boot option I added is Linux Mint pointing to it's install partition. Switching from BOOT to C; doesn't help, the boot loader still only gives me the option of booting from Windows 7 or PCBSD which does not really exist.

Also, according to Disk Management I have a 199 MB System partition which is Active and My C drive is the Boot drive. It appears as if EasyBCD's BCD config files are not being read by the Active System partition's MBR. ( assuming I understand this right)

Where is the MBR getting it's BCD data? Obviously it's not reading what EasyBCD has set but then.. where is it getting the BCD it is using ? If I knew this.. perhaps I could edit or delete this data and point the MBR to the EasyBCD data I really want it to load?
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#6
If you're loading, and operating on, a backup BCD, then no changes you make will have any effect on the boot menu you see at startup.
Get the latest Beta to be sure you are specifying the live BCD.
The MBR goes to the "active" partition to find the boot files (which is where EasyBCD also looks if that override field is not in use)
 
#7
O.k.. I uninstalled the 2.1.2 version and installed the EasyBCD 2.2 Beta - Build 177 version. On program start I get the error that it could not find a valid config file and asks me if I want to load one from backup. I tell it, No. The program loads and I attempt to add a new Windows 7 default entry because there are no entries. All boxes under Add New Entry are greyed out. Under the Windows tab there is no default Windows 7 listed and I cannot click on any of the other tabs.

Am I not pointing it to the Live BCD correctly?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#8
You can't select no. You must select yes, then browse to /boot/bcd
 

Terry60

Knows where his towel is.
Staff member
#9
That would indicate that your BCD is not on the active partition of the first HDD in the boot sequence. (default where Easy looks).
Is your BIOS boot sequence correct ?
 
#10
Computer Guru, I dont have a boot/bcd. I have a Boot folder under Windows.. but it has no BCD files inside it.

Terry I haven't checked but I never changed the boot sequence in my Bios ever. That said, I have no idea what exactly the program Bootice did to fix my MBR ( if it moved things around in a non normal way)
 

mqudsi

Mostly Harmless
Staff member
#11
Hal, you need to enable viewing of both system and hidden files. You can't boot into Windows Vista and up without having a BCD file *somewhere*.
 

Terry60

Knows where his towel is.
Staff member
#12
You don't need to have changed the boot sequence intentionally. It can change by itself if you disconnected drives temporarily while you were trying to sort-out your PC.
Post a screenshot of your Disk Management and we'll look. (the sticky will tell you how if you need help)
 
#13
Thanks guys, and I would like to know if those new ideas would have fixed the problem.. just so you can better help others - But, I managed to fix the problem.

Where ever the BCD data is, (doesn't matter) I trust EasyBCD to look in the right places for it by default - that's how it's designed you know.. I know I never changed the location of the hard coded BCD data or even if that's possible. I reasoned that for some reason, EasyBCD could not find the data then it had to be a Windows problem that caused the file EasyBCD was looking for, not to be read. Either it was corrupted or not in it's proper location. I preformed an In Place Upgrade of Windows 7. Instantly on starting EasyBCD without me telling it to look in any specific location, it found the correct BCD file. I was able to edit out the old non existent PC-BSD entry. and so far, EasyBCD is working normally.

My problems with EasyBCD only occurred after I used the software Bootice to fix my MBR, so I suspect it may be some unorthodox way in which Bootice fixed the problem that caused the correct BCD data to not be read by EasyBCD.

Computer Guru, I always have the show system and hidden files checked btw, so if the file was there, I would have found it. I suspect it was not where it should have been.

Terry, As mentioned above, I already used the tutorial to check Disk Management for problems and didn't find any... I took a screenshot then and it is exactly the same as the report is now. Here it is: er.. wait.. I'll post it when I find where I put it. LOL Be back in a few minutes.

DskMgnt.JPG

If you guys have other tough problems like this, you may consider recommending a repair install or In Place Upgrade as they call it. I found the process to be simple and worked flawlessly. All it's doing it restoring your system to correct working settings without messing with your installed programs or data. I used this tutorial. How To Reinstall Windows 7 Without Changing Your Personal Settings, Installed Programs Drivers

I do thank you kindly for all your patience and help. I would not have been able to find the solution without your help in finding what worked and didn't work.
 
Last edited: