Error running EasyBCD in XP

#1
Hey,
I've replied to an old thread in a different area of this forum, but thought I may get a better response if I posted in here:

http://neosmart.net/forums/showthread.php?t=1290

For reference, that's the old thread ^^^^^^^^^^^

My problem is as follows:

I have a dual boot Win XP and Win 7 on my laptop, and I'm trying to convert my Windows XP installation into a VMWare Virtual Machine. To cut a long story short, I need to strip away the Windows 7(Vista) boot loader in oreder for VMWare to recognise my Windows XP system volume.

I've installed EasyBCD in my Windows 7 installation and it loads up fine, BUT if I disbale the window 7 boot loader then I will need to use EasyBCD in Windows XP in order to reinstall the Windows 7 boot loader.

However, when I install and run EasyBCD under my Windows XP installation I get this error:

EasyBCD has encountered a problem and needs to close. We are sorry for the inconvenience

with the option of sending an error report or not.

I've followed the advice from the previous thread, and re-installed .net 2.0, but in order to do that I had to remove pretty all the versions of .net that were already installed (1.1, 2.0, 3.0, 3.5). Anyway, now I have just .NET Framework 2.0 and I have reinstalled EasyBCD but I'm still getting the same error.

I've since re-installed Service Pack 3 and and gone to windows update and installed all the latest updates etc. This has updated and installed all .net frameworks to the most recent revisions.

However I'm still getting the same error whenever I try and run EasyBCD.

I've attached a screenie of the error, and the data contained within the error.

Any ideas would be gratefully received...
 

Attachments

Terry60

Knows where his towel is.
Staff member
#2
Hi machin, welcome to NST.
Is this happening with EasyBCD 2.0 latest build ?
(You'll need it anyway - 1.7 doesn't contain the code to auto-configure XP included in 2.0)
 
#3
Having only just signed up to the forum I hadn't realised there was a Version 2.0.
I'll give that a go and let you know.
Cheers Terry

Addendum:

Hi,

I've tried the new beta build 64 of Version 2.0 but I'm still getting the exact same error as with 1.7.4

Works in Win7 but not in XP.

Any other ideas?

Cheers,
Will
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#4
There's obviously something broken in your XP .NET environment, but I've no practical experience to even begin to suggest a cause or a cure.
Hang around till Guru, or someone else with some .NET expertise shows up.
 
#6
Cheers for the help so far, hopefully someone can help assist with any .net solutions.

I'm logged in as an administrator and have never experienced any isses installing or running any software that require admin rights before so I can't see that being the issue. I will, however, log in as the local admin and give that a try. Although I can't give that a go until tomorrow morning.

Keep the suggestions coming though!

Cheers,
Will
 
#8
Hey,

Just to clarify. I'm logging in with my own user account on our domain, but this account is part of all the relevant administrative groups, Domain Admins, Administrators etc... That's why I said that I was logged in as "AN administrator". What I've tried this morning is logging on to the machine as the local user "Administrator"

Alas this still didn't work but will try your other solutions shortly.

Cheers,
Will

Addendum:

Well in the meantime, you can try deleting all the files/folders that can be found in the following folder:

c:\documents and settings\<user>\application data\local\neosmart_technologies

Then try running EasyBCD again.
Hi,

I tried to locate this folder but I couldn't find it under any of the user profiles in the Documents and Settings folder. I performed a search at the root of the Documents & Settings folder for neosmart, and the only results reffered to the sortcuts for the application in the "All Users" profile.

Maybe the application data is only created after you've run the prgramme for the first time?

I suspect this is a .NET issues but beyond what i've already tried, I'm running out of ideas...

:scared:
 
Last edited:

JustinW

Super Moderator
Staff member
#9
Is EasyBCD being blocked somehow say a firewall? I notice you've got 1.7.2 there. You should try our latest [thread=642]beta[/thread] of 2.0 to see if the problem persists. You could try re-installing EasyBCD/.net. I've never tried EasyBCD in a domain before so your best bet it using the local admin account.
 
#10
Is EasyBCD being blocked somehow say a firewall? I notice you've got 1.7.2 there. You should try our latest [thread=642]beta[/thread] of 2.0 to see if the problem persists. You could try re-installing EasyBCD/.net. I've never tried EasyBCD in a domain before so your best bet it using the local admin account.
Hi,
Thanks for your reply.
I've upgraded to version 2.0, it was only after signing up to these forums that I realised there was a version 2.0 available. Anyhow, it's still generating the same error as before.

Are you asking whether there is some software blocking the exe from running, when you refer to a firewall? Anyway, I'm running EasyBCD 2.0 as a local admin, without a network connection, with no firewall/av software running. I don't think it's a domain issue, as EasyBCD runs on my Win7 when logged on to the domain.

I've totally stripped off and then re-installed all my .net versions and then reinstalled EasyBCD 2.0 and apart from this I don't know how else to troubleshoot any potential .NET issues.

When looking at the content of the error report, this is what's displayed:

EventType : clr20r3 P1 : easybcd.exe P2 : 2.0.0.64 P3 : 4ab26985
P4 : easybcd P5 : 2.0.0.64 P6 : 4ab26985 P7 : ee P8 : d4
P9 : system.invalidoperationexception

Any good?
 
#11
I'm having a problem with EasyBCD as well. I was getting an error when I started EasyBCD but when I updated all my .Net stuff the errors went away, but now it doesnt open at all. Not even an error to mention. So I have no clue what to do to get it to work. My Cousin had a PC with Vista and wanted me to dual boot his system and that worked when I used EasyBCD, Installed XP, ran it in XP, fixed boot loader, and it worked.

I did the same thing with my fathers PC and this is when I get the errors with Easy BCD, Same exe 1.7.2 and cant seem to get it to work. Does anyone have a fix for this? I havent tried 2.0 but I dont think its the problem but I dont know much. One diferance with the XP installs, This version is fully updated with SP3 the other for my cousin was only SP2 but idk if that matters or not.

Thanks everyone for any help u can offer