Famous Bootmgr error

ziki

New Member
#1
I dont know how it happened but earlier today i just finished 4 mandator updates, and was prompted to restart which i did. After that i keep getting the dread bootmgr is missing press ctr+alt+del to restart.

The windows recovery console has not been able to fix this.

I can only access windows with hirens boot cd, with the option boot from hard drive (bootmgr is missing).

I then tried everything. I reset BCD, i then readded it and repaired, i selected write MBR, but nothing sems to be able to fix this.

I am running win 7 home premium, which is my only OS. It is installed on my SSD with AHCI enabled.

P.S. I also tried the install BCD option for my C: drive before i got to read that it is only aimed at portable devices...

Please help me, i am so out of my way on this one...
 

Terry60

Knows where his towel is.
Staff member
#2
Check your BIOS boot sequence to make sure you're not going to the wrong disk, then do the "startup repair" again (3 times) if necessary.
 

ziki

New Member
#3
For some reason boot drive was mentioned last... I never set that myself. Was it always like that, or is it possible it was altered by the windows update or some virus?

I have 4 mechanical drives and one SSD. The priority was like that.

CH0-Master
CH0-Slave
CH3-Master
CH3-Slave
SCSI-0 SSD

Was it last because sata mode for this port is set to AHCI and it was viewed as SCSI?

I remember possibly re-ordering priority before using easyBCD but problem was not solved. So did i also have to use the easyBCD menu before i had to move priority?

Problem seem to have been solved for the moment, and thanx a ton, i really appreciate it!! I'm just asking all of this follow to try and determine what wet wrong in the first place...

Addendum:

Oh man something weird is happening! Every time i restart it doesnt detect the SSD. Then upon another restart it sets it position as last priority and i have to set it first. So here's how i have to boot.

1)Hit Restart on Windows.
2)Device not detected after POST, Bootmgr is blah blah...
3)Yet another Restart at that point
4)Set SSD first priority over the other drives.
5)Save CMOS and restart for the last time.

Seriously?
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#4
Check the voltage on your CMOS battery. Maybe it's losing it's memory between boots.
 

ziki

New Member
#5
No i dont think its that. I base my answer due to the fact that at times when i restart (it seems not always) the drive is not even recognized, i even checked one time, and it only showed the other 4 on the hdd priority. And consequently when that happens, the drive changes priority to being the last one.

The real question now, is what does it happen to cause the SSD not to POST? IS it due to the fact that i have lots of drives booting at once? Or maybe a controller malfunction, or due to the fact that it is AHCI enabled? These are ,my best guesses...
 

Terry60

Knows where his towel is.
Staff member
#6
I've encountered "lost" HDDs in the past (in the pre XP days that caused all remaining HDDs to change letter assignments, with the consequence of all apps failing in a cascade of errors) which were due to simple dirty contacts.
Try disconnecting/reconnecting the power and data leads to your SSD several times to clean up the pins.
 

ziki

New Member
#7
Ok i will make sure the SSD is connected right. A final question that bothers is this.

IS there any chance I caused any trouble by reseting,recreating-repairng BCD, and Writing MBR and installing BCD on fixed drive and all of which, i did before i realised it was a simple matter of disc priority?

Do i need to undo or correct any of the previous actions?
 

Terry60

Knows where his towel is.
Staff member
#8
The fact that it does boot OK when it's top of the heap would indicate that you haven't caused a problem by what you did.
Post the contents of EasyBCD "view settings" (detailed) and a DIsk Management screenshot when it's running and we'll see if everything looks normal.
(how-to details in the sticky if needed)
 

Terry60

Knows where his towel is.
Staff member
#10
That all looks fine.
I notice F is active but none of the other HDDs, so its possible you might have created some extra W7 boot files on there (F\boot with the BCD in it and bootmgr) in which case you can just delete them.
 
#11
That all looks fine.
I notice F is active but none of the other HDDs, so its possible you might have created some extra W7 boot files on there (F\boot with the BCD in it and bootmgr) in which case you can just delete them.
Yeah i noticed that too. How can i delete them? I enabled option to show hidden files but i cannot find F:\Boot

Also do i really need a letter assigned for the system reserved partition? Shouldn I just remove the letter assignment?
 

Terry60

Knows where his towel is.
Staff member
#12
Boot files are "super hidden". You need folder options set like this to see them (if there are any there, I only said "might" be)
Unless you have other users you don't trust with your PC, or you're in the habit of randomly deleting files on a whim, I can't see why having a letter assigned makes any difference, unless you have so many partitions and USB drives attached that you're running out of letters and need it for something else.
 
#13
I ckecked those as well but i could not find boot folder on F. (It shows up on C though just fine...). How can i reverse the active status now? I found a way by using acronis disk director on another thread. I guess i only have to uncheck the"boot" box on the F drive. Isnt there another method though, so i dont have to get Acronis DD?




BTW i checked that the SSD is connected tightly to the mobo sata ports. It is indeed but this issue keeps happening from time to time... IF it is not realted to the fact that AHCI is enabled, what other reason can relate to the drive occasioanly not being recognised after POST? It is so weird.... Could it be that it doesnt get enough poer from PSU (doubt it)?
 

Terry60

Knows where his towel is.
Staff member
#14
There's no problem.
"Active" is just the flag to tell the MBR where to go next for the boot sector if you are booting that HDD
There can be an "active" partition on every device. It's a bit of a misnomer in common with all MS HDD flags.
In MS land
"boot" = "the system you're using at this moment"
"system" = "this is where to find the boot files that were used to start the above"
"active" = "MBR - start here if the BIOS says this is the HDD to boot"

Just look at my config, active partitions all over the place, no problem.
 

Attachments

#15
Ok then i wont worry about that. As for the SSD issue, do you have any other suggestions of what might be causing this? It really bums me out, that i have to do this over and over to boot the system...