GRUB2 installed, tried to restore WinBCD, cannot find boot registry. :(

hunterm

New Member
I'm using Windows 7 (32-bit, if that helps)
Well, I had GRUB2 installed, and when I first started EasyBCD 2.0.1, it said that it coulden't find a "BCD Registry". I kind-of expected an error since it probably expected to see Windows' bootloader. Well, I wanted to reinstall Windows 7's bootloader, so, I press No on the dialog box, clicked Bootloader Setup, and pressed Write MBR (With "Install the Windows Vista/7 bootloader to the MBR" radio button checked). Then, I closed EasyBCD, and opened it back up, hoping not to see any error from EasyBCD. The same error I got before re-installing it appeared. Any idea how to fix it?

Right now, I'm too scared to reboot my computer, fearing that I won't be able to boot into Ubuntu or Windows. Please respond! :frowning:
 

JustinW

Super Moderator
Staff member
BCD Backup/Repair > Re-create boot files. Before rebooting confirm theres an entry for Windows 7. Add a new grub2 entry for Ubuntu.
 

hunterm

New Member
I just did that. Still can't find BCD Registry. No entries.

Addendum:

Oh, great news!! :grinning:

I just found the bcd file, it was under the C:\Boot folder (which wasn't listed, and I even had hidden files showing.), so it detected entries, and I'm happy again :smile:
 
Last edited:

Terry60

Knows where his towel is.
Staff member
If EasyBCD isn't finding the BCD, it may be because it's not on the "active" partition.
Is the partition marked "system" also "active" ?
 
Top