Help with Boot problems.

#1
I bought a white Box with windows 2000 installed in it, windows 2000 was partitioned off with 20gb, so I installed XP Pro on the other 220gb left, then I added 3 more Hard Drives, 1 for storage and the other 2 for Vista and now wndows 7.
Before Vista had came out, I tried slip streaming an upgrade for Vista and I lost all the boot info. Computer would not boot to any of the OS. So instead of trying to fix the bootloader,( at the time I had wndows 2000, XP Pro, vista Business and Vista Ultimate)...I just reinstalled Vista Ultimate on one of the drives and never tried getting those other OS to boot up.

My problem is that the drive that has windows 2000 on it sometimes dissapears. and when I try booting back up, it can't find the bcedit.. for vista or windows 7. So I shut down my PC and unplug it, take the side off and unplug the problematic HD and plug it back in, boot it back up and it works until that happens again.

What I need help with is either to posibly move the Vista and windows 7 bcedit to another drive ?? I don't know if that is possible?
or maybe rebuild the windows 2000 and XP pro boot ini back so I would have all the OS working again?
Your help would be much appreciated.
Attatched is two pictures of the mess:nerd:
Thanks
 

Attachments

Last edited:

Terry60

Knows where his towel is.
Staff member
#2
Hi Pump, welcome to NST.
Your problem is that you've formatted all your new drives with a single extended partition, and installed each OS to a logical disk inside that.
Windows (all varieties) needs a primary partition for its boot files. Prior to XP, the definition of a primary partition was "one capable of holding an operating system". Since XP (SP1 or 2 I think) it has been possible to install Windows to a logical partition, but the requirement for a primary for the boot files has never changed.
The extended/logical concept was only invented when disks became large enough that users wanted to divide them into more than the absolute limit for primary partitions (i.e. Four, the number of entries in the partition table of the MBR)
Since you only have a single partition, there was no reason to make it anything other than primary. (you can have 4 primaries or 3 primaries and 1 extended).
You'll see that your 1st primary on the first disk is marked with the "system" flag. That tells you that the boot files for the running system reside there. (confusingly the "boot" flag just indicates which is the running system).
That 1st HDD is now an absolute "sine qua non". You cannot boot any of your OSs without it.
If you have the occasional problems you describe, (that's not unusual, though critical of course when the disk happens to be the boot disk), take the remedial action you describe, but unplug/replug multiple times to clean the tarnish layer of oxidation from the contacts on the HDD and the connecting lead. Don't forget to disconnect/reconnect the mobo end of the same cord, in case that's where the bad contact is.
 
#3
Thanks Terry, I kind of figured that the only way around this would be to just start over.:frowning:

Before I do that,, Since I still have the legancy bootloader still showing up and the 2000 OS and XP OS are still intack on those drives, How would I go about repairing or rebuilding the bootloader so it will boot into those drives? AKA Disk 0
Here is what shows from EasyBCD/Tools/ Edit Legacy entries

;
;Warning: Boot.ini is used on Windows XP and earlier operating systems.
;Warning: Use BCDEDIT.exe to modify Windows Vista boot options.
;
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /NOEXECUTE=OPTIN /FASTDETECT
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Professional" /FASTDETECT
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#4
If you're going to reinstall the new OSs into primaries, just connect each one individually with the other disks temporarily disconnected and do a clean install of each.
Choose whichever, Vista or W7 you want to be in charge (it has to be one of them - XP is not forward compatible and cannot boot either of them), and put it first in the BIOS boot sequence after reconnecting the other disks.
Boot the system and you should go straight into your chosen system with no option to boot the others.
Install EasyBCD 2.0 latest build (not 1.7), and add entries for the other longhorn system and one for XP.
Let it auto-configure XP when it offers and it should do everything for you.
When you next boot, you'll have 3 options in the menu, W7, Vista and XP.
Choosing XP chains to NTLDR which will give you a further 2 options for your XP and 2000 choice. (from boot.ini)
(One thing to note. Booting Vista from W7's BCD ,or W7 from Vista's should work either way round, but some people have reported problems (unsigned module) when booting W7 from Vista. The workaround is to use W7 at the top of the chain and use it to boot Vista if the other way won't work)
 
#5
OH Okay, I didn't know about version 2.0:smile:
So your saying just to start over and not mess with trying to get XP or 2000 to boot again.:frowning:
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#6
If you're happy to leave your new OSs on logical disks and boot them from the XP disk as at present, then just install EasyBCD 2 and add an XP entry, and it should automatically pick up and correctly configure the boot for your 2 legacy systems.

If you don't want the BCD residing on the XP disk, you'll need to make at least one of the new systems a primary, in order to get the BCD back with the OS.
 
Last edited:
#7
Got it :joy:Thanks Terry, I am going to try that just for the heck of it .

So to make sure of what I am doing, would I just go to Tools/Auto-Configure Boot ini. and select yes. as shown in Picture?
 

Attachments

Last edited:

Terry60

Knows where his towel is.
Staff member
#8
That dialogue is also launched automatically when you add an XP entry for the first time.
Simplest thing to do if you have an XP entry and it's not working is to delete it, add a new one and reply yes to the auto-configure.