Help with Windows XP and Windows 7 boot issue

#1
Hello,
First, the computere had windows XP installed on the PC with some issues. We installed Windows 7 on the same drive.
Now, when the computer boots a menu is presented and we have to choose windows XP or Windows 7. The default is set to Windows XP unfortunately.
I want to remove the reference to windows XP and make the computer start Windows 7 automatically.

1.) Currently, when I try to edit to boot menu in EasyBCD, it only shows a default of Windows 7. Possibly because, I selected the Win7 version to boot.
2.) If I select Windows XP options, I endup getting a blue scree partly the windows xp has many issues in the install..

Questions:
A.) How do I make Windows 7 the only boot selection in my situation
B.) I have removed the Windows.old (xp) install, but the references to XP on the PC confuses me.
Thanks
 

Terry60

Knows where his towel is.
Staff member
#2
Can you post a screenshot of Disk Management and copy/paste the contents of EasyBCD "view settings" (detailed mode).
 

Terry60

Knows where his towel is.
Staff member
#4
And Disk Management ?
 

Terry60

Knows where his towel is.
Staff member
#6
OK, let me see if I understand your problem.
You upgraded XP to W7 (no dual-boot)
EasyBCD shows only one system in the BCD
When you boot, a phantom XP entry appears in the menu ?

If that's a correct summary, check EasyBCD > Tools > Options for an entry in the "Automatically Load........." box
If you can see a data set in there (even greyed out), go to EasyBCD > File > Select BCD store, and navigate to
C:\boot\BCD.
(You will need folder options set like this to see the hidden system files)

If there's nothing in the box, try EasyBCD > File > Select BCD store, and navigate to
C:\boot\BCD anyway.
If EasyBCD isn't already using the correct BCD, it will start to do so.
If it is using the correct BCD, it will reject your attempt to select it with a message telling you it's already doing so.

If you were not previously using the correct BCD, you should now be able to see the XP entry in the EasyBCD "Edit boot menu", and delete it.
If the situation is unchanged, post back and I'll explain how to fix the problem.
 
#7
Hello Terry,
Thanks so much for your excellent support.
I followed the steps to the letter. On the first one, nothing shows in the box.
On the second step after un-hiding the folders, etc.. when I select c:\boot\BCD it says that the file is already Open /in use.
Anyway, I used notepad to open boot.ini and that's what it shows:
;
;Warning: Boot.ini is used on Windows XP and earlier operating systems.
;Warning: Use BCDEDIT.exe to modify Windows Vista boot options.
;
[boot loader]
timeout=5
default=c:\$WIN_NT$.~BT\BOOTSECT.DAT
[operating systems]
c:\$WIN_NT$.~BT\BOOTSECT.DAT="Microsoft Windows XP Professional Setup"
Which does not list the Windows 7 in it, even though EasyBCD sees Windows 7 and when I boot the PC I have the boot menu asking me to choose.
Do you know if I can manually edit that file to avoid seeing XP and getting the computer to start Windows 7 by default?
Thank you so much
 

Terry60

Knows where his towel is.
Staff member
#8
OK then. There's apparently some minor corruption in the BCD.
Ignore boot.ini, thats outside the BCD and not involved with this problem.
You should EasyBCD > BCD Backup/Repair > Reset BCD.. > Perform Action.
DO NOT REBOOT
EasyBCD will warn you not to reboot your system without further action, but you'd be amazed at how many people ignore the warning and come here complaining that EasyBCD broke their PC saying "I didn't think it meant it !"
At this stage you've reinitialized the BCD, i.e. It's empty.
Now you must put an entry back for W7.
EasyBCD > Add new entry > Type: "Vista/7/8" Name: "Whatever you want it to say in the boot menu" Drive: "C:\" > Add entry
EasyBCD > Edit boot menu > check that your Windows 7 entry is there as the sole entry.
NOW you can reboot safely, not before.
You can delete boot.ini and NTLDR if you find them hanging around on your C disk, they're just detritus left over from XP.
 
#9
Hi Terry,
Thanks a great deal. Finally, it works...No more windows XP showing up in the boot.
I am thankful for your excellent support.
Luke