I think I just need a simple correction in Win7's BCD

#1
Greetings to all!

I just added Ubuntu 10.04 in my multi-boot-Windows system, and I used EasyBCD (1.7.2) to add it into my Win7's boot menu ... but selecting Ubuntu in that menu just quickly drops me off at a GRUB prompt with "Error 8: Kernel must be loaded before booting" being displayed.

Here is my setup:

>> Three hard drives (2 PATA and 1 SATA)
>> Win98-Win2k-WinXP on first PATA drive
>> Second PATA drive used for page files and storage
>> Win7 and Ubuntu on SATA drive
>> Ubuntu is most-recent (last) installation
>> All Win systems booting fine both before and after addition of Ubuntu

Suspected cause of problem:

I ran EasyBCD while in Win7 with Win7 hijacking the letter "C" and calling my system drive something else.

My guess at a solution:

Change "R" to "C" in EasyBCD's Ubuntu entry in Win7's BCD.

Am I even close?!

If so, I do not know how to edit that "R" into a "C", and I will need someone to walk me through actually doing that.
 

Attachments

Last edited:
#3
... selecting Ubuntu in that menu just quickly drops me off at a GRUB prompt with "Error 8: Kernel must be loaded before booting" being displayed ...
... after typing "boot" and pressing "Enter" at that prompt, I forgot to add.

In any case, using the newer version of EasyBCD to remove the previous menu entry and adding a new entry with GRUB2 being referenced still leaves me with the same result ... but now I see less activity along the way. I now very briefly see "Starting (something)" in the corner of my screen just before GRUB appears, but there previously seemed to be something more than that happening just before GRUB appeared.

During my use of EasyBCD, other entries this time appeared as also being in "R", but my screen shot from BCDEdit shows they are in "C" in Win7's BCD. So, I still believe I just need to make that edit in my Win7's BCD.

Edit: I am wrong there. I used EasyBCD to change "R" to "C" and received a Windows "selected entry missing or corrupt" error.

Note: I also tried using "legacy GRUB" in the EasyBCD entry, and that did get me farther along into something being loaded and where I ended up seeing "Error 15: File not found" right after "find --set-root --ignore-floppies /grub/grub.conf" had been displayed.

Other notes:

I had definitely unchecked "Add boot" at Step 8 during the Ubuntu 32-bit DeskTop installation process.

I had installed Mint in a different location and used the older version of EasyBCD to add its entry in this same machine with Win7 a few months ago, and that worked fine at that time.

... and I thank you very much for your time!
 

Attachments

Last edited:
#4
Ah, please excuse ...

My problem has been that of not getting the switches and GRUB selection right during installation and while using EasyBCD. I am now here in an installed copy of Mint 8, and I have corrected my boot trouble by having Mint's installer place its boot loader on Mint's "/" partition, then letting EasyBCD know that loader actually *is* there.

Just to be sure about my trouble with booting Ubuntu, I am now going to go ahead and install it (Ubuntu) behind Mint and in the same manner to see whether doing so takes care of the problem I brought to you here ... and I suspect it will.

I thank you for your time and I appreciate now having your newer version of EasyBCD!