invalid boot.ini at boot

#1
I had a dual boot of Windows XP & 7 with xp on the first partition of one HDD (Hitachi) & 7 on the first partition of another (Western digital). I decided to clean install xp and then use EasyBCD to recreate the win7 bootloader to get win7 running again. I followed the instructions at Recovering the Windows Bootloader with EasyBCD - EasyBCD - NeoSmart Technologies Wiki. But now not only is there no win7 option at boot but also before xp boots it says 'invalid boot.ini booting from c:\windows' and then continues to boot normally. (I also later tried copying the win7 image to the second partition on the Hitachi drive and used Easybcd to try to get it onto the boot menu but that too was no good.)

How can i get back win7 and get rid of the invalid boot.ini message?
 

Terry60

Knows where his towel is.
Staff member
#2
Which HDD has higher priority in the BIOS boot sequence ?
Where were the W7 boot files before you reinstalled XP ?
Can you see a "bootmgr" file and a \boot folder anywhere since you repaired the boot (set folder options thus to unhide them)
 
#3
Which HDD has higher priority in the BIOS boot sequence ?
The Hitachi HDD - the one with xp (and now an image copy of w7 as well)
But Disk mgt sees Hitachi as Disk 1 (see attached jpg, i have named the Hitachi partitions as HITx and WD as WHx)

Where were the W7 boot files before you reinstalled XP ?
I don't remember that, but when i got this box i installed xp and then win7

Can you see a "bootmgr" file and a \boot folder anywhere since you repaired the boot (set folder options thus to unhide them)
No bootmgr but in c: (xp partition) but there is a boot folder (which got created after I used EasyBCD) in which there's BCD and BCD.log
In the old win7 partition, bootmgr is in \Windows\Boot\PCAT but there's no \boot folder at root level
 

Attachments

Terry60

Knows where his towel is.
Staff member
#4
I notice that the Hitachi HDD is much smaller than the WD. Is it an older IDE drive and the WD SATA, or are both SATA ?
I ask because there's confusion in the Disk Management output, when a mixture of devices exists, about the display order.
It might be a good idea to put the WD drive top of the HDD boot sequence, boot your W7 DVD and run "startup repair" (3 times), to recreate the W7 boot files in the W7 partition. (make sure the WD W7 partition is set active first).
When W7 is booting without the aid of the DVD, use EasyBCD to add an XP entry to the new BCD (auto-configure) to get your dual-boot back.
This will also enable you more easily to dispense with the services of XP in the future, if and when you no longer need it, without destroying your ability to boot W7 like this time.
 
Last edited:
#5
I notice that the Hitachi HDD is much smaller than the WD. Is it an older IDE drive and the WD SATA, or are both SATA ?
I ask because there's confusion in the Disk Management output, when a mixture of devices exists, about the display order.
It might be a good idea to put the WD drive top of the HDD boot sequence, boot your W7 DVD and run "startup repair" (3 times), to recreate the W7 boot files in the W7 partition. (make sure the WD W7 partition is set active first).
When W7 is booting without the aid of the DVD, use EasyBCD to add an XP entry to the new BCD (auto-configure) to get your dual-boot back.

ok thanks, but will the annoying xp 'boot.ini' message go away if i do what you suggest?

BTW, yes, the Hitachi HDD is an IDE drive.
 

mqudsi

Mostly Harmless
Staff member
#6
Yes. That message is because you have the wrong bootsector code installed.